RPi3 A+ won't boot attached to MMDVM open-source head

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Wed Mar 20, 2019 1:06 pm

Hello everybody,

Did anybody hit the case using RPi 3 A+ with this mmdvm modem:
Image

The Pi3 A+ boots without any problem while the modem is detached. When attaching the MMDVM board the RPi just staying on black screen and nothing happen. The problem is that I cannot connect to RPi console to see what happen before the display.

I try with RPi 0 and the board and RPi connected booting without any trouble. Is that something related pi-start distro or some HW issue between 40 pin connector and MMDVM head. I cannot find any difference between GPIO connector of Pi0 and A+

Thanks for your assistance.

Regards,
Alex

User avatar
KE0FHS
Posts: 1106
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by KE0FHS » Wed Mar 20, 2019 1:45 pm

Hi Alex, I'm not familiar with that board, but one basic thing: the RPi 3A+ (and 3B+), which are designed for the Stretch version of Raspbian OS, require the new version of Pi-Star, currently available as release candidate version 4.0.0-RC3: http://www.pistar.uk/beta/. Previous versions of Pi-Star (3.4.x) won't run on those two RPi boards. If you need to upgrade from 3.4.x to 4.0.0, see these instructions for the easiest method:
https://amateurradionotes.com/pi-star-u ... -to-v4.htm

FYI: There are many people running the release candidate and finding that it works quite well. I've got it installed on five hotspots that are based on the RPi 3A+ with ZUMspot and MMDVM_HS_Hat boards, and I really like the combination.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Wed Mar 20, 2019 3:13 pm

Hi Toshen,

Yes, exactly the same version I install yesterday. With the stable version RPi 3 A+ alone didn't boot. I try stable version weeks ago. Then I took the last version and the result is - RPi3 A+ booting without attached MMDVM head. After installing the MMDVM the RPi just stay on a black screen and nothing happen.

If someone hit such case I'll be happy to learn how to resolve it by myself.

User avatar
KE0FHS
Posts: 1106
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by KE0FHS » Wed Mar 20, 2019 3:23 pm

Have you asked the manufacturer of the board whether they have a firmware update available so that it will support being used with a RPi 3A+ or 3B+? Otherwise, suggest you consider using a RPi 3B (not +), which is based on the same version of the Raspbian OS as the Zero W.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Wed Mar 20, 2019 3:44 pm

Actually not yet. Thanks for the remark.
Will do that.
However, I keep them in touch with the status here. Probably they also read also this thread.

just check currently booted RPi 0 and yes confirm the release are the latest

Code: Select all

[email protected]'s password: 
Linux pi-star 4.14.79+ #1159 Sun Nov 4 17:28:08 GMT 2018 armv6l

╔═══════════════════════════════════════════════════════════════════════╗
║                                                                       ║
║           ██████╗ ██╗      ███████╗████████╗ █████╗ ██████╗           ║
║           ██╔══██╗██║      ██╔════╝╚══██╔══╝██╔══██╗██╔══██╗          ║
║           ██████╔╝██║█████╗███████╗   ██║   ███████║██████╔╝          ║
║           ██╔═══╝ ██║╚════╝╚════██║   ██║   ██╔══██║██╔══██╗          ║
║           ██║     ██║      ███████║   ██║   ██║  ██║██║  ██║          ║
║           ╚═╝     ╚═╝      ╚══════╝   ╚═╝   ╚═╝  ╚═╝╚═╝  ╚═╝          ║
║                                                                       ║
╚═══════════════════════════════════════════════════════════════════════╝
The Pi-Star Dashboard can be found at one of the following locations:
http://pi-star/  http://pi-star.local/   http://fd3c:2741:7f32::19e/

Pi-Star's disk is read-only by default, enable read-write with "rpi-rw".
Pi-Star built by Andy Taylor (MW0MWZ), pi-star tools all start "pistar-".

                     Welcome to Pi-Star: v4.0.0-RC3

[email protected](rw):~$
For the firmware, I found in another thread in the forum here but I am really not sure my board which model or version is.

User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Wed Mar 20, 2019 8:47 pm

I found something not understandable to me.
I try to flash with the latest firmware using instructions at amateur radio notes by Toshen, KE0FHS and I get stuck. The modem appears as:

Code: Select all

[email protected](ro):~$ sudo pistar-findmodem 
Detected MMDVM    (GPIO): /dev/ttyAMA0 (MMDVM 20181212 (D-Star/DMR/System Fusion/P25/NXDN/POCSAG) 19.2000 Mhz (Build: 10:34:23 Dec 11 2018))
This didn't match to any of firmware available for MMDVM modems. Is that something completely new or some replica of real MMDVM

User avatar
KE0FHS
Posts: 1106
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by KE0FHS » Wed Mar 20, 2019 9:20 pm

Remember when I said that I'm not familiar with that board? Since there are no markings on the board identifying it, you probably need to get the information about which modem it is and which version of firmware it uses from the person who made the board or the vendor who sold it to you. Not all modem firmware can be updated through the script that is built into Pi-Star, so if your board doesn't support that, you should ask for the firmware upgrade procedure, as well.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Thu Mar 21, 2019 4:01 pm

The vendor was informed I think.
Will update once get some reasonable feedback. Can help in the future to someone.

dh3ybe
Posts: 42
Joined: Sun Aug 26, 2018 9:02 pm
Location: Germany

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by dh3ybe » Thu Mar 21, 2019 7:12 pm

Hi Alex,

beneath of the hints of Toshen, maybe the connection with the gpio pins may not be correctly mounted. A bad connection from the gpio connector to your dmr hat or switched pins during connecting the hat to the Raspberry Pi can lead to such an effect like not booting. Or the dmr hat may have a damaged/broken electronic device/circuit. But I am not a Raspberry Pi or electronic Guru.

Best Regards

Kai
dh3ybe

User avatar
lz3jy
Posts: 6
Joined: Fri Feb 01, 2019 3:10 pm

Re: RPi3 A+ won't boot attached to MMDVM open-source head

Post by lz3jy » Sat Mar 23, 2019 6:42 pm

Hi Kai,

I was thinking about such scenario, but the board booting with Pi Zero without any problem. Even more I dismount the connector then clean and resolder it back to original position.
Again perform the same test with Pi A+ - not booting. With Pi Zero has no problem.
Anyway I have several Processor boards and can use RPi 3 instead of A+ and will launch my project soon if I can't found a solution with Pi A+.

I want to prepare a hot spot for our local System Fusion repeater. Actually to replace the HRI with Computer, Windows etc. with something small which not need license and consume less power than conventional PC with Windows which I hate really.

Thanks for your idea indeed :)

Post Reply