Pi-Star v4.0.0 RC4 bugs? reports for consideration

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
Post Reply
Posts: 25
Joined: Mon Sep 10, 2018 4:31 am

Pi-Star v4.0.0 RC4 bugs? reports for consideration

Post by VK5BB »

I have been playing with Pi-Star for a number of months and have built a number of hotspots based on Raspberry Pi Zero's and Raspberry Pi 3B using V3.4.17_20-Jan-2019 and they have been most successful. I have successfully loaded ON7LDS Nextion drivers and run PD0DIB "Flags" images successfully (not on the Zero's, used the OLED screens.)

Just recently I have built another hot spot using the Raspberry Pi 3 A+, however I had to use the beta image V4.0.0 RC4 as the earlier image would not extract on the initial boot up. V4.0.0 RC4 extracted nicely and when set up drives a basic format Nextion Screen. However, when I tried to load ON7LDS Nextion driver, I had some problems, the first time it "broke" the operation and the Jumbo radio board would not receive or transmit, however the Pi-Star Dashboard was working OK.

On a second image build, (formated the SD card and reloaded the image) on rebooting the rPi A+, all seemed OK, however I found I could not link to my local gateway, VK5RWN? I could link to any reflector OK but not my local VK5RWN gateway or other gateways that I tried. The funny thing is that it would connect to REF023C, which is currently off air and not available. The problem here might be as i report below?

In the last couple of days I have been playing with a Pi Zero using N5BOC's Simplex radio board and again I used V4.0.0 RC4, no screens. The image extracted and the Pi Zero booted OK and once configured, it works a treat, very nice. However I have just found that again I could not link to my local gateway VK5RWN? I double checked the service and my older Pi-Star hot spot connects to VK5RWN without any problems. I am yet to try V3.4.17 on the Pi Zero/N5BOC version. Based on my previous Zero builds, I am expecting that it may work?

I am not sure what the problem is but a though has occurred to me?

I also have a SharkRF OPENSPOT V1 and of recent times it no longer connects to VK5RWN through either a command from the my radio or from the Dashboard. On communicating with the SharkRF team, they provided an address list that is used for reference to all reflectors and gateways for the purposes of linking the hot spot with the required destination. On reviewing the list, I found that the IP address for VK5RWN is out of date. The address changed early 2019 and it now best accessed using a domain address. From the Dashboard, I can manually change the address using the domain name and the SharkRF Openspot will connect to VK5RWN, but if change to another destination then try to come back to VK5RWN, I have to manually reload the correct address.

With the new Pi-Star V4.0.0 RC4 images, has there been any changes to how Pi-Star finds and selects the address of a destination Reflector or Gateway? The V3.4.17_20-Jan-2019 image allows me to link to VK5RWN but the later version does not.

73, Ben VK5BB
User avatar
Site Admin
Posts: 1357
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK

Re: Pi-Star v4.0.0 RC4 bugs? reports for consideration

Post by MW0MWZ »


All versions of Pi-Star use the same addresses, make sure you update from the dashboard and see if the problem persists, if it does, just let me know the hostname of the VK5RWN host and I will make very sure out host files are correct.

See thats how simple this is :)

To make sure I get it, please mail me at [email protected], that will make very sure I take care of it :)

73 de MW0MWZ
Post Reply