PI 4b+ (1g) won't see MMDVM

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 9:09 am

On my second duplex board thinking I got a bad one first go around. Set it up like my DMR Duplex hotspot, and PI-Star won't see the modem.

Sudo pistar-findmodem seems to get stuck in a search loop and just sits there.. Anyone else have this issue. Pi-star is 4.1.0 RC1 freshly burned to a new SD Card.
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by KE0FHS » Fri Aug 23, 2019 2:14 pm

Gene, there was some issue with 4.1.0-RC1 that caused Andy to pull it. Try downloading RC2.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 2:30 pm

Dang, how did I miss that??? Thanks Toshen, I'll get it tonight after work and report back.. worse that can happen is I have a spare duplex board.. lol
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 10:30 pm

Burned RC2.. No Bueno.. half the time it won't save settings. Having the WiFi connect issue that seems prevalent..

Put one of the Duplex boards on a Pi0w and it's up an running in 5 minutes..

Frustrating.. But I'll win yet...
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by KE0FHS » Fri Aug 23, 2019 10:35 pm

Yeah, the Pi-Star 4.1 WiFi issues are frustrating. I finally got things working somewhat better by using 2.4 GHz (and by making sure my router didn't try to kick the hotspot up to 5.0 GHz based on the capability of the RPi 4B board). Funny, because I'm using another RPi 4B to run Raspbian and am having to problem with it whatsoever.
Last edited by KE0FHS on Tue Oct 08, 2019 9:22 pm, edited 1 time in total.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 11:08 pm

Well, I'm making progress. Got it on WiFi, sudo pistar-update completed with no errors (finally) Still won't see modem #1.. Switching to Modem #2 (which worked on the Pi0w) to see if maybe I got a bad modem in #1.
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 11:17 pm

OK, well I'm about to give up. Both Duplex MMDVMs work fine on the Pi0w.. Neither will on the 4b+...

I'm off to order another 3b+.. Or maybe 2.. since I have 2 duplex MMDVMs doing nothing ;-)
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

n9mxq
Posts: 208
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Fri Aug 23, 2019 11:36 pm

And in another frustrating twist. Put my Zumspot on the 4b+ and it's all rainbows and unicorns... (Bangs head on desk)
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by KE0FHS » Sat Aug 24, 2019 1:28 am

n9mxq wrote:
Fri Aug 23, 2019 11:36 pm
And in another frustrating twist. Put my Zumspot on the 4b+ and it's all rainbows and unicorns... (Bangs head on desk)
Ain't life grand! :)
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
MW0MWZ
Site Admin
Posts: 1074
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by MW0MWZ » Sat Aug 24, 2019 12:49 pm

I've just been looking into this - there is a weird problem on the Pi4, not exactly sure what happens, but the long and short of it - is that *some* modems get stuck in reset and won't boot.

So far I have seen this on Zumspot GPIO and MMDVM HS_HAT boards.

I am working on a fix, in the short term, you can try updating Pi-Star and then running this on the CLI:

Code: Select all

sudo pistar-mmdvmhshatreset
You should get an output similar to:

Code: Select all

[email protected](ro):~$ sudo pistar-mmdvmhshatreset
Resetting Modem: MMDVM_HS_Hat (DB9MAT & DF2ET) for Pi (GPIO)
Warning: Stopping mmdvmhost.service, but it can still be activated by:
  mmdvmhost.timer
Reset Complete
[email protected](ro):~$
followed directly by your modem springing to life.

I need to add the Dual boards to the command, I only have simplex boards in there right now - I'll have that done in a few mins
Andy

73 de MW0MWZ
http://pistar.uk

Post Reply