PI 4b+ (1g) won't see MMDVM

Help with Raspberry Pi Foundation Boards (Raspberry Pi, Pi Zero, Pi Zero W, Pi A, Pi B, Pi B+, Pi2 B, Pi3 B, Pi 3 B+)
User avatar
MW0MWZ
Site Admin
Posts: 931
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by MW0MWZ » Sat Aug 24, 2019 12:51 pm

Dual boards now included...

Once I start getting some confirmations that this works for more people than just me, I'll make it part of the boot process :)
Andy

73 de MW0MWZ
http://pistar.uk

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Sat Aug 24, 2019 1:06 pm

Worked like a charm!!!

Thank you sir!
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Sat Aug 24, 2019 1:29 pm

After a few minutes, it lost the modem again and I had to reset...
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
MW0MWZ
Site Admin
Posts: 931
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by MW0MWZ » Sat Aug 24, 2019 3:49 pm

Keep testing for me, I need to run mine for longer too and see if it stays working or if the modem locks up/resets again.
After a reboot it will go back to not working (currently) but once we have it sorted - it should stay put.
Andy

73 de MW0MWZ
http://pistar.uk

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Sat Aug 24, 2019 5:13 pm

Since my last post it's been running like a champ. Modem is nice and steady. Haven't had to re-reset it again.
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Sun Aug 25, 2019 12:35 pm

Woke up this morning and it was still working fine..
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
MW0MWZ
Site Admin
Posts: 931
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by MW0MWZ » Tue Aug 27, 2019 11:06 am

Update and then Upgrade to 4.1.0-RC4 and this is now in the boot process, it ONLY takes effect on Pi 4 hardware at boot time.

Currently this cures VR2VYE Dual / HS_HAT Simplex and HS_HAT Duplex boards, and Zumspot Simplex.
If anyone runs into other boards that boot up stuck in reset/bootloader let me know pls.
Andy

73 de MW0MWZ
http://pistar.uk

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Tue Aug 27, 2019 11:26 am

Mine is a China spot duplex and uses the MMDVM_HS_DUAL HAT (DB9MAT, DF2ET & DO7EN) for Pi (GPIO) modem selection.
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

User avatar
MW0MWZ
Site Admin
Posts: 931
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: PI 4b+ (1g) won't see MMDVM

Post by MW0MWZ » Tue Aug 27, 2019 3:46 pm

That's covered :)
Andy

73 de MW0MWZ
http://pistar.uk

n9mxq
Posts: 199
Joined: Sun Apr 29, 2018 12:12 pm

Re: PI 4b+ (1g) won't see MMDVM

Post by n9mxq » Wed Aug 28, 2019 7:36 pm

It was working fine after the last restart I posted. Now it's been updated and hasn't had an issue since.

Oh, and since I ordered another duplex board thinking I had a bad one, I now have a spare duplex on a 3b+. So Win Win... hehe
Gene in Belvidere IL
Please don't email me with questions.
That's what these forums are for.
There's much more brainpower collected here
than I have alone.

Post Reply