on7lds l3 hmi wont compile

All things relating to the Nextion Screen(s)
Post Reply
KA3VGM
Posts: 9
Joined: Tue Nov 09, 2021 6:50 pm

on7lds l3 hmi wont compile

Post by KA3VGM »

downloaded the l3 hmi for My screen newest Nextion edito says okd version will convert then says index outside bounds of array and when i try 2 compile it says failed invalid font id and his tft on his sitw won't load in my screen says version 2 low anyone know the fix i'm not a programer
jinny ka3vgm
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: on7lds l3 hmi wont compile

Post by KE7FNS »

KA3VGM wrote: Tue Jan 11, 2022 3:12 pm downloaded the l3 hmi for My screen newest Nextion edito says okd version will convert then says index outside bounds of array and when i try 2 compile it says failed invalid font id and his tft on his sitw won't load in my screen says version 2 low anyone know the fix i'm not a programer
Old .hmi's that are floating around need the older versions of the software. A while ago Nextion decided to make a change where older files created with their older editors didn't work correctly with their newer editors.

So either use the .53 LTS version of the nextion editor (available on their website) or find another .hmi that is newer.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
KA3VGM
Posts: 9
Joined: Tue Nov 09, 2021 6:50 pm

Re: on7lds l3 hmi wont compile

Post by KA3VGM »

MY screen take a tft file from version 058 sats tft version too low'
i tried this posthttps://forum.pistar.uk/viewtopic.php?t=2014&p=9440
regening and replaceing all fonts still get invalid font id i want q layout m17 in it and i would like the pi cpu temp i like way some layouts display the country flag of the talking sation i have a duplex mmdvm abd a 3.5 screen does anyonw have an hmi that works with editor version 1.6
jimmy ka3vgm
ps i don't have facebook
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: on7lds l3 hmi wont compile

Post by KE7FNS »

KA3VGM wrote: Wed Jan 12, 2022 6:15 pm MY screen take a tft file from version 058 sats tft version too low'
i tried this posthttps://forum.pistar.uk/viewtopic.php?t=2014&p=9440
regening and replaceing all fonts still get invalid font id i want q layout m17 in it and i would like the pi cpu temp i like way some layouts display the country flag of the talking sation i have a duplex mmdvm abd a 3.5 screen does anyonw have an hmi that works with editor version 1.6
jimmy ka3vgm
ps i don't have facebook
I can't understand your post, take the extra time and post complete sentences and try to express your thoughts clearly.

The instructions I wrote on that thread are to fix the weird looking fonts, not fix an "index out of bounds" error. Like I said, download and install the .53 LTS nextion editor.

I don't know of any .hmi's that include M17. You will have to create your own by copying the NXDN page and making a few field name changes.

Most of the people discussing .hmi's for Nextion's are on the facebook group and there is only one place I know of that is open to the public and doesn't require facebook and that is PD0DIB's github. https://github.com/PD0DIB/Nextion_HAM-radio-screens
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
Post Reply