Nextion Display and Pi-Star 4.1.4 issues

All things relating to the Nextion Screen(s)
Post Reply
wl7cli
Posts: 2
Joined: Mon Feb 08, 2021 1:13 pm

Nextion Display and Pi-Star 4.1.4 issues

Post by wl7cli »

Hello,

I am having trouble with my Nextion Display not working after updating to Pi-Star 4.1.4 and could use some help. As long as I don’t select Nextion as my MMDVM Display my hotspot functions. Once I select Nextion as my display type the hotspot stops transmitting or receiving.

I installed the latest image of Pi-Star 4.1.4 on to a new Micro SD card. I first used SD Card Formatter to make sure it was clean then belenaEtcher to create the image. Went through all the configurations found that the Nextion driver was not installed. I installed the driver and selected Nextion display, port: /dev/ttyNextionDriver and Nextion Layout: ON7LDS L3 as I had been using prior to 4.1.4 and nothing, I could not connect by RF and nothing was showing in Gateway Activity either. I unselected the Nextion display and activity started for both RF and Gateway but nothing on the Nextion display. I then went to expert commands and compared my old configuration to the new and fond that under NextionDriver the port on the old had changed from modem to /dev/ttyAMA0 on the new. I changed that back and now my hotspot sends and receives RF and Gateway but nothing is showing on my Nextion screen.

For the Nextion driver I first did a uninstall and then a fresh install. This is the 2nd time I created a new image of 4.1.4

My setup is:
Raspberry Pi Zero W
ZUMSpot-Pi v0.4
Nextion 3.5 NX4832K035 connected to the 4 ZUMSpot headers
Pi-Star 4.1.4
KE7FNS
Pi-Star Team
Posts: 1797
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion Display and Pi-Star 4.1.4 issues

Post by KE7FNS »

wl7cli wrote: Wed Feb 10, 2021 2:00 pm I am having trouble with my Nextion Display not working after updating to Pi-Star 4.1.4 and could use some help. As long as I don’t select Nextion as my MMDVM Display my hotspot functions. Once I select Nextion as my display type the hotspot stops transmitting or receiving.
That is because there is a port conflict and you have two things trying to use one serial port and fighting each other.
wl7cli wrote: Wed Feb 10, 2021 2:00 pm I installed the driver and selected Nextion display, port: /dev/ttyNextionDriver and Nextion Layout: ON7LDS L3 as I had been using prior to 4.1.4 and nothing, I could not connect by RF and nothing was showing in Gateway Activity either.
That is the issue, you need to configure the port correctly BEFORE you attempt to install the Nextion Driver. The Nextion Driver warned you that it needed to be functioning correctly before continuing to install the Nextion Driver. That is the reason for displaying that warning message.

The port can ONLY be ONE of these two options BEFORE you install the Nextion Driver.

"modem" for Nextions connected to Nextion port on MMDVM_HS hats

or

"/dev/ttyUSBX" for USB/TTL adapters (where X is some integer depending on how many USB devices you have connected)

Then when you run the Nextion Driver installer it will then detect which connection and add the appropriate settings for the connection type.

I tested everything last night for another user in another thread and was able to get either connection working correctly in pi-star 4.1.4.

follow these instructions:
viewtopic.php?p=17202#p17202
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
wl7cli
Posts: 2
Joined: Mon Feb 08, 2021 1:13 pm

Re: Nextion Display and Pi-Star 4.1.4 issues

Post by wl7cli »

Hello,

I got it up and running, thanks for the help.

I re-formatted the MicroSD card and flashed it with Pi-Star 4.1.4
Inserted it into the RPi Zero W
Powered it up and connected and set my configurations and applied the changes
I have Radio/Modem Type: ZUMSpot-Single Band RaspberryPi Hat (GPIO)
MMDVM Display Type: Nextion, Port: modem, and Nextion Layout: ON7LDS L3
I transmit and receive on my HT and info is showing in Dashboard and Admin. Basic information is showing on my Nextion display, Date time, RX frequency, my Call sign/DMR ID. It also shows partial contact info.
Opened Expert SSH Access and logged in
Cd /tmp
git clone https://github.com/on7lds/NextionDriverInstaller.git
sudo NextionDriverInstaller/install.sh
install: Y
version 1.7 found to be installed
reboot: N

Repeated
Cd /tmp
git clone https://github.com/on7lds/NextionDriverInstaller.git
sudo NextionDriverInstaller/install.sh
install: Y
this time it installed version 1.9
reboot: Y

Nextion display is populating all fields and showing all contact info
KE7FNS
Pi-Star Team
Posts: 1797
Joined: Wed Apr 17, 2019 11:11 pm

Re: Nextion Display and Pi-Star 4.1.4 issues

Post by KE7FNS »

wl7cli wrote: Fri Feb 12, 2021 3:51 am I got it up and running, thanks for the help.
Glad you got it working.

Just for future users seeking help, the 2nd install is only for 4.1.2, and 4.1.4 images at the current time. Once the process of adding the Nextion Driver and all its services is finished to the base image it won't be necessary to install the Nextion Driver twice. Hopefully it will be soon.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
Post Reply