How to set the default baudrate on a Nextion.

All things relating to the Nextion Screen(s)
Locked
KE7FNS
Posts: 1664
Joined: Wed Apr 17, 2019 11:11 pm

How to set the default baudrate on a Nextion.

Post by KE7FNS »

You need a USB/TTL adapter that supplies 5 volts. Make sure TX on the Nextion goes to RX on the adapter, and RX on the Nextion goes to TX on the adapter.

(it is possible to use a com port on your computer directly, but you need to hook up TX, RX and GND, and then figure out a different way to supply 5 volts and ground to power the Nextion, since the com port doesn't supply 5 volts.)

Plug in the USB/TTL adapter and wait for the drivers to be installed. (some USB/TTL adapters from companies like FTDI or Prolific have drivers that will fail to work with cloned chips. If your adapter isn't working correctly that could be the reason.)
  • Open Nextion Editor
  • open any project
  • select debug
  • at the top change the send command dropdown from Simulator to Nextion device
  • click autoconnect.

once the display has connected
issue the one of the following commands in the left window panel (instruction input area) Be sure to press enter to issue the command.

enter the following if you want 9600 baud

Code: Select all

bauds=9600
or

enter the following if you want 115200 baud

Code: Select all

bauds=115200

Disconnect and reconnect the simulator and at the lower status bar area of the simulator window you should see the baudrate and the Nextion specific information for your screen. Confirm that the baudrate matches what you wanted set to default.

Note:: Make sure you don't confuse the command bauds= with baud=. bauds= sets the default baudrate at powerup, baud= sets the current baudrate until power is lost.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
Locked