IDLE logo on OLED

All things relating to OLED Screen(s)
Post Reply
w2rjr
Posts: 7
Joined: Sat Oct 13, 2018 11:55 pm

IDLE logo on OLED

Post by w2rjr »

I'm running PiStar 4.1.6 on a digital repeater with an 1.2'' OLED. In the last two weeks I noticed that when there is no activity the display now shows IDLE. I do have the screen saver turned off. Does anyone know how to turn it off ? Thank You
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: IDLE logo on OLED

Post by KE7FNS »

w2rjr wrote: Sun Dec 05, 2021 12:26 am Does anyone know how to turn it off ?
There isn't a way to turn the OLED off so it does not display anything while in use.

The LogoScreensaver parameter does not work like I think you are expecting. LogoScreensaver=1 displays a bitmap image or "logo" or banner across the top of the screen to indicate what mode it is currently in. Normally if you run LogoScreensaver=1 you want scrolling on also to prevent pixel burnin.

If LogoScreensaver is set to 0, it does not display any "logo" or banner at all, but any other text on the lower half of the display is unaffected and displayed as usual.

If you don't want the OLED to display things then you need to physically remove it from the hat. Pixel burnin is common and OLED's dim over time while being lit. The bonus is they only cost a few bucks to replace, so buy 10 and you'll be good to go for a year or so.

In a remote repeater it makes no sense to even have a display, nobody is going to be there to read it.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
w2rjr
Posts: 7
Joined: Sat Oct 13, 2018 11:55 pm

Re: IDLE logo on OLED

Post by w2rjr »

Thanks for the info. Just to be sure I explained it correctly, When the repeater is idle the OLED would be blank not off. When there is traffic the display would come on indicating the mode, callsign etc...which is the way I had it setup! now instead of a blank screen when the repeater is idle, it displays the word ILDE.. can that be turned off? Don't need a screen saver. thanks.
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: IDLE logo on OLED

Post by KE7FNS »

w2rjr wrote: Wed Dec 08, 2021 11:46 am can that be turned off?
I already explained it in detail in my previous post.
w2rjr wrote: Wed Dec 08, 2021 11:46 am Don't need a screen saver.
It isn't a screen saver in the traditional sense.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
M1DNS
Pi-Star Team
Posts: 976
Joined: Thu Apr 05, 2018 5:30 am

Re: IDLE logo on OLED

Post by M1DNS »

Idle isnt the screen saver.

Idle is it giving you the mmdvmhost status.
Just like it gives you info when theres traffic.

Theres no option to drop idle, not unless you rewrite that part of mmdvmhost code.

Sent via smoke signals from my SM-G935F M1DNS (Admin)



Andrew M1DNS.
Pi-star Admin Team.
Post Reply