Page 1 of 1

Zumspot firmware upgrade problem

Posted: Wed Mar 11, 2020 8:14 pm
by EB2AQH
Hi all,
I have bought in Amazon (Europe) a MMDVM hotspot running on a Raspy Zero W called "Vbestlife MMDVM Hotspot". The hotspot come already configured and I only need to create WIFI access and introduce my personal data.
I updated pi-star to the last verion 3.4.17 and everything OK.
Problems started when I tried to upgrade firmware.
In the dashboard apperaed ZUMSpot hat ver. 1.3.7 and I tried to go to lastest one using
sudo pistar-zumspotflash rpi
Process finised OK and after restarting new version 1.47 aperars on the Dashboard but with no TX and RX.
I repeated the upgrade process many times wihout positive results.
I don't know if its possible to downgrade firmware to previous version 1.37.
Anyway I made a trial upgrading firmare with command
sudo pistar-mmdvmhshatflash hs_hat
Process also finished OK and in the dashboard nnow I have HS_Hat v.1.4.17 version working OK.
My questions are:
- Is possible to install two different firmare in the same board (ZUMSpot and HS_hat)?
- IS possible to downgrade to previous verision ZumSpot v.1.3.7 that came initially intalled?
Thanks for you support.
Inigo
EB2AQH

Re: Zumspot firmware upgrade problem

Posted: Wed Mar 11, 2020 10:11 pm
by KE7FNS
EB2AQH wrote:
Wed Mar 11, 2020 8:14 pm
- Is possible to install two different firmare in the same board (ZUMSpot and HS_hat)?
Yes. There are build configuration differences between the Zumspot firmware and the HS_Hat firmware.

https://github.com/juribeparada/MMDVM_H ... spot_RPi.h
vs.
https://github.com/juribeparada/MMDVM_H ... M_HS_Hat.h

Most MMDVM boards use the same microprocessor (STM32) so yes you can successfully flash a firmware that is not compatible with the board you are using.
EB2AQH wrote:
Wed Mar 11, 2020 8:14 pm
- IS possible to downgrade to previous verision ZumSpot v.1.3.7 that came initially intalled?
Yes, but that is highly not recommended. The simplest way would be to download the precompiled firmware for your board, and then flash it manually, you cannot use the built in pi-star scripts.

https://github.com/juribeparada/MMDVM_H ... tag/v1.3.7

Since you have it working on the HS_Hat firmware, don't worry about it and just leave it that way. You are better off running the latest release that includes new features and many bugfixes.

I suspect you have a Jumbospot board which isn't a Zumspot compatible configuration in the latest version of the firmware. Maybe in earlier versions (which I am not as familiar with) they were grouped under the same configuration settings which is why it reported ZumSpot v.1.3.7, but in a later version it has diverged into two separate configurations.

Re: Zumspot firmware upgrade problem

Posted: Thu Mar 12, 2020 7:09 am
by EB2AQH
Many Thanks for your answer and technical explanation.
You are right, better to leave as it is while it's working OK.
73's

Inigo
EB2AQH