Interface is down

Help and support for ZUMSpot Hardware
User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Interface is down

Post by KE0FHS » Mon Jul 16, 2018 7:41 pm

KM4UJP wrote:
Mon Jul 16, 2018 4:58 pm
How do I connect my computer to the pi-star by my regular WiFi?
I've been doing a bunch of testing for the past couple of hours. Before I answer your question, I want to share that my testing confirms the issue you're having. This is what I found:
  • After I deleted my network configurations from two different hotspots and then attempted to start over, I cannot connect via Auto AP (using hotspots and methods that previously worked for me). When I attempt to connect to the Auto AP access point, I can successfully enter the authentication password, but the wireless connection never successfully completes and I'm unable to connect to Pi-Star via my browser.
  • I cannot successfully connect my phone to Auto AP using 192.168.50.1 (but this is something I've never tried before, so I can't confirm that it previously worked).
  • After manually creating a wpa_supplicant file and copying to the root directory of the microSD cards for both hotspots, I started over. Once each hotspot had booted up, I was able to successfully connect to Pi-Star via my computer's browser with my computer connected to my normal WiFi network, and everything worked normally.
  • I cannot connect to my hotspots via my cellphone (using methods that previously worked for me). Using the app IP Tools: WiFi Analyzer, I could see that each hotspot was able to successfully connect to my phone's hotspot, but I couldn't connect to Pi-Star in my phone's browser using either http://pi-star.local/ or the IP address of the connected hotspot.
  • This is not a ZUMspot issue, but it does affect my ZUMspot hotspot. One of the hotspots I tried uses a ZUMspot Pi Board, but the other one uses a genuine MMDVM_HS Hat, and both hotspots have the same issue. Both are on the latest Pi-Star version 3.4.16, and both are updated to firmware version 1.4.1 (updated via Pi-Star and using: https://github.com/juribeparada/MMDVM_HS). I don't know how to troubleshoot past this point. I guess it could be an issue with the 1.4.1 firmware, or it could be an issue with most recent version of Pi-Star.
Okay, to answer your question. Here's how it works for me:
  • I create a fresh image on my hotspot's microSD card using Etcher running on a Windows 10 laptop. When I do this, I ignore any system messages that I should format the card (before or after I burn the image). I let Etcher take care of everything, including formatting the card and verifying the image once it has been burned to the card.
  • I create a wpa_supplicant.conf file using Notepad++ (saved as a plain txt file with the .conf extension). Since I have both a home and phone hotspot network that I want to be able to connect to, I use the format quoted below, which prioritizes the mobile network.
  • I eject the microSD card from the laptop, insert it into the hotspot's RPi, and power up the hotspot.
  • After about a minute and 40 seconds or so (it takes a bit longer for me since the hotspot has to try to connect to my cellphone hotspot (which is off) before it can connect to my home network), I open my browser on my computer (I can successfully use either a Mac and the Windows laptop for this) and enter the Pi-Star URL: http://pi-star/ for Windows and http://pi-star.local/ for Mac.
  • After a few seconds, the Pi-Star dashboard opens. If it's a totally fresh installation, I go to the configuration page and enter my settings BUT I DON'T NEED TO DO ANYTHING FURTHER WITH WIFI AT THIS POINT SINCE IT'S ALREADY WORKING.
  • I apply my changes and just to be on the safe side, reboot Pi-Star. And then I start using it as a hotspot.
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
ap_scan=1
fast_reauth=1
country=JP
network={
ssid="MobileHotspotNetworkName"
psk="MobileHotspotNetworkPassword"
id_str="0"
priority=100
}
network={
ssid="WirelessHomeNetworkName"
psk="WirelessHomeNetworkPassword"
id_str="1"
priority=99
}
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KM4UJP
Posts: 15
Joined: Fri Jul 13, 2018 1:36 pm

Re: Interface is down

Post by KM4UJP » Mon Jul 16, 2018 8:05 pm

Here is my wpa file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
ap_scan=1
fast_reauth=1
country=JP

network={
ssid="ATT4QYh6np"
psk="2p5isg7tr2tc"
id_str="0"
priority=100
}

I tried another SD card and got the same results...

I am wondering why when I enter the IP address that the pi can not be found.

KM4UJP
Posts: 15
Joined: Fri Jul 13, 2018 1:36 pm

Re: Interface is down

Post by KM4UJP » Mon Jul 16, 2018 8:09 pm

My phone sees the pi-star network but it can not obtain the IP address.

Maybe my Pi is not working??

KM4UJP
Posts: 15
Joined: Fri Jul 13, 2018 1:36 pm

Re: Interface is down

Post by KM4UJP » Mon Jul 16, 2018 11:08 pm

My iPad sees the Pi just fine and logs in to the Dashboard.

I just ordered a new Pi Zero W from Amazon.

Hopefully the Pi is the problem.

KM4UJP
Posts: 15
Joined: Fri Jul 13, 2018 1:36 pm

Re: Interface is down

Post by KM4UJP » Mon Jul 16, 2018 11:37 pm

Would it matter that my wifi analyzer shows the pi-star as being on channel 6, while my WiFi is on Channel 9??

KM4UJP
Posts: 15
Joined: Fri Jul 13, 2018 1:36 pm

Re: Interface is down

Post by KM4UJP » Tue Jul 17, 2018 1:21 am

HURRAY....I got it working!!!

I was able to find out the ip address of the pi and through my router.

Once I logged in through the ip address, everything works!!!

My four days of struggle are over.

Thanks to everyone who offered advice and support.

User avatar
W1KMC
Posts: 96
Joined: Wed May 02, 2018 8:34 pm
Location: Bangor, ME USA
Contact:

Re: Interface is down

Post by W1KMC » Tue Jul 17, 2018 1:29 am

Once in the dashboard -- note the HOSTNAME, normally pistar (or pi-star [ I changed mine as I was working on a friend's at the same time] ) and you can just go to a browser and type http://pi-star/ and you should see the dashboard also -- what you type in the browser is what is in the HOSTNAME field [Windows is as above, if you have Apple stuff use http://pi-star.local/ and it should work]

On tablets and phones , use the IP address only as Android won't go looking for pi-star.

Just make sure the pi-star and the computer - tablet - phone - whatever, are all on te same network or none of this will work. :-)
I am no developer, guru, expert, nor do I claim to be or want to be. All advice I give is purely from experience and my efforts to help others.

W1KMC - Kevin M Carman
Bangor, ME
Jumbospot on a Pi0W
DMR 3123142 & 3123143
HHUS Trunk Ext 4329

W4AFK
Posts: 4
Joined: Sun Sep 09, 2018 5:54 am

Re: Interface is down

Post by W4AFK » Sun Sep 09, 2018 5:15 pm

I "had" a very similar problem yesterday as I was setting-up my new ZumSpot.

I was powering it from the computer and no matter what I did (USB port or PWR port), it would NOT connect to my WiFi. It stayed in AP mode.

For the heck of it I connected my ZumSpot to a phone charger and after the reboot it immediately connected to my WiFi.

I don't know if this is relevant but I wanted to share as I could not find a solution in any of the documentation or PPT presentations. If the above is really a factor then IMHO this should be written in the PPT and elsewhere :-)

KD8ZSK
Posts: 2
Joined: Sun Nov 18, 2018 12:13 pm

Re: Interface is down

Post by KD8ZSK » Tue Nov 20, 2018 1:29 am

Play the lottery for a better chance! 192.168.50.1 is in the private IP range, there are thousands of options as to the IP assigned by an AP. To get the actual IP of the spot access your wireless AP web page and review the list of clients. The device name is likely your call sign, use the IP next to it. Each AP is different.

Clear Skies!
AP Sample.JPG
AP Sample.JPG (20.02 KiB) Viewed 1263 times

Post Reply