Pi-Remote commands not working

General support for the Pi-Star System
ke4qdc
Posts: 5
Joined: Mon Apr 16, 2018 1:39 pm

Pi-Remote commands not working

Post by ke4qdc » Thu Apr 26, 2018 10:45 am

I have tried every combination I can think of between TG's and private or group contact. I have my .ini file setup to what I think is correct. I have the pi-star remote tab lit up on my admin page indicating it on. I am only using dmr and have the TG's 8999999 through 8999996 set up as private contacts in my contact section. I have setup channels for each in a separate zone. I never see any action from the dashboard when I send any commands. I do a refresh as soon as I send a command and I never catch the pi in a restart or rebooting mode. Any thing to check? Here is my file


[enable]
# Should PiStar-Remote be Enabled? (true|false)
enabled=true

[keeper]
# Keepers Information
callsign=ke4qdc



[dmr]
# TG commands
svckill=8999999
svcrestart=8999998
reboot=8999997
shutdown=8999996

9M2TPT
Posts: 10
Joined: Thu Apr 12, 2018 2:52 am

Re: Pi-Remote commands not working

Post by 9M2TPT » Thu Apr 26, 2018 12:03 pm

Have you tried using all uppercase letters for your callsign? I believe the pi-remote does a direct comparison between your callsign and the one coming from the log.
73 de Mohd/9M2TPT

ke4qdc
Posts: 5
Joined: Mon Apr 16, 2018 1:39 pm

Re: Pi-Remote commands not working

Post by ke4qdc » Thu Apr 26, 2018 12:20 pm

No I haven't but I will give it a shot

Thanks

ke4qdc
Posts: 5
Joined: Mon Apr 16, 2018 1:39 pm

Re: Pi-Remote commands not working

Post by ke4qdc » Fri Apr 27, 2018 3:46 pm

All caps on the callsign did the trick for me. Thanks everyone

MW0MWZ
Site Admin
Posts: 304
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Pi-Remote commands not working

Post by MW0MWZ » Sat Apr 28, 2018 11:02 am

The python script that handles remote commends is pretty smart in some ways, and pretty dumb in others, it looks for an exact match of the callsign, so yes case does matter :)
Andy

73 de MW0MWZ
http://pistar.uk

WB2KWC
Posts: 9
Joined: Sun Apr 15, 2018 2:15 am
Location: Massapequa, NY

Re: Pi-Remote commands not working

Post by WB2KWC » Sun Apr 29, 2018 12:44 am

In software that I have worked on I convert the text to upper case before doing the compare. I believe that Python has a built in upper() function.

Ken WB2KWC

ng0n
Posts: 2
Joined: Sat Apr 28, 2018 11:30 pm

Re: Pi-Remote commands not working

Post by ng0n » Tue Jun 12, 2018 3:34 pm

I have been UNABLE to get REMOTE to work on my TYT MD-380.
I am running PI-Star ver 3.4.15

The only way I can get the message into my Jumbospot is w/ Group Call.
When I use Private Call , I never link up to Jumbospot.. never transmits ...just get a TONE
on the handset. What the devil is wrong ??

Yes, I have enabled set to true
Yes, i have keeper as NG0N (matching exactly my DMR Callsign.)

HELP !!

/ Frank NG0N

ng0n
Posts: 2
Joined: Sat Apr 28, 2018 11:30 pm

Re: Pi-Remote commands not working

Post by ng0n » Wed Jun 13, 2018 9:03 pm

HOW TO SEND 'PI-STAR REMOTE COMMANDS' TO md380

Works with TYT MD380 pistar 3.4.15

1. Click into a channel that is not being used... make sure u are in the channel... (Parrot might work, haven't tried it yet)
2. Press GREEN button
3. Pres down arrow to UTILITIES
4. Press GREEN button
5. Press down arrow to Private Call
6. Press GREEN button
6. ENTER Remote Command u want. example: for Reboot make the screen read: 7999998 (hint use RED button to erase numbers)
7. Pres CONFIRM
8. Wait for the MD380 disply to go back to channel display AND be sure that Jumbospot is idleing...(rolling MMDVM display.
Press TRANSMIT for 3 seconds or so

IT SHOULD WORK. Watch Jumbospot and wait for -CLOSE-- display... When u SEE THAT you shou;d be HAPPY. :lol:

If you UNDERSTAND why this works when standard codeplug programming doesn't .. TELL US !!!

/ng0n

W8DSB
Posts: 2
Joined: Thu Jun 14, 2018 5:54 pm

Re: Pi-Remote commands not working

Post by W8DSB » Thu Jun 14, 2018 6:08 pm

So, I added these three TG's 8999998, 8999997, 8999996 in to my digital contacts. Added the contacts to three channels. Added the three changes into a zone named "PI". When I key up, the jumbospot shows the new TG in the display and on the dashboard however the command does not work.

Yes I enable remote
Yes I put the callsign in as capital letters match my callsign

I tried both as group call and private call TG's

I expected when I keyed with TG = 8999996 that it would just shutdown the PI but it keeps on running.

Thoughts?

W8DSB
Posts: 2
Joined: Thu Jun 14, 2018 5:54 pm

Re: Pi-Remote commands not working

Post by W8DSB » Thu Jun 14, 2018 6:44 pm

Wait, I think it is working now....when I change my contacts from group to private the radio software deleted the TG numbers. I reinstalled the TG's number with the TG set to private. the reboot display ~~close~~ on the screen. I don't see the shutdown doing anything.

Post Reply