run pi-star repeater without an internet connection?

General support for the Pi-Star System
Post Reply
PD0HOF
Posts: 2
Joined: Wed Mar 27, 2019 7:31 pm

run pi-star repeater without an internet connection?

Post by PD0HOF »

hi, im trying to run a MMDVM/pi-star repeater with no internet connection
however, when i start the repeater with no internet it won't work..
if i disconnect the internet after it booted all is fine.

sadly i dont have an internet connection at the location..

hope someone can help me :)

Pi-Star:4.1.4 / Dashboard: 20210322
kernel: 5.10.11-v7+
platform: Pi 3 Model B (1GB) - Sony, UK
firmware MMDVM:20190130

73,
PD0HOF
ZL3DMH
Posts: 6
Joined: Mon Jun 11, 2018 3:52 am

Re: run pi-star repeater without an internet connection?

Post by ZL3DMH »

Hi, I have tested and had this running fine on my repeater running Pi-star

It would only go into stand alone repeater if Auto AP is enabled (default) in firewall configuration section I found

So unless something has been changed or broken in pi-star the sequence is as below

1. MMDVM repeater powers up
2. trys connecting to any saved wi fi internet connections or cable connection ( about 2 minutes)
3. when no connections in 2. above then turns into a wifi hotspot to log into and configure (for about 2-3 minutes)
4. If not logged into after about the time period above in 3. then shuts off wifi hotspot login and MMDVM continues to start up and runs as standalone repeater.

Hope this still works and helps you.

Doug
ZL3DMH
KE7FNS
Posts: 1664
Joined: Wed Apr 17, 2019 11:11 pm

Re: run pi-star repeater without an internet connection?

Post by KE7FNS »

ZL3DMH wrote: Sun Apr 04, 2021 9:41 pm 4. If not logged into after about the time period above in 3. then shuts off wifi hotspot login and MMDVM continues to start up and runs as standalone repeater.
I don't think that is accurate. I don't believe the AutoAP ever shuts itself off after any amount of time. There is nothing that I'm aware of that ever turns the AutoAP off.

It makes sense that MMDVMHost doesn't work properly until AutoAP is active, because the AutoAP assigns a static IP address.

I'll have to do some testing with AutoAP later.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
KE7FNS
Posts: 1664
Joined: Wed Apr 17, 2019 11:11 pm

Re: run pi-star repeater without an internet connection?

Post by KE7FNS »

KE7FNS wrote: Mon Apr 05, 2021 3:40 am I'll have to do some testing with AutoAP later.
My test so far:

Code: Select all

wlan0_ap: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.50.1  netmask 255.255.255.0  broadcast 192.168.50.255
        ether aa:bb:cc:dd:ee:ff  txqueuelen 1000  (Ethernet)
        RX packets 294  bytes 23267 (22.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 500  bytes 109268 (106.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[email protected](ro):~$ uptime
 21:40:45 up 21 min,  1 user,  load average: 0.00, 0.00, 0.08
21 minutes after boot and the AutoAP is still accepting connections.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
Post Reply