NTP settings and time zone

General support for the Pi-Star System
User avatar
G0NMY
Posts: 14
Joined: Wed Apr 11, 2018 2:22 pm
Location: IO83VA
Contact:

NTP settings and time zone

Post by G0NMY » Mon Mar 11, 2019 11:51 am

Well I am struggling I have edited ntp-conf file
server ntp2a.mcc.ac.uk iburst
server ntp2b.mcc.ac.uk iburst
server ntp2c.mcc.ac.uk iburst
server ntp2d.mcc.ac.uk iburst

Ive edited the fake clock data file
Where or what else do I need to edit to get the correct time in pi-star?
Pulling my hair out as it appears to be 4 hours out USA maybe.

Any help appreciated
¡ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

User avatar
G0NMY
Posts: 14
Joined: Wed Apr 11, 2018 2:22 pm
Location: IO83VA
Contact:

Re: NTP settings and time zone

Post by G0NMY » Mon Mar 11, 2019 1:02 pm

Have sorted it now seems to be set up correct
I should of used
server 0.uk.pool.ntp.org
server 1.uk.pool.ntp.org
server 2.uk.pool.ntp.org
server 3.uk.pool.ntp.org

A quick edit of fakeclock data and a reboot seems to have done the trick
¡ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

k2dls
Posts: 37
Joined: Mon Aug 20, 2018 5:24 pm

Re: NTP settings and time zone

Post by k2dls » Mon Mar 11, 2019 1:25 pm

ntp does not actually control the timezone.

You can verify your timezone with:

timedatectl

You can list timezones available with:

timedatectl list-timezones

You can set your timezone with:

sudo timedatectl set-timezone ZONE (use the one from the list-timezones command that makes sense for you).

User avatar
w7efs
Posts: 206
Joined: Sun Apr 22, 2018 4:26 pm

Re: NTP settings and time zone

Post by w7efs » Mon Mar 11, 2019 4:04 pm

In addition to "timedatectl" you might want to investigate "dpkg-reconfigure tzdata" for timezone settings. The use of only tab, Enter and cursor keys minimizes the possibility of typographical errors.

User avatar
G0NMY
Posts: 14
Joined: Wed Apr 11, 2018 2:22 pm
Location: IO83VA
Contact:

Re: NTP settings and time zone

Post by G0NMY » Mon Mar 11, 2019 5:02 pm

k2dls wrote:
Mon Mar 11, 2019 1:25 pm
ntp does not actually control the timezone.

You can verify your timezone with:

timedatectl

You can list timezones available with:

timedatectl list-timezones

You can set your timezone with:

sudo timedatectl set-timezone ZONE (use the one from the list-timezones command that makes sense for you).
Yes I used timedatectl to find out that NTP wasnt running
and time zone has always been set to europe/london
My pi is always running 24/7 except when doing auto update at night.
Which may of accounted for the time error as I have no hardware clock on the pi/
Amyway I seemed to have muddled through and got it put right.
Time will tell! Ewwwwww! that was so lame :D :D
Thanks for the input though most appreciated
¡ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

k2dls
Posts: 37
Joined: Mon Aug 20, 2018 5:24 pm

Re: NTP settings and time zone

Post by k2dls » Tue Mar 12, 2019 1:25 pm

You're just lucky that you live in the GMT timezone...that is the default. :D

SP2ONG
Posts: 32
Joined: Fri Aug 10, 2018 5:05 am

Re: NTP settings and time zone

Post by SP2ONG » Tue Mar 12, 2019 3:54 pm

Pi-star is running on Debian. The following command uses to configure Time Zone:

rpi-rw
sudo dpkg-reconfigure tzdata

and you can set Time Zone

User avatar
KE0FHS
Posts: 739
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: NTP settings and time zone

Post by KE0FHS » Sat Mar 16, 2019 7:32 pm

SP2ONG wrote:
Tue Mar 12, 2019 3:54 pm
Pi-star is running on Debian. The following command uses to configure Time Zone:

rpi-rw
sudo dpkg-reconfigure tzdata

and you can set Time Zone
I'm curious: why would you do this instead of simply setting the correct time zone on the Pi-Star Configuration page in the General Configuration section by selecting your System Time Zone?
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
w7efs
Posts: 206
Joined: Sun Apr 22, 2018 4:26 pm

Re: NTP settings and time zone

Post by w7efs » Sun Mar 17, 2019 12:05 am

Port 80, the default Pi-Star access port, like other WKS (well-known services) is subject to orchestrated attacks from anywhere in the world. I'm not speaking for the OP, but many of us who are responsible for networks tend to disable port 80 forwarding and enable ssh on an obscure port other than default 22 || (pi-star) 2222 and do all configuration via command line.

Code: Select all

$ less /etc/services
might interest some.

M1DNS
Posts: 344
Joined: Thu Apr 05, 2018 5:30 am

Re: NTP settings and time zone

Post by M1DNS » Sun Mar 17, 2019 12:27 am

Each to his own. I guess there's no right or wrong way to do this, as it's a personal choice.

But, just like torsen I too wondered why not use the pistar config, given ur in there already setting other parameters. Personal choices I guess.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

Post Reply