Change config-->Apply Changes-->No joy-->Error

General support for the Pi-Star System
Post Reply
User avatar
g0bvz
Posts: 9
Joined: Wed Apr 11, 2018 12:14 pm

Change config-->Apply Changes-->No joy-->Error

Post by g0bvz » Sat Jan 26, 2019 8:00 pm

I changed the config of a hotspot and applied changes. The display scrolled up as per normal but the lower edge of the scrolled up bit had two lines of messages. The first said "unable to read source configuration files...", the second said "Please wait a few seconds and retry..." I retried several times with the same result.

Exactly the same happened with a second hotspot. On a third I just applied changes without having changed anything, with the same result. I tried the same thing using a different computer with the same result. All three hotspots are on 3.4.16 Dashboard 20190124, today's date being 26th Jan.

Is it possible an overnight update went wrong? I can't think of much else which would affect three largely unused hotspots simultaneously but I'm open to correction on this.

You can bet I won't be doing any configuration changes on the hotspots I use regularly: that'd put me hors de combat entirely.

User avatar
KE0FHS
Posts: 850
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Change config-->Apply Changes-->No joy-->Error

Post by KE0FHS » Sat Jan 26, 2019 8:53 pm

I'm running a ZUMspot + RPi Zero W with the latest dashboard updates applied (20190124), and have no issue when I make configuration changes and then Apply Changes. One difference is that I'm up to date with the latest upgrade (3.4.17).

Suggest you try running a Pi-Star Update followed by a Pi-Star Upgrade (best would be to do it via an SSH app like Termius or PuTTY). Then reboot and try Apply Changes again. If that doesn't work, try powering off and restarting the hotspot.

Other things to try if those steps don't work: Do a factory reset or burn a freshly downloaded image and try again.

Other things to think about: Do you have the correct modem selected? Is your radio/modem board firmware up to date (current version for ZUMspot/MMDVM_HS_Hats is 1.4.14.) Have you made any changes in the Expert Editor or manually to any of the core files?

Good luck!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

MW0MWZ
Site Admin
Posts: 886
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Change config-->Apply Changes-->No joy-->Error

Post by MW0MWZ » Sat Jan 26, 2019 9:46 pm

Something is up with one of the config files - either restore a backup, or use the "factory-reset" link from the config page to restore factory fresh configs.
Andy

73 de MW0MWZ
http://pistar.uk

User avatar
g0bvz
Posts: 9
Joined: Wed Apr 11, 2018 12:14 pm

Re: Change config-->Apply Changes-->No joy-->Error

Post by g0bvz » Sun Jan 27, 2019 1:45 am

Many thanks to all who replied. As it turned out, I pretty much used all suggestions.
1) Factory reset
2) SSH-ed in and then rpi-rw, sudo pistar-update followed afterwards by sudo pistar-upgrade
3)Reboot
4)Entered the settings all over again. Being weak, I cheated & copied the main info from the cards I use as a paper backup. (Who doesn't trust computers then? )

This worked where nothing else would. I ended up with Pi-Star 3.4.17 and hotspots that were back under control.

It came as a bit of a shock to have an issue with Pi-star, particularly with hotspots which had been fallow for a month or so. I can't remember the last problem I had. I still have no clue what caused this, but never mind, all's well that ends well.

Thanks again gents, I'm indebted to you.

User avatar
KE0FHS
Posts: 850
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Change config-->Apply Changes-->No joy-->Error

Post by KE0FHS » Sun Jan 27, 2019 2:01 am

That's good news! One note: it's not necessary to manually put Pi-Star into read-write mode using rpi-rw; the Update and Upgrade scripts automatically take care of that. (Sometimes for some reason, the Update script fails to return the system to read-only mode at the end, but that's another story.)
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

OH1SDR
Posts: 1
Joined: Wed Mar 27, 2019 1:10 pm

Re: Change config-->Apply Changes-->No joy-->Error

Post by OH1SDR » Thu Apr 18, 2019 9:26 am

I have the exact same issue with Pi-Star:3.4.17 / Dashboard: 20190402. If I even go to the expert/MMDVMHost -page, something happens to the configuration -files and I get the: "Unable to read source configuration files(s)".

Few noticeable things are, that after the previous situation, the OLED display in my MMDVM dual HS HAT says "-CLOSE-" and when going to the configuration page, all of the MMDVMHost Configuration are set to default and also Radio Frequency is set to 0 (all other parameters in General are ok). The parameters in the configuration file (etc/mmdvmhost) seem still to be correct.

Only way resolving this is to do a factory reset. For the moment, it is impossible to do any frequency calibrations.

73 de OH1SDR

Post Reply