Cannot (Permanently) disable APRS

General support for the Pi-Star System
Post Reply
K9EQ
Posts: 20
Joined: Wed Jan 09, 2019 4:07 am

Cannot (Permanently) disable APRS

Post by K9EQ » Mon Mar 04, 2019 5:02 pm

It seems like Pi-star really, really wants APRS data reported.....

Through the expert menus for MMDVM and YSF I set APRS Enabled to 0. Following updates or reboots it gets turned back on. I've edited the .ini files in /etc. Same result. The only way I have found to really kill it is to redirect the traffic to localhost in the hosts file - not the best way to solve the problem.

For the life of me I can't figure out what is rewriting APRS Enabled back to 1. It does seem to require a reboot and/or update to make it happen - but that is guaranteed to happen at least once a day.

This is a security issue as I DO NOT want any of my data being reported to aprs.fi. I've checked and it is showing up there. It seems to be picking up GPS data from my radio because I have bogus GPS data programmed into Pi-star.

73,
Chris, K9EQ

User avatar
KE0FHS
Posts: 1082
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Cannot (Permanently) disable APRS

Post by KE0FHS » Mon Mar 04, 2019 5:50 pm

Check out this post: viewtopic.php?f=5&t=557&p=2126#p2119
It's the only thing I found that actually stops location data from being reported to aprs.fi.

Edit: There's also an APRS-related setting in the Expert Editor > ircDDBgateway Quick Editor: aprsEnabled (0 = disabled; 1 = enabled).
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply