Changed password and now can't login to admin or configuration

General support for the Pi-Star System
Post Reply
ac7n
Posts: 3
Joined: Fri Jul 20, 2018 10:49 pm

Changed password and now can't login to admin or configuration

Post by ac7n » Fri Mar 08, 2019 5:23 am

Hi from Hawaii,

I was helping a friend set up his hotspot. He wanted to change the admin/configuration password from the default. He used the configuration menu to change his password to his call. When he rebooted, he can no longer access the admin or configuration pages. It asks for a username/password. It refuses.

I have put it on my system, and I can't get it to work either. I can SSH to his hotspot as user [email protected]i-star.local without problem. But, I can't authenticate to his admin or configuration pages.

Can someone offer some help?

Aloha,

Pascal ac7n

User avatar
KE0FHS
Posts: 1033
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Changed password and now can't login to admin or configuration

Post by KE0FHS » Fri Mar 08, 2019 2:12 pm

In which field did he change the password?
Did he reboot after changing the password?
Did he re-try the default password?
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

ac7n
Posts: 3
Joined: Fri Jul 20, 2018 10:49 pm

Re: Changed password and now can't login to admin or configuration

Post by ac7n » Fri Mar 08, 2019 6:28 pm

He changed the password from the bottom of the Configuration page. Yes, he has rebooted numerous times. Yes, we tried the original password.

I can SSH to the hot-spot using the new password. The dashboard comes up OK, but when we try to bring up the Admin or Configuration pages, it asks for authentication - but will not take any password which we enter.

We have tried more than one computer, and more than one browser, so it isn't a browser cache problem.

Pascal ac7n

User avatar
KE0FHS
Posts: 1033
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Changed password and now can't login to admin or configuration

Post by KE0FHS » Fri Mar 08, 2019 6:41 pm

If this happened to me, I'd start over by burning a fresh image.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
w7efs
Posts: 298
Joined: Sun Apr 22, 2018 4:26 pm

Re: Changed password and now can't login to admin or configuration

Post by w7efs » Fri Mar 08, 2019 7:29 pm

ac7n wrote:
Fri Mar 08, 2019 5:23 am
... I can SSH to his hotspot as user [email protected] without problem. But, I can't authenticate to his admin or configuration pages. ...
If the new password is being used for ssh, it sounds as if the system password was successfully changed but the web password wasn't. Go ahead and create the new web password manually at pi-star's "$" prompt:

Code: Select all

$ rpi-rw
$ sudo cat /var/www/.htpasswd
pi-star:$apr1$gQKNKz3z$uSPIA3YZW6iZfmsXXXXXXX                                                           
$ sudo htpasswd -c /var/www/.htpasswd pi-star 
# you'll be prompted for the new password, so match the one that works in ssh; it's less to remember
$ sudo cat /var/www/.htpasswd
pi-star:$apr1$gQKNKz3z$uSPIA3YZW6iZfmsLfyNOu1                                                           
Compare the two passwords, see if they're different and verify that the new one works on the Admin page..
Last edited by w7efs on Sat Mar 09, 2019 9:41 pm, edited 1 time in total.

ac7n
Posts: 3
Joined: Fri Jul 20, 2018 10:49 pm

Re: Changed password and now can't login to admin or configuration

Post by ac7n » Sat Mar 09, 2019 6:26 am

w7efs --

Thank you. This is exactly what I wanted and did not know how to do for the web password.

I will try this and have high expectations that it will work. Otherwise we will start from a new pi-star image.

Mahalo (thank you in Hawaiian)

Pascal ac7n

Post Reply