NTP settings and time zone

General support for the Pi-Star System
User avatar
w7efs
Posts: 298
Joined: Sun Apr 22, 2018 4:26 pm

Re: NTP settings and time zone

Post by w7efs » Sun Mar 17, 2019 12:36 am

One always wonders why the addition of a few extra characters is so difficult when typing "you're" or "your", instead of using D-Star terminology.

User avatar
KE0FHS
Posts: 1031
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: NTP settings and time zone

Post by KE0FHS » Sun Mar 17, 2019 12:44 am

w7efs wrote:
Sun Mar 17, 2019 12:05 am
Port 80, the default Pi-Star access port, like other WKS (well-known services) is subject to orchestrated attacks from anywhere in the world. I'm not speaking for the OP, but many of us who are responsible for networks tend to disable port 80 forwarding and enable ssh on an obscure port other than default 22 || (pi-star) 2222 and do all configuration via command line.
interesting. Thanks.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

M1DNS
Posts: 389
Joined: Thu Apr 05, 2018 5:30 am

Re: NTP settings and time zone

Post by M1DNS » Sun Mar 17, 2019 9:29 am

w7efs wrote:One always wonders why the addition of a few extra characters is so difficult when typing "you're" or "your", instead of using D-Star terminology.
Text talk. Gotta be down with the kids. Image

I guess having raised kids now in their mid twenty something's their text message formatting and compositing has started to rub-off.

Have urself a Gr8 day m8.

Andrew M1DNS, (Mod)




Andrew M1DNS.
Pi-star Admin Team.

User avatar
KE0FHS
Posts: 1031
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: NTP settings and time zone

Post by KE0FHS » Sun Mar 17, 2019 2:04 pm

M1DNS wrote:
Sun Mar 17, 2019 9:29 am
Have urself a Gr8 day m8.
The kids are changing the English language, for sure! Although I don't use it myself and don't even always understand all of it, I like it; it makes the language feel a bit more fluid.

I read the other day that emojis are now making their way into court documents. Perhaps someday emojis will be become a worldwide pictographic language.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

M1DNS
Posts: 389
Joined: Thu Apr 05, 2018 5:30 am

Re: NTP settings and time zone

Post by M1DNS » Sun Mar 17, 2019 2:18 pm

Emojis in official documents ?
I've not read that, but doesn't surprise me really.

Obvs. as this is a casual enviroment, I do find myself cutting corners on my grammar, punctuation and general composure within my text. In any other environment I can say I do adopt a much more professional approach.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

User avatar
G0NMY
Posts: 14
Joined: Wed Apr 11, 2018 2:22 pm
Location: IO83VA
Contact:

Re: NTP settings and time zone

Post by G0NMY » Mon Mar 25, 2019 12:21 am

KE0FHS wrote:
Sat Mar 16, 2019 7:32 pm
SP2ONG wrote:
Tue Mar 12, 2019 3:54 pm
Pi-star is running on Debian. The following command uses to configure Time Zone:

rpi-rw
sudo dpkg-reconfigure tzdata

and you can set Time Zone
I'm curious: why would you do this instead of simply setting the correct time zone on the Pi-Star Configuration page in the General Configuration section by selecting your System Time Zone?
My problem wasnt anything to do with the timezone as I first suspected Timezone was correct, however the time was about +4 hours out of sink.
The reason for this is that my pi-star has been running for a long time never turned off. The clock is nowhere near accurate or stable and I guess with the downtime during nightly upgrades as well the time got corrupted. Anyway all seems ok now :)
¡ʎɐqǝ ɟɟo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

User avatar
KE0FHS
Posts: 1031
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: NTP settings and time zone

Post by KE0FHS » Mon Mar 25, 2019 12:41 am

G0NMY wrote:
Mon Mar 25, 2019 12:21 am
however the time was about +4 hours out of sink.
The RPi uses Network Time Protocol (NTP) to synchronize its clock to UTC. In some cases, the time may get out of sync. In that case, you can simply restart the RPi and the NTP daemon should re-synchronize to UTC. If necessary, you can force a manual re-synchronization via Pi-Star. Log into Pi-Star via SSH, and then:

Code: Select all

sudo systemctl stop ntp.service
sudo ntpdate pool.ntp.org
sudo systemctl start ntp.service
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply