XLX not showing link if APRS disbaled in pi-star

General support for the Pi-Star System
Post Reply
Ki6anr
Posts: 8
Joined: Fri Apr 05, 2019 7:37 am

XLX not showing link if APRS disbaled in pi-star

Post by Ki6anr » Thu Apr 11, 2019 11:26 pm

So very interesting.... i was experimenting with connecting to xlx reflectors today.... more specifically xlx313.

Most people use the A module a sit is the “constellation” module connected to many other reflectors. For fun, I connected to xrf313E, changed to use reflector... and bingo! I showed up in the module E column as linked.. during this time... i realized that pi-star sends out my qth location through aprs... i found on this forum that you can disable this by going to expert>ircdbb and changing the aprsEnabled setting to ‘0’. once i did this...pi-star DID stop sending aprs pings out... however now, i cannot link to the xlx reflector. I link to xrf313E just as i did before... change to use reflector... key up.... i dont show up in the module e column and my transmission does not show up in last heard. this is NOT the case for other XRF reflectors (i tried xrf002A) for fun and it worked fine.

Just to test this theory out... I restored pi-star to a backup copy where aprs was still enabled... connected to xrf313E and once again i showed up... By the way... simply changing ‘aprsEnabled” back to ‘1’ does not correct the issue. only a restore to an old image. this is the ONLY change I have made between images.what. The. Heck?!

User avatar
w7efs
Posts: 302
Joined: Sun Apr 22, 2018 4:26 pm

Re: XLX not showing link if APRS disbaled in pi-star

Post by w7efs » Fri Apr 12, 2019 3:01 am

It would be helpful if you posted the relevant /var/log/pi-star/irc*log entries.

Ki6anr
Posts: 8
Joined: Fri Apr 05, 2019 7:37 am

Re: XLX not showing link if APRS disbaled in pi-star

Post by Ki6anr » Fri Apr 12, 2019 4:55 am

*Working pi-star Image* - aprsEnabled = 1, boots, auto connects to REF012A, I switch to XRF313EL, Key up CQCQCQ, I appear on the xlx dashboard under module E...

I: 2019-04-12 04:58:49.600 This software is for use on amateur radio networks only,
I: 2019-04-12 04:58:49.600 it is to be used for educational purposes only. Its use on
I: 2019-04-12 04:58:49.601 commercial networks is strictly prohibited.
I: 2019-04-12 04:58:49.601 Copyright(C) 2015-2018 by Jonathan Naylor, G4KLX and others
M: 2019-04-12 04:58:49.601 MMDVMHost-20181107_Pi-Star is starting
M: 2019-04-12 04:58:49.601 Built 09:24:10 Nov 12 2018 (GitID #9444eca)
I: 2019-04-12 04:58:49.601 General Parameters
I: 2019-04-12 04:58:49.601 Callsign: KI6ANR
I: 2019-04-12 04:58:49.601 Id: 1234567
I: 2019-04-12 04:58:49.601 Duplex: no
I: 2019-04-12 04:58:49.601 Timeout: 240s
I: 2019-04-12 04:58:49.601 D-Star: enabled
I: 2019-04-12 04:58:49.601 DMR: disabled
I: 2019-04-12 04:58:49.601 YSF: disabled
I: 2019-04-12 04:58:49.601 P25: disabled
I: 2019-04-12 04:58:49.601 NXDN: disabled
I: 2019-04-12 04:58:49.601 POCSAG: disabled
I: 2019-04-12 04:58:49.601 Modem Parameters
I: 2019-04-12 04:58:49.601 Port: /dev/ttyAMA0
I: 2019-04-12 04:58:49.601 Protocol: uart
I: 2019-04-12 04:58:49.601 RX Invert: no
I: 2019-04-12 04:58:49.602 TX Invert: yes
I: 2019-04-12 04:58:49.602 PTT Invert: no
I: 2019-04-12 04:58:49.602 TX Delay: 100ms
I: 2019-04-12 04:58:49.602 RX Offset: 0Hz
I: 2019-04-12 04:58:49.602 TX Offset: 0Hz
I: 2019-04-12 04:58:49.602 RX DC Offset: 0
I: 2019-04-12 04:58:49.602 TX DC Offset: 0
I: 2019-04-12 04:58:49.602 RF Level: 100.0%
I: 2019-04-12 04:58:49.602 DMR Delay: 0 (0.0ms)
I: 2019-04-12 04:58:49.602 RX Level: 50.0%
I: 2019-04-12 04:58:49.602 CW Id TX Level: 50.0%
I: 2019-04-12 04:58:49.602 D-Star TX Level: 50.0%
I: 2019-04-12 04:58:49.602 DMR TX Level: 50.0%
I: 2019-04-12 04:58:49.602 YSF TX Level: 50.0%
I: 2019-04-12 04:58:49.602 P25 TX Level: 50.0%
I: 2019-04-12 04:58:49.602 NXDN TX Level: 50.0%
I: 2019-04-12 04:58:49.602 POCSAG TX Level: 50.0%
I: 2019-04-12 04:58:49.602 RX Frequency: 444200000Hz (444200000Hz)
I: 2019-04-12 04:58:49.602 TX Frequency: 444200000Hz (444200000Hz)
M: 2019-04-12 04:58:49.603 Opening the MMDVM
I: 2019-04-12 04:58:51.614 MMDVM protocol version: 1, description: ZUMspot-v1.4.16 20190211 14.7456MHz ADF7021 FW by CA6JAU GitID #8cf46ca
I: 2019-04-12 04:58:51.634 Display Parameters
I: 2019-04-12 04:58:51.634 Type: OLED
I: 2019-04-12 04:58:52.035 D-Star Network Parameters
I: 2019-04-12 04:58:52.035 Gateway Address: 127.0.0.1
I: 2019-04-12 04:58:52.035 Gateway Port: 20010
I: 2019-04-12 04:58:52.035 Local Port: 20011
I: 2019-04-12 04:58:52.035 Mode Hang: 20s
M: 2019-04-12 04:58:52.036 Opening D-Star network connection
I: 2019-04-12 04:58:52.036 RSSI
I: 2019-04-12 04:58:52.036 Mapping File: /usr/local/etc/RSSI.dat
I: 2019-04-12 04:58:52.036 Loaded 14 RSSI data mapping points from /usr/local/etc/RSSI.dat
I: 2019-04-12 04:58:52.036 D-Star RF Parameters
I: 2019-04-12 04:58:52.036 Module: B
I: 2019-04-12 04:58:52.036 Self Only: no
I: 2019-04-12 04:58:52.036 Ack Reply: yes
I: 2019-04-12 04:58:52.036 Ack message: BER
I: 2019-04-12 04:58:52.036 Ack Time: 750ms
I: 2019-04-12 04:58:52.036 Error Reply: yes
I: 2019-04-12 04:58:52.036 Remote Gateway: no
I: 2019-04-12 04:58:52.037 Mode Hang: 20s
I: 2019-04-12 04:58:52.180 Interfaces Info
I: 2019-04-12 04:58:52.181 IPv4: lo:127.0.0.1
I: 2019-04-12 04:58:52.182 IPv4: wlan0:172.16.0.14
I: 2019-04-12 04:58:52.182 Default interface is : wlan0
I: 2019-04-12 04:58:52.182 IP to show: wlan0:172.16.0.14
M: 2019-04-12 04:58:52.182 MMDVMHost-20181107_Pi-Star is running
M: 2019-04-12 04:59:23.661 D-Star link status set to "Linking to REF012 A "
M: 2019-04-12 04:59:24.781 D-Star link status set to "Linked to REF012 A "
M: 2019-04-12 04:59:26.950 D-Star, received network header from KI6ANR /INFO to CQCQCQ via REF012 A
M: 2019-04-12 04:59:33.275 D-Star, received network end of transmission, 6.5 seconds, 0% packet loss, BER: 0.0%
M: 2019-04-12 04:59:42.120 D-Star, received RF header from KI6ANR /ID51 to XRF313EL
M: 2019-04-12 04:59:42.121 D-Star link status set to "Linking to XRF313 E "
M: 2019-04-12 04:59:42.146 D-Star, received RF end of transmission, 0.2 seconds, BER: 0.0%, RSSI: -47/-47/-47 dBm
M: 2019-04-12 04:59:43.046 D-Star link status set to "Linked to XRF313 E "
M: 2019-04-12 04:59:44.352 D-Star, received network header from KI6ANR /INFO to CQCQCQ via XRF313 E
M: 2019-04-12 04:59:50.657 D-Star, received network end of transmission, 6.5 seconds, 0% packet loss, BER: 0.0%
M: 2019-04-12 05:01:10.574 D-Star, received RF header from KI6ANR /ID51 to CQCQCQ
M: 2019-04-12 05:01:10.586 D-Star, received RF end of transmission, 0.1 seconds, BER: 0.0%, RSSI: -47/-47/-47 dBm


*THEN, the only thing i change is aprsEnabled = 0 under expert settings... hit apply... pi reboots...autoconnects to REF012A, I switch to xrf313E (i get audio readback “connected to...”), key up CQCQCQ... I dont show up in xlx313 dashboard??

M: 2019-04-12 05:06:31.871 D-Star link status set to "Linking to REF012 A "
M: 2019-04-12 05:06:32.967 D-Star link status set to "Linked to REF012 A "
M: 2019-04-12 05:06:35.108 D-Star, received network header from KI6ANR /INFO to CQCQCQ via REF012 A
M: 2019-04-12 05:06:41.430 D-Star, received network end of transmission, 6.5 seconds, 0% packet loss, BER: 0.0%
M: 2019-04-12 05:06:52.427 D-Star, received RF header from KI6ANR /ID51 to XRF313EL
M: 2019-04-12 05:06:52.428 D-Star link status set to "Linking to XRF313 E "
M: 2019-04-12 05:06:52.428 D-Star link status set to "Linked to XRF313 E "
M: 2019-04-12 05:06:52.892 D-Star, received RF end of transmission, 0.7 seconds, BER: 0.0%, RSSI: -47/-47/-47 dBm
M: 2019-04-12 05:06:55.098 D-Star, received network header from KI6ANR /INFO to CQCQCQ via XRF313 E
M: 2019-04-12 05:07:01.402 D-Star, received network end of transmission, 6.5 seconds, 0% packet loss, BER: 0.0%
M: 2019-04-12 05:07:07.313 D-Star, received RF header from KI6ANR /ID51 to CQCQCQ
M: 2019-04-12 05:07:07.415 D-Star, received RF end of transmission, 0.3 seconds, BER: 0.0%, RSSI: -47/-47/-47 dBm

Thats literally the ONLY thing changed. i can still connect to other xrf reflectos like XRF002A and show up on its dashboard/last heard.. but the XLX reflector like 313 does not work. Are they rejecting connections without aprs enabled? It still says im connected via the radio...but not showing up on the xlx313 dashboard or last heard...Sounds strange to me.... Weird thing is even if i go back in and change aprsEnabled back to ‘1’, it’s still broken until i restore to the original pi-star image i started with up top.

Im not great with linux.. i was able to ssh in and get through all the directories to find the log file but dont remember/cant get it open or view it.

User avatar
w7efs
Posts: 302
Joined: Sun Apr 22, 2018 4:26 pm

Re: XLX not showing link if APRS disbaled in pi-star

Post by w7efs » Fri Apr 12, 2019 6:35 am

Ki6anr wrote:
Fri Apr 12, 2019 4:55 am
... Are they rejecting connections without aprs enabled?
That same idea occurred to me after your first post about the issue, as every station in the "Last Heard" listing on http://xlx313.openstd.net/ has an aprs.fi link enabled, including yours slightly west of Anaheim.

I'm curious though, where did you acquire the connection information for XLX313, please? Even after a manual hostfile update here, we get "M: 2019-04-12 06:53:08: DExtra link to XLX313 E has failed to connect"
Weird thing is even if i go back in and change aprsEnabled back to ‘1’, it’s still broken until i restore to the original pi-star image i started with up top.
That is indeed "weird", makes no operational sense and requires further investigation.
Im not great with linux.. i was able to ssh in and get through all the directories to find the log file but dont remember/cant get it open or view it
You examined the log file, copy-n-pasted most of the relevant portions into your reply, so kudos to ya, mite.<grin>

Andy and crew have done a tremendous job in "dumbing down" Linux to a simple web interface for those who have historically innocently paid many hundreds of their money for something that's free with Linux, but at even greater cost to their learning. There are many of us that hope it will stimulate an interest in how a real computer OS (Linux) actually works, which is actually quite simple.

Ki6anr
Posts: 8
Joined: Fri Apr 05, 2019 7:37 am

Re: XLX not showing link if APRS disbaled in pi-star

Post by Ki6anr » Fri Apr 12, 2019 6:54 pm

so as i understand it.. “xlx” is just a protocol and theough research on the web you do not connect “to” xlx”... there are usually xrf reflectors that connect to the xlx protocol. to connect to XLX313 in particular all you do is change UR to “XRF313AL” to connect to XLX313 through pi-star. you can change A to any of its other modules...(A-E i believe)...

All I can think of is the xlx protocol requires aprs/location for some (very) odd reason... but i really do not understand why changing aprsEnabled back to ‘1’ does not resolve the issue and i have to reset my pi-star image to be able to connect again.

save a copy of your pi-star image and try it for yourself.
XRF313AL
CQCQCQ
Check XLX313 dashboard (you’ll be there)
disconnect
disable aprs in expert settings and repeat above (wont work)
restore pi-star image and all is well again

M1DNS
Posts: 402
Joined: Thu Apr 05, 2018 5:30 am

Re: XLX not showing link if APRS disbaled in pi-star

Post by M1DNS » Fri Apr 12, 2019 10:00 pm

Preferred protocol for use with XLX is DCS

DCS313AL



Andrew M1DNS, (Mod)


Andrew M1DNS.
Pi-star Admin Team.

Ki6anr
Posts: 8
Joined: Fri Apr 05, 2019 7:37 am

Re: XLX not showing link if APRS disbaled in pi-star

Post by Ki6anr » Fri Apr 12, 2019 10:31 pm

Thanks andrew i’ll try that when i get home and have access to my hotspot.

however, that doesnt address the issue of why it works just fine with aprs enabled and then simply does not with it disabled... more troubling is why it continues to “not work” after changing the aprsEnabled value back to 1... it wont work without restoring an entire backup copy with nothing different besides aprsEnabled being changed to 0.

in addition to stil being curious why the xlx reflector is not fully accepting the connection... this also tells me that changing aprsEnabled value to 0 is changing something else in the pi-star image because the problem persists after changing it back to 1... and the only way to resolve the issue is to restore to the pi-star image prior to changing the aprsEnabled value.

Post Reply