Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

General support for the Pi-Star System
Post Reply
K1MQ
Posts: 3
Joined: Wed May 15, 2019 7:53 pm

Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by K1MQ » Fri May 17, 2019 7:05 pm

I am trying to run the 3B+ board as a hotspot with V4.0 RC3. Everything seems to set up normally, but the Mode selected will not stay selected.
The YSF, DMR or any other mode indicator turns GREEN for about 3 seconds on the dashboard and then turns RED.
I have looked for something amiss in the files, but to no avail. I have tried several different modems, but nothing.
I know that some people have had success with this operation and others have not. Thanks for your assistance.
Gary K1MQ

MW0MWZ
Site Admin
Posts: 777
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by MW0MWZ » Fri May 17, 2019 9:42 pm

Have a look at the live log for clues - it might take a few mins to get the log output - but my best guess is that MMDVMHost can't talk to the modem, or the modem is on a satellite band frequency.
Andy

73 de MW0MWZ
http://pistar.uk

K1MQ
Posts: 3
Joined: Wed May 15, 2019 7:53 pm

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by K1MQ » Sat May 18, 2019 4:05 pm

Thanks Andy for the reply. Here are the last several entries of my Live Log. All above these lines look fine.
Gary

I: 2019-05-18 15:58:19.674 RX Frequency: 434800000Hz (434800000Hz)
I: 2019-05-18 15:58:19.674 TX Frequency: 434800000Hz (434800000Hz)
M: 2019-05-18 15:58:19.674 Opening the MMDVM
E: 2019-05-18 15:58:32.490 Unable to read the firmware version after six attempts

User avatar
KE0FHS
Posts: 795
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by KE0FHS » Sat May 18, 2019 4:27 pm

A couple possibilities:
  • Incorrect radio/modem selected, for example, a simplex radio/modem is selected but the hardware is duplex (or vice versa), or simply a mismatch. Verify your Radio/Modem Type selected in the General Configuration settings.
  • Firmware corrupted, very out of date, or the incorrect firmware for the radio/modem board. You may need to re-flash the firmware. Make sure the firmware you're flashing matches the board.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

MW0MWZ
Site Admin
Posts: 777
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by MW0MWZ » Sat May 18, 2019 4:51 pm

As above, so to start trouble shooting, what modem do you have connected (the service will not start without one), and what do you have selected in the dashboard for your modem?
Andy

73 de MW0MWZ
http://pistar.uk

KE7FNS
Posts: 94
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by KE7FNS » Sat May 18, 2019 8:36 pm

K1MQ wrote:
Fri May 17, 2019 7:05 pm
I have tried several different modems, but nothing.
That comment leads me to believe you don't have it configured for the correct serial port, because the odds of having several modems all having corrupted firmware is pretty much impossible to achieve.

What modems have you tried? And what modems and ports have you selected in the configuration?

K1MQ
Posts: 3
Joined: Wed May 15, 2019 7:53 pm

Re: Pi-3B+ Not locking in selected Mode w/ v4.0 RC3

Post by K1MQ » Sun May 19, 2019 8:48 pm

Got the unit operating. Nothing wrong with my configuration. Tried again another different MMDVM modem board and all is now fine.
Strange to have several that did not work. They still work on my 0W boards.
Thanks for the help.

Post Reply