Pi-Star Update hangs on Updating DV Binaries

General support for the Pi-Star System
User avatar
VK7HSE
Posts: 168
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Pi-Star Update hangs on Updating DV Binaries

Post by VK7HSE » Fri May 31, 2019 4:26 am

Glad you have it sorted...

Sent from my Pixel 2 XL using Tapatalk


User avatar
KE0FHS
Posts: 1031
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Pi-Star Update hangs on Updating DV Binaries

Post by KE0FHS » Sun Jun 02, 2019 3:20 pm

VK7HSE wrote:
Fri May 31, 2019 4:26 am
Glad you have it sorted...
Hey Scott, I just realized that using this workaround causes another problem that I previously posted about in the forum, but didn't realize the source of: after I run sudo git stash on /var/www/dashboard, the callsign in the header of Pi-Star changes to M1ABC, even though my callsign is properly entered in Configuration as the Node Callsign. (See: viewtopic.php?f=3&t=1826)

Since the only fix I've found to the incorrect callsign being shown in the header is flashing a new image and setting up Pi-Star manually (neither a factory reset or a fresh image using a backup works), this is a circular firing squad, because flashing a new image leaves me with the Updating DV Binaries bug again.

Any further ideas?

UPDATE: Applying changes on the Configuration page fixes the callsign disconnect. I can't believe I didn't try that previously since applying changes is one of my standard troubleshooting steps, but I guess I simply had a brain fart. Sorry about that!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
VK7HSE
Posts: 168
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Pi-Star Update hangs on Updating DV Binaries

Post by VK7HSE » Sun Jun 02, 2019 9:01 pm

Sometimes you just need to click on apply a few times to sort out the new additions

Sent from my Pixel 2 XL using Tapatalk


Post Reply