Time between modes to avoid QSO disruption.

General support for the Pi-Star System
Post Reply
KJ7IEG
Posts: 10
Joined: Thu Dec 19, 2019 6:20 pm

Time between modes to avoid QSO disruption.

Post by KJ7IEG »

I have a repeater using Pi-Star and MMDVM for both DMR and D-Star mode. I find out that my D-Star QSO would be disrupted by traffic initiated from a DMR TalkGroup over the network. Is there a way to set Pi-Star to prioritized RF traffic and stick to a mode for x minute before allowing different mode traffic to coming from the Net?
M1DNS
Pi-Star Team
Posts: 925
Joined: Thu Apr 05, 2018 5:30 am

Re: Time between modes to avoid QSO disruption.

Post by M1DNS »

in mmdvnhost expert you have settings for mode hang time and net hang time. Whilst it wont completly solve your issue altering the values there will help.

/admin/expert/edit_mmdvmhost.php



Sent from my SM-G935F using Tapatalk


Andrew M1DNS.
Pi-star Admin Team.
KJ7IEG
Posts: 10
Joined: Thu Dec 19, 2019 6:20 pm

Re: Time between modes to avoid QSO disruption.

Post by KJ7IEG »

My RF and NET hang time are all set to default 300 which I think is 5 minutes. I don't know if it will prevent MMDVM to switch modes while a QSO is going on.
M1DNS
Pi-Star Team
Posts: 925
Joined: Thu Apr 05, 2018 5:30 am

Re: Time between modes to avoid QSO disruption.

Post by M1DNS »

The longer the mode hang time you set, the longer it will hold that mode before it drops to idle, where any mode can pick it up.

The longer the net hold setting the longer it wil hold off on permiting another mode as it comes in over the net.

Sent from my SM-G935F using Tapatalk

Andrew M1DNS.
Pi-star Admin Team.
KJ7IEG
Posts: 10
Joined: Thu Dec 19, 2019 6:20 pm

Re: Time between modes to avoid QSO disruption.

Post by KJ7IEG »

In practices, I observed that a DMR traffic initiated from Brandmeister ignored any Hang time settings and switch modes right after I unkeyed my D-Star radio.
M1DNS
Pi-Star Team
Posts: 925
Joined: Thu Apr 05, 2018 5:30 am

Re: Time between modes to avoid QSO disruption.

Post by M1DNS »

Then you prob. have a setting somewhere set incorrectly.

Sent from my SM-G935F using Tapatalk

Andrew M1DNS.
Pi-star Admin Team.
KJ7IEG
Posts: 10
Joined: Thu Dec 19, 2019 6:20 pm

Re: Time between modes to avoid QSO disruption.

Post by KJ7IEG »

Any clues on what settings maybe triggering this?
User avatar
AA1PR
Posts: 11
Joined: Thu Jun 25, 2020 5:00 am

Re: Time between modes to avoid QSO disruption.

Post by AA1PR »

KJ7IEG wrote: Fri Nov 27, 2020 2:14 am Any clues on what settings maybe triggering this?
so odd its now months later & still no asnwer
Post Reply