Unable to Switch Back to 'rpi-ro'

General support for the Pi-Star System
M1DNS
Posts: 406
Joined: Thu Apr 05, 2018 5:30 am

Re: Unable to Switch Back to 'rpi-ro'

Post by M1DNS » Sat Feb 02, 2019 10:32 am

Guys if ur running a wired connection.
Try turning off pistar setup AP.
I've noticed recently if running wired the pi obvs isn't seeing a WiFi connection
and I believe pistar AP is holding the OS open to RW.


Were looking into this currently.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

K9DJN
Posts: 12
Joined: Mon Dec 24, 2018 6:25 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by K9DJN » Sat Feb 02, 2019 1:56 pm

M1DNS wrote:
Sat Feb 02, 2019 10:32 am
Guys if ur running a wired connection.
Try turning off pistar setup AP.
I've noticed recently if running wired the pi obvs isn't seeing a WiFi connection
and I believe pistar AP is holding the OS open to RW.


Were looking into this currently.

Andrew M1DNS, (Mod)
Agree wholeheartedly on this. I saw the same thing when I flashed a new image and didn't turn the Auto AP feature off. I use wired connections exclusively to my hot spots, so no need for wireless.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Sat Feb 02, 2019 2:17 pm

I never use a wired connection, but my hotspots are all opening in rw mode. I definitely leave Auto AP enabled, but I also use it occasionally.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

W4JEW
Posts: 35
Joined: Sun Aug 12, 2018 12:53 am

Re: Unable to Switch Back to 'rpi-ro'

Post by W4JEW » Sun Feb 17, 2019 5:45 pm

Very interesting! I will try this and report back with my findings.


Sent from my iPhone using Tapatalk Pro

User avatar
PE1BVU
Posts: 20
Joined: Mon Oct 22, 2018 8:17 am
Location: Amsterdam, the Netherlands
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by PE1BVU » Mon Feb 18, 2019 9:44 am

Hi all,

Tried this on my RPI 2b+ with DVMEGA Single HAT and a on my RPI Zero-W with Chinese single Jumbo HAT (running POCSAG).
After reboot the OS stays in "rpi-ro" after manual update or editing some files over SSH.

Seems to be the culprit....

pi-star_firewall-setting.jpg
pi-star_firewall-setting.jpg (48.46 KiB) Viewed 1166 times
pi-star_ssh.jpg
pi-star_ssh.jpg (74.44 KiB) Viewed 1166 times

I'll check my hotspots comming weeks to see if it's a stable fix.

73's
Adri

User avatar
PE1BVU
Posts: 20
Joined: Mon Oct 22, 2018 8:17 am
Location: Amsterdam, the Netherlands
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by PE1BVU » Tue Feb 19, 2019 5:04 am

Update:
All of my hotspots "survived" the nightly update! They all remain in "ro" mode and i can manualy "rpi-rw" and "rpi-ro" as much as i wish.

note:
As soon as i install / restart samba on one of the hotspots the problem is back... but i can live without samba.
I used samba to view the log-files, using my windows-box but i can do that over ssh with a small script.

Anyway, thanks everyone for the tips, the "Auto AP" is the solution for me and gives me a more secure feeling
on accidental power outages during mobile operation.

73's
Adri

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Tue Feb 19, 2019 2:30 pm

Good detective work, Adri. Thank you!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AF4FA
Posts: 29
Joined: Wed Jan 23, 2019 6:20 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by AF4FA » Wed Feb 20, 2019 1:12 am

I went into SSH this afternoon and did a pistar-update.
The following is what I saw on the screen.
This was after the debian lists showed

Reading package Lists... Done
could not get lock /var/lib/dpkg/lock- open (11: resource temporarily unavailable)
unable to lock the administration directory (/var/lib/dpkg), is another process using it?

after the rest of the updates were done the system remained in rw mode and would not go into ro mode no matter what I tried

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Wed Feb 20, 2019 1:54 am

AF4FA wrote:
Wed Feb 20, 2019 1:12 am
I went into SSH this afternoon and did a pistar-update.
The following is what I saw on the screen.
This was after the debian lists showed

Reading package Lists... Done
could not get lock /var/lib/dpkg/lock- open (11: resource temporarily unavailable)
unable to lock the administration directory (/var/lib/dpkg), is another process using it?

after the rest of the updates were done the system remained in rw mode and would not go into ro mode no matter what I tried
When that has happened to me previously, I was able to get past it by powering off my hotspot, then powering it back on, and then re-running a Pi-Star Update followed by a Pi-Star Upgrade.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AF4FA
Posts: 29
Joined: Wed Jan 23, 2019 6:20 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by AF4FA » Wed Feb 20, 2019 2:26 am

[/quote]

When that has happened to me previously, I was able to get past it by powering off my hotspot, then powering it back on, and then re-running a Pi-Star Update followed by a Pi-Star Upgrade.
[/quote]

I tried all that but it would not go back to ro mode. I had to rebuild the sd card from scratch.

Post Reply