Unable to Switch Back to 'rpi-ro'

General support for the Pi-Star System
User avatar
PE1BVU
Posts: 20
Joined: Mon Oct 22, 2018 8:17 am
Location: Amsterdam, the Netherlands
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by PE1BVU » Wed Feb 20, 2019 5:28 am

Reply to AF4FA
I tried all that but it would not go back to ro mode. I had to rebuild the sd card from scratch.
If this happens one of the pi-star scripts did not finish or hangs, causing the remount to malfunction.
Try to remount all:

Code: Select all

sudo mount -a
After that you should be able to "rpi-ro" and "rpi-rw" again.

73's
Adri

AF4FA
Posts: 29
Joined: Wed Jan 23, 2019 6:20 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by AF4FA » Wed Feb 20, 2019 4:30 pm

[/quote]

If this happens one of the pi-star scripts did not finish or hangs, causing the remount to malfunction.
Try to remount all:

Code: Select all

sudo mount -a
After that you should be able to "rpi-ro" and "rpi-rw" again.

73's
Adri
[/quote]

I will try that if it happens again. Thanks.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Wed Feb 20, 2019 4:47 pm

PE1BVU wrote:
Tue Feb 19, 2019 5:04 am
Anyway, thanks everyone for the tips, the "Auto AP" is the solution for me and gives me a more secure feeling
on accidental power outages during mobile operation.
Unfortunately, this ended up not working for me. I turned off Auto AP yesterday on one of my hotspots. I don't leave my hotspots on, and this morning, when I powered that hotspot back on, it started up in rw mode again. It wasn't stuck; I was able to set it into ro mode with rpi-ro. But there must be something else causing Pi-Star 4.0.0-RC3 to start up in rw mode.

EDIT: After I restarted the hotspot and manually set it in ro mode, I ran the Pi-Star Update script. This time it did get stuck in rw mode. I tried sudo mount -a, but that didn't help. I ran the Pi-Star Upgrade script, and that didn't help. I ran sudo reboot, but it didn't successfully reboot, so I powered off and back on. It started up in rw mode, but I was then able to manually set it into ro mode using rpi-ro.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

W4JEW
Posts: 35
Joined: Sun Aug 12, 2018 12:53 am

Re: Unable to Switch Back to 'rpi-ro'

Post by W4JEW » Thu Feb 21, 2019 5:04 pm

I also disabled Auto AP mode on my 3B running 4.0 RC3 and it is still stuck in read/write mode.

I installed ‘lsof’ to show which files were held open preventing the mount going back to read-only and the list was pretty long!

I am going to reimage the card and see if I get different results. If not, I’ll post the output from ‘lsof’.

User avatar
PE1BVU
Posts: 20
Joined: Mon Oct 22, 2018 8:17 am
Location: Amsterdam, the Netherlands
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by PE1BVU » Thu Feb 21, 2019 5:16 pm

UPDATE
Now a few days of checking and all of my hotspots still in "ro" mode:
  • Can rpi-rw / edit some file / rpi-rw without trouble.
  • Can do nightly updates without trouble.
  • Can do manual update/upgrade without trouble.
  • Guess i'm lucky
One thing: my Pi's are always powered on.

Keep y'all informed if anything changes, and meanwhile following the thread.

73's
Adri

User avatar
MW0MWZ
Site Admin
Posts: 916
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by MW0MWZ » Fri Feb 22, 2019 12:24 am

Pi-Star AutoAP has been patched so that it no longer keeps the disk in RW mode, you will need an update and a reboot if you want to test it with the AutoAP active.
Andy

73 de MW0MWZ
http://pistar.uk

User avatar
PE1BVU
Posts: 20
Joined: Mon Oct 22, 2018 8:17 am
Location: Amsterdam, the Netherlands
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by PE1BVU » Fri Feb 22, 2019 3:56 pm

MW0MWZ wrote:
Fri Feb 22, 2019 12:24 am
Pi-Star AutoAP has been patched so that it no longer keeps the disk in RW mode, you will need an update and a reboot if you want to test it with the AutoAP active.
Thanks Andy !

Tested it with all my hotspots now AutoAP on and they are all running fine.
The AutoAP works as usual, and for now the "rpi-rw" and "rpi-ro" seem to function ok.
Tested it manual over SSH with PUTTY doing rpi-rw/edit a file/viewed logfile/rpi-ro.
Also tested it from Pi-Star using "update", which ended ok and made the OS "ro".

For your info here my configuration:

Hotspot #1
Hardware: raspberry pi zero-w Rev 1.1 (512 MB)
Radio: MMDVM_HS_Hat (DB9MAT & DF2ET) for PI(GPIO)
Radio Firmware: HS_Hat:v1.4.16
Description: Japanese Jumbospot-Clone
TXCO: 14.7456 MHz
Radio Frequency: 438.012500 MHz
POSCAG Frequency: n/a
OS: Linux pi-star 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l
Pi-Star: 4.0.0-RC3 / Dashboard: 20190205
Enabled modes: DMR only
Auto AP: ON
uPNP: OFF

Hotspot #2
Hardware: raspberry pi zero-w Rev 1.1 (512 MB)
Radio: MMDVM_HS_Hat (DB9MAT & DF2ET) for PI(GPIO)
Radio Firmware: HS_Hat:v1.4.16
Description: Japanese Jumbospot-Clone
TXCO: 14.7456 MHz
Radio Frequency: 430.012500 MHz
POSCAG Frequency: 439.987500 MHz
OS: Linux pi-star 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l
Pi-Star: 4.0.0-RC3 / Dashboard: 20190205
Enabled modes: DMR and POCSAG
Auto AP: ON
uPNP: OFF

Hotspot #3
Hardware: raspberry pi 3 Model B (1GB) - Sony, UK
Radio: DV-Mega Raspberry Pi Hat (GPIO) - Single Band (70cm)
Radio Firmware: DVMEGA HR3.19
Description: Original DVMEGA Board (using Atmel Atmega 328)
TXCO: n/a
Radio Frequency: 434.012500 MHz
POSCAG Frequency: n/a
OS: Linux pi-starb 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l
Pi-Star: 4.0.0-RC3 / Dashboard: 20190205
Enabled modes: DMR only
Auto AP: ON
uPNP: OFF

On all my Hotspots i use a I2C OLED 0,96" monochrome or bi-color display.

73's
Adri

W4JEW
Posts: 35
Joined: Sun Aug 12, 2018 12:53 am

Re: Unable to Switch Back to 'rpi-ro'

Post by W4JEW » Tue Oct 08, 2019 10:04 am

Hello,

I’ve noticed that there’s a regression of this issue in Pi-Star 4.1 RC3 to RC5.

I know there was a proposed workaround initially that didn’t work, then it seemed like the issue was fixed in the 3.x days with a patch to AutoAP but it’s back. Big time!

I need to try disabling AutoAP to see if this is simply a matter of the patch not being included in 4.1 but I’m out of town and will not be able to try it until I get back home this coming weekend.

I’m not alone in noticing this issue. I just replied to a post on “Pi-Star Support Group” on Facebook as someone asked about this same issue there.

This issue is one of the leading causes of instability on Raspberry Pi in general and Pi-Star is one of the few solutions I’ve worked with that makes a converted effort to ensure the filesystem is read-only during traditional operational state.

Please look into this. It would be great to get a root cause analysis and a fix checked in that resolves it.

If there’s any way I can assist in providing logs or other datasets to help with debugging the issue.

Before people beat me up on this - yes, I know it’s free software and that Andy and any other contributing developers are volunteering their valuable time.

Thanks so much!!!

Best regards,

-JeffH

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Tue Oct 08, 2019 12:47 pm

Disabling auto ap doesn't work. After an update you get /mount point busy or somesuch.

Sent from my SM-A102U using Tapatalk


W4JEW
Posts: 35
Joined: Sun Aug 12, 2018 12:53 am

Re: Unable to Switch Back to 'rpi-ro'

Post by W4JEW » Tue Oct 08, 2019 1:00 pm

Out of curiosity have you rebooted since disabling AutoAP?

Post Reply