Unable to Switch Back to 'rpi-ro'

General support for the Pi-Star System
KE7FNS
Posts: 410
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Thu Oct 10, 2019 9:41 pm

K, so looks like it has to do with files that were used during the update and then deleted, which for some reason leaves them as still open.

I was able to restart the service which released those files, then I was able to set it back to RO without having to reboot.

I'm not sure if there are more services that can cause this issue, but I know for sure running "sudo pistar-update" causes it, and I'm fairly confident apt-daily.service and apt-daily-upgrade.service cause the issue to happen when they are run on their own by the OS.

Maybe Andy can add restarting the service to his cron job that tries to set RO mode and the end of the "pistar-update" script.

Code: Select all

sudo systemctl restart systemd-udevd.service
All views, comments, posts and opinions shared are entirely my own.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Thu Oct 10, 2019 9:55 pm

Nice find!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Fri Oct 11, 2019 12:50 am

All 4 of my currently running pistar installations have reverted back to rw. Pi zero running 4.1 rc6

Sent from my SM-A102U using Tapatalk


KE7FNS
Posts: 410
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Fri Oct 11, 2019 5:57 am

KD8DVR wrote:
Fri Oct 11, 2019 12:50 am
All 4 of my currently running pistar installations have reverted back to rw. Pi zero running 4.1 rc6
run the command to restart the service and retry.
All views, comments, posts and opinions shared are entirely my own.

G8SEZ
Posts: 52
Joined: Fri Apr 13, 2018 8:26 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by G8SEZ » Fri Oct 11, 2019 1:21 pm

Updated my Pi Zero Ws with the latest kernel and got the / mount is busy message.

Ran the sudo systemctl restart systemd-udevd.service command and it disappears.

Naturally I rebooted cleanly after the kernel update but it looks like this is at least one of the culprits.
--

Brian G8SEZ

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Fri Oct 11, 2019 3:58 pm

KE7FNS wrote:
Fri Oct 11, 2019 5:57 am
KD8DVR wrote:
Fri Oct 11, 2019 12:50 am
All 4 of my currently running pistar installations have reverted back to rw. Pi zero running 4.1 rc6
run the command to restart the service and retry.
No Go..... mount point is busy

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Fri Oct 11, 2019 6:05 pm

KE7FNS wrote:
Thu Oct 10, 2019 9:41 pm

Code: Select all

sudo systemctl restart systemd-udevd.service
This has worked for me several times now. A big thanks!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KE7FNS
Posts: 410
Joined: Wed Apr 17, 2019 11:11 pm

Re: Unable to Switch Back to 'rpi-ro'

Post by KE7FNS » Fri Oct 11, 2019 6:46 pm

KE0FHS wrote:
Fri Oct 11, 2019 6:05 pm
This has worked for me several times now. A big thanks!
That is really great to hear Toshen, but apparently it isn't always the case, so there is still something else causing it to be busy that needs to be discovered.

I'll keep messing with things whenever I notice my hotspots are stuck in RW. :(
All views, comments, posts and opinions shared are entirely my own.

KD8DVR
Posts: 53
Joined: Tue Aug 14, 2018 6:23 pm
Location: Columbus, OH USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KD8DVR » Sat Oct 12, 2019 9:27 am

KE0FHS wrote:
KE7FNS wrote:
Thu Oct 10, 2019 9:41 pm

Code: Select all

sudo systemctl restart systemd-udevd.service
This has worked for me several times now. A big thanks!
Hasn't worked for me

Sent from my SM-A102U using Tapatalk


User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Unable to Switch Back to 'rpi-ro'

Post by KE0FHS » Sat Oct 12, 2019 5:18 pm

Here's what I've found so far:
  • There are two different messages I see when Pi-Star gets stuck in rw mode: mount: / is busy and mount: /: mount point is busy. I haven't yet identified the pattern for when each message gets displayed. It might be that mount: /: mount point is busy is the Buster message, but I'm not sure yet.
  • If Pi-Star starts up in rw mode, I sometimes can use rpi-ro to kick it into ro mode, but other times not.
  • If Pi-Star is in ro mode and I run sudo pistar-update, then it sometimes finishes in rw mode. Sometimes I can use rpi-ro to kick it into ro mode, but other times not.
  • If I can't use rpi-ro to kick it into ro modes, then most of the time I can run sudo systemctl restart systemd-udevd.service followed by rpi-ro to kick it into ro mode. But sometimes that doesn't work, especially if Pi-Star starts up in rw mode.
    If I can't use rpi-ro or sudo systemctl restart systemd-udevd.service followed by rpi-ro to kick it into ro mode, then the only thing I've found that works is rebooting.
  • Just now, on RPi 4 hotspot running 4.1.0-RC6, Pi-Star started up in rw mode. It did not work to use rpi-ro to kick it into ro mode (message: mount: /: mount point is busy), but it did work to run sudo systemctl restart systemd-udevd.service followed by rpi-ro to kick it into ro mode.
    Next, I ran sudo pistar-update. (Note: Most of the time, I run updates via SSH so I catch any OS updates, too, and today's update did include an OS update.) When the update was finished, it ended up in rw mode with the mount: /: mount point is busy message. Once again, running sudo systemctl restart systemd-udevd.service followed by rpi-ro did successfully kick it into ro mode.
  • Earlier this morning, when I started up an RPi 3A+ hotspot running 4.1.0-RC6, Pi-Star started up in rw mode. It did not work to use rpi-ro to kick it into ro mode (unfortunately, I didn't pay to the exact mount is busy message that was displayed). Running sudo systemctl restart systemd-udevd.service followed by rpi-ro also didn't kick it into ro mode. In that case, I rebooted, and the second time it started up in ro mode.
P.S. Because I'm doing so many fresh image installs and configurations, I'm really falling in love with the RPi 4B. Even though it may be overkill for ordinary hotspot operations, it's so much faster whenever you need to install and do an initial configuration, when you run a pistar-update that includes an OS update, or simply when you Apply Changes on the Configuration page. Because of that, I I'm going to switch a couple more of my primary 3A+ hotspots to 4B. Yesterday, I noticed that Canakit has released a new fan case for the RPi 4B that looks pretty nice: https://www.canakit.com/raspberry-pi-4-case-white.html (available in white, black, and clear).

So I ordered a couple, along with RPi 4B boards, fans, and their USB-C power switches, which I really like. They also have various all-included kits available, but I don't need any more microSD cards/readers or micro HDMI cables, so I put together my orders from their basic RPi 4B 1GB kit in order to save a few bucks (includes USB-C power supply and three heat sinks), and then added the other items from their other accessories list.
.
canakitpi4bfancase.jpg
canakitpi4bfancase.jpg (16.59 KiB) Viewed 206 times
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply