Cant do pi-star link except on phone wifi

General support for the Pi-Star System
Post Reply
ae0dc
Posts: 8
Joined: Wed Aug 01, 2018 7:50 pm

Cant do pi-star link except on phone wifi

Post by ae0dc » Sat Aug 25, 2018 10:02 pm

Ok, so I setup my pi-star, had the control panel on my desktop, all seemed well but I needed to hook it up to my phone hotspot. This took several attempts, but it finally worked. Now I purchased a sprint hotspot, and tried to link it to that. It linked and runs, however I can not bring up the
http://pi-star/admin/power.php panel. It says site cant be reached (Yes I changed the desktop to same wifi), and on top of that, I can not bring up the control panel on the desktop when the pi-star is linked to my home wifi. That's where it originally worked ! The only way I can get the control panel up is by linking pi-star to phone wifi, and desktop to same.
Ok, I give up...what do I ned to do. neither internet explorer or chrome will bring up http://pi-star/admin/power.php or the same with config ?

any help would be appreciated.

Doug AE0DC

User avatar
KE0FHS
Posts: 1072
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Cant do pi-star link except on phone wifi

Post by KE0FHS » Sat Aug 25, 2018 10:57 pm

Probably need more information to begin to give you a good answer. Presuming you have different network names and passwords for each of your networks (home WiFi, phone hotspot, Sprint hotspot). Have you entered all three into the Wireless Configuration section of Pi-Star?

If yes, then here's how it works: When you boot up Pi-Star, it will scan each one in turn based on its priority until it finds one to connect to. Each connection attempt takes about 40 seconds. If Pi-Star connects to the first or second WiFi network you have configured, then it won't connect to the third unless you turn off the first and second network and then reboot Pi-Star.

Also, when you first attempt to open the dashboard in your browser, it's best to navigate to:
Windows: http://pi-star/
macOS, iOS, etc.: http://pi-star.local/

Once you have connected to the dashboard, you can click Admin to log into the Admin view with your Pi-Star credentials (by default, username: pi-star; password: initially raspberry, but after you configure Pi-Star for the first time whatever you changed the password to). Once you're in Admin view, you can navigate to Power, etc.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

User avatar
W1KMC
Posts: 98
Joined: Wed May 02, 2018 8:34 pm
Location: Bangor, ME USA
Contact:

Re: Cant do pi-star link except on phone wifi

Post by W1KMC » Sun Aug 26, 2018 12:46 pm

I am no developer, guru, expert, nor do I claim to be or want to be. All advice I give is purely from experience and my efforts to help others, take my advice/suggestions as you deem fit. I help when I can but make absolutely no guarantees what worked for me will work for you.

Doug, what you describe is common...and normal. I have to explain. Toshen, you do a great job on your site but this (from experiences of my own is what I find).

So first you had hotspot on the Home Network. you typed http://pi-star/ and were presented a web page ...right. Good - you are set on home network.

Next you tried to connect the hotspot to your phone, from what you say, it took a few attempts, but finally worked.
Now did you try http://pi-star/ in your phoneand get the dashboard? My guess is no but the hotspot worked so you didn't really try (or care). If it did on your phone your one up on me, mine won't connect in my phone's browser using pi-star -- I need something else, wait for it....

Now you buy a Sprint Hotspot and this time it won't work,well let's walk through this.

Since you say it won't connect on your home WiFi no, connect the laptop, and Hotspot to your phone. Now on your laptop, type http://pi-star/ and see what it says. Do you get the "This site cannot be reached -- connected to my phone I would, and the reason is phones and hotspots (Sprint) cannot resolve the hostnames, they do not have internal DNS servers (DHCP will assign an IP number but the Hotspot/phone doesn't know to look within itself. So on your phone in your Hotspot settings area there should be a way to see 'Connected Devices' this will tell you the Pi-Star's IP address, USE this instead -- this is where many people say -- My hotspot is broken -- no not broken the Hotspots(Phones and Jetpacks, myfi, portable hockey pucks, whatever) cannot decypher the pi-Star names, they were not built to do that.

So on to how to fix this.

Connect radio hotspot (jumbo/zum/mmdvm, whatever) and laptop to the same WiFi Hotspot (phone, jetpack, whatever) and get the pi-star IP address. Home networks may look like 192.168.[0/1].xxx or 10.10.[0/1].xxx | wifis devices are sometimes in the 172 or similar starting number (mine is not on now so I cannot check.

Once all three are working, on the laptop type http://172.36.43.109/ [obvoiusly replace with the REAL IP that your device assigned.
you should now see the dashboard, you can click configure now and type pi-star / raspberry (or if you changed your Pi-Star password, use it instead)

Now we need Expert mode, and WiFi-Setu (yes you can manually edit the wpa_supplicant file right from within Pi-Star itself ( the config wifi gui makes it easier to FIND new ones and set them up, but if you know the SSID (Network Name) and PSK (Password this will be faster in the long run.

In this WiFi-Setup you will see a block that looks like:

Network{
SSID="MyHomeNetworkName"
PSK="Mysuperniftysuperlongnoonegunnaguesspassword"
ID="1"
Priority="100"
}

You will see one block for EACH network your Radio Hotspot knows about but the ID will go UP and the Priority will go DOWN.

The order in which the Radio Hotspot checks and uses these networks is Priority order 100.99.98.... So if you want it to always use Jetpack first then Cell phone second then Home WiFi that is the Priority you need to place them in. When at Home make sure the Cell and Jetpack are TURNED Off, otherwise the radio hotspot will connect there first. Caveat is if your Home Network is FIRST then No Phone or Jetpack will ever connect while at home.

Save the changes and try this out. (reboot your Pi.

Now I have heard many people say just change your Phone WiFi and Jetpack Wifi to the same Network Name and Password as your Home Network is and you are all set. Well that will work, but what if you wanted to take this to work or someplace where you frequent where you have NO CONTROL over its wifi name or password. Setting the Priorities will help also make sure the Network names and passwords have no 'funky' characters numbers and letters are ok but some sevices have issues with # ( ^ you get the idea.

Try this out and let us know how it goes. I am available for one-on-one setups via TeamViewer where I come in by remote, see what you see and walk you through step by step, I do this as one ham to another but donations (need caffeine) are greatly accepted and appreciated. All you have to do is find my Contact Number-- the clue is Google W1KMC and look for any RADIO Clubs it pops up on, two will have phone numbers for me.

Good Luck.
I am no developer, guru, expert, nor do I claim to be or want to be. All advice I give is purely from experience and my efforts to help others.

W1KMC - Kevin M Carman
Bangor, ME
Jumbospot on a Pi0W
DMR 3123142 & 3123143
HHUS Trunk Ext 4329

ae0dc
Posts: 8
Joined: Wed Aug 01, 2018 7:50 pm

Re: Cant do pi-star link except on phone wifi

Post by ae0dc » Sun Aug 26, 2018 7:17 pm

I will try tonight, what you say makes sense, I will report back but I believe you just made my hero's list !
Doug

ae0dc
Posts: 8
Joined: Wed Aug 01, 2018 7:50 pm

Re: Cant do pi-star link except on phone wifi

Post by ae0dc » Tue Aug 28, 2018 8:34 pm

OK, I can now access the dashboard when using the phones wifi by logging my desktop into the same wifi (Phones) and using the pi-star command.
I can access again, the dashboard when I use my home network, which has both hard and wireless points. I allow the pi-star Zumspot to
access one of my wireless spots, and I access the dashboard via the main network (Don't login to wireless point)

However, Using my SPRINT hotspot, my pi-star / zumspot will link to it and run, but I can not access the dash board, even if I link my main
pc into the hotspot. I can access the hot spots dashboard, but it only gives me a mac address and not a IP address. It does show that it
will create IP address 192.168.128.10 to .100 I tried .10 thru .15 with no joy.

Any suggestions? and yes Im happy to donate a few bucks (up to 20) for your time if we solve this.

Thanks in advance, Doug AE0DC

User avatar
W1KMC
Posts: 98
Joined: Wed May 02, 2018 8:34 pm
Location: Bangor, ME USA
Contact:

Re: Cant do pi-star link except on phone wifi

Post by W1KMC » Wed Aug 29, 2018 2:01 am

Somewhere in the sprint Hotspot menus is a selection similar to 'Connected Devices' If your Zumspot is connected to the Sprint device thiat is where you need to look, if it only giives a MAC address then something went wrong. Anyone else out there with a Sprint Hotspot that can give us a hand?

Something else to try, but may not have luck if it asks for a password. You said that the Sprint box gives out 192.168.128.XXX addresses then try either:

192.168.128.0 // 192.168.128.1 or 192.168.128.255 if the Sprint device has some sort of web GUI these are the most likely places.

The only way I can help, albeit this may not work on a sprint device, is have your Zumspot and laptop connected to it and then try Teamviewer so I can see what is going on.

Give me the MODEL of the Sprint Device, I will try to find the manual to walk you through on the phone if we cannot connect visually. some of these small devices hide the simplest info deep in its guts.
I am no developer, guru, expert, nor do I claim to be or want to be. All advice I give is purely from experience and my efforts to help others.

W1KMC - Kevin M Carman
Bangor, ME
Jumbospot on a Pi0W
DMR 3123142 & 3123143
HHUS Trunk Ext 4329

W4AEQ
Posts: 4
Joined: Fri Apr 13, 2018 2:26 am

Re: Cant do pi-star link except on phone wifi

Post by W4AEQ » Fri Aug 31, 2018 5:12 pm

Something else you might try on your Jetpack is to make sure that it allows connected devices to see each other. Normally that is set to "Off" (at least in the Jetpacks that I have configured). You'll find this switch in the Jetpack configuration settings.

Post Reply