MMDVM Not working (almost) at all

MMDVM_HS Hat hardware
Post Reply
Posts: 1
Joined: Thu Jan 10, 2019 6:27 pm

MMDVM Not working (almost) at all

Post by iu2frl » Fri Jan 11, 2019 6:30 pm

Hi everybody, i've bought a MMDVM clone (quite sure) on Amazon but i can't get it working, here my attempts:
- Standard pi-star installation, everything set as usual with only DSTAR enabled -> display working but no RF (either receiving or transmitting)
- Some tuning: tried upgrading the firmware to the latest with "sudo pistar-mmdvmhshatflash hs_hat" (i've checked the board and it has the 14MHz oscillator) but no RF, when trying the MMDVMCal it says "Unable to read the firmware version after six attempts", while if i flash the 12MHz version it starts doing the tests but still no RF.

The transmitting frequency is on 430.550 so i'm not in satellite band, on the board i have the PTT (almost always) ON and the SVC led blinking

please help me even with some brainstorming

Update 1: after another flash with the 14MHz version i got "E: 2019-01-11 19:11:07.808 D-Star, overflow in the D-Star RF queue" in the log, but i'm not able to run the MMDVMCal
Update 2: it seems that the TCXO of the ADF7021 is not oscillating at all, power good but no signal, which type do i need?

Post Reply