Page 2 of 2

Re: failed to update system

Posted: Fri May 03, 2019 5:49 am
by RC3C
Thanks for reply and support.
KE7FNS wrote:dmesg | grep -i voltage
I have no voltage issues in the log
volt.PNG
volt.PNG (3.57 KiB) Viewed 209 times
Ok, i'll burn new image on new microSD card

FYI
fsck-rpi-rc3c.PNG
fsck-rpi-rc3c.PNG (6.96 KiB) Viewed 208 times

Re: failed to update system

Posted: Fri May 03, 2019 4:49 pm
by RC3C
Hi all.

Seems I just fixed an issue by myself according KE7FNS and related guides, which I found on internet for MMDVM_HS_hat.
1) Made backup of settings from hostpot.
2) Bought new microSD card 16Gb
3) Downloaded image https://www.pistar.uk/downloads/Pi-Star ... n-2019.zip for RPi-zero
4) Downloaded SDcard formatter https://www.sdcard.org/downloads/formatter/
5) Downloaded Etcher https://www.balena.io/etcher/
6) According Guide by 9V1KB https://9v1kb.blogspot.com/2018/03/how- ... tspot.html made preparations
7) According Guide by W1MSG https://www.youtube.com/watch?v=B5G4gYDdJeQ flashed my microSD card
8) microSD card unplugged then plugged again into PC
9) Onto "boot" partition I put "wpa_supplicant.conf" file with WiFi config
10) microSD card unplugged from PC
11) microSD card plugged into hotspot
12) Power ON hotspot
13) Checked DHCP IP leases on my Mikrotik router RB2011
14) Opened browser when I found certain IP address for https://pi-star/ (I have fixed IP 192.168.80.200 on DHCP server)
15) Opened https://pi-star/
16) Opened Configuration --> Backup/Restore
17) Restored hotspot settings from .ZIP file.

Now it works. QSO round tested with RK7K on TG2501.

18) Opened SSH on pi-star and logged on with default credentials
19) Now I have this
FIXED-rpi_rw.PNG
FIXED-rpi_rw.PNG (16.99 KiB) Viewed 201 times

Re: failed to update system

Posted: Fri May 03, 2019 4:50 pm
by RC3C
20) Checked possibility to update pi-star node from web interface. I have this
update_run_fixed_1.PNG
update_run_fixed_1.PNG (24.38 KiB) Viewed 201 times
update_run_fixed_2.PNG
update_run_fixed_2.PNG (24.03 KiB) Viewed 201 times
update_run_fixed_3.PNG
update_run_fixed_3.PNG (24.73 KiB) Viewed 201 times

Re: failed to update system

Posted: Fri May 03, 2019 9:07 pm
by KE7FNS
RC3C wrote:
Fri May 03, 2019 5:49 am
I have no voltage issues in the log
That is good news so far, keep monitoring it every day or so.
RC3C wrote:
Fri May 03, 2019 5:49 am
FYI
fsck needs to be run with root permissions, so next time run "sudo fsck"

also it doesn't always do a full check, it just quickly checks to see if the dirty bit has been set, so its better to add the "-f" option to force it to check.

"sudo fsck -f"

Either way the backup and restore process built into pi-star is excellent and is the fastest way I have found to recover a hotspot and get it running correctly again.

I am glad you got it fixed. :D

Re: failed to update system

Posted: Fri May 03, 2019 11:22 pm
by RC3C
Hey
KE7FNS wrote:That is good news so far, keep monitoring it every day or so.
OK, thanks for this idea.
KE7FNS wrote:
Fri May 03, 2019 9:07 pm
fsck needs to be run with root permissions, so next time run "sudo fsck"
also it doesn't always do a full check, it just quickly checks to see if the dirty bit has been set, so its better to add the "-f" option to force it to check.
"sudo fsck -f"
Thanks.
KE7FNS wrote:
Fri May 03, 2019 9:07 pm
Either way the backup and restore process built into pi-star is excellent and is the fastest way I have found to recover a hotspot and get it running correctly again.
Well, I was informed from our local HAMs that if you're using hotspot you have to have few microSD cards in addition in case of current working one failed. So, I decided to buy few cards and already made working image from current microSD card with all my settings inside as one .IMG file (used Win32-Disk-Imager software). So, it's just for back up 100% a working one.
KE7FNS wrote:
Fri May 03, 2019 9:07 pm
I am glad you got it fixed. :D
Appreciated on that much.
Happy weekend from Moscow, RU.

Re: failed to update system

Posted: Thu May 09, 2019 4:02 am
by KE7FNS
RC3C wrote:
Fri May 03, 2019 11:22 pm
So, I decided to buy few cards and already made working image from current microSD card with all my settings inside as one .IMG file (used Win32-Disk-Imager software). So, it's just for back up 100% a working one.
That is an excellent solution to make sure you can get the hotspot back up and running as quickly as possible. 8-)

Re: failed to update system

Posted: Thu May 09, 2019 4:05 am
by RC3C
KE7FNS wrote:
Thu May 09, 2019 4:02 am
RC3C wrote:
Fri May 03, 2019 11:22 pm
So, I decided to buy few cards and already made working image from current microSD card with all my settings inside as one .IMG file (used Win32-Disk-Imager software). So, it's just for back up 100% a working one.
That is an excellent solution to make sure you can get the hotspot back up and running as quickly as possible. 8-)
Sure, it does. :D