Hotspot ignoring my signal

Help with NXDN issues
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Hotspot ignoring my signal

Post by K8BMZ »

Hello,

I have a Icom F6061D radio programmed to the hotspot frequency. Whenever I key up the radio, the hotspot ignores the signal completely. I have made sure the RAN is correct and I also am using my NXDN ID from radioid.net. I have also tried both 'Individual' and 'TalkGroup' call types in the radio programming. I have tried both wide and narrow signals. I have also tried setting my Talkgroup and Indicvidual ID on the radio to the same as my NXDN ID from radioid.net

I used my RTL-SDR and DSD+ to decode my signal to make sure the radio is transmitting the correct RAN. It decodes the signal just fine as 'NEXEDGE48'.

Can anyone help point me in the right direction?

Rpi-Zero
Pi-star 4.1.4
MMDVM Firmware: HS_Hat:v1.5.2
KE7FNS
Pi-Star Team
Posts: 1913
Joined: Wed Apr 17, 2019 11:11 pm

Re: Hotspot ignoring my signal

Post by KE7FNS »

K8BMZ wrote: Fri Mar 19, 2021 4:05 pm Can anyone help point me in the right direction?
It could be the offset is incorrect.

Try MMDVMCal.

Use this as a guide but use option 'n' instead of 'b'
http://www.kh7ms.com/mmdvm/
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Re: Hotspot ignoring my signal

Post by K8BMZ »

KE7FNS wrote: Fri Mar 19, 2021 6:07 pm
K8BMZ wrote: Fri Mar 19, 2021 4:05 pm Can anyone help point me in the right direction?
It could be the offset is incorrect.

Try MMDVMCal.

Use this as a guide but use option 'n' instead of 'b'
http://www.kh7ms.com/mmdvm/
Thanks, I just tried this and when in the test mode for NXDN, I don't see anything when trying to key up the hotspot. I adjusted the offset up and down and tried keying it up and still nothing reported :(
KE7FNS
Pi-Star Team
Posts: 1913
Joined: Wed Apr 17, 2019 11:11 pm

Re: Hotspot ignoring my signal

Post by KE7FNS »

K8BMZ wrote: Fri Mar 19, 2021 7:22 pm Thanks, I just tried this and when in the test mode for NXDN, I don't see anything when trying to key up the hotspot. I adjusted the offset up and down and tried keying it up and still nothing reported :(
Check frequency the hotspot is listening on. You said you used an SDR to confirm, so make sure the hotspot is listening on the freq you think it is. Remember if you are using duplex, you need to listen on the frequency the radio is transmitting on and vice versa.

Also 145.8 to 146 MHz and 435 to 438 MHz are blocked because they interfere with the satellite portion of the bands. If the frequency field in the configuration panel is red change to a valid frequency.

Also try a different mode if possible, maybe the hat has a fault.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Re: Hotspot ignoring my signal

Post by K8BMZ »

KE7FNS wrote: Fri Mar 19, 2021 7:35 pm
K8BMZ wrote: Fri Mar 19, 2021 7:22 pm Thanks, I just tried this and when in the test mode for NXDN, I don't see anything when trying to key up the hotspot. I adjusted the offset up and down and tried keying it up and still nothing reported :(
Check frequency the hotspot is listening on. You said you used an SDR to confirm, so make sure the hotspot is listening on the freq you think it is. Remember if you are using duplex, you need to listen on the frequency the radio is transmitting on and vice versa.

Also 145.8 to 146 MHz and 435 to 438 MHz are blocked because they interfere with the satellite portion of the bands. If the frequency field in the configuration panel is red change to a valid frequency.

Also try a different mode if possible, maybe the hat has a fault.
Yep, I have been using this hotspot as a Fusion hotspot for a long time, and verified the frequency is correct. I am using 434.650mhz

It might be the way this radio is programmed as its a commercial radio and the programming software is quite advanced.

*EDIT* Nope... I loaded factory settings and added just the hotspot and still a no-go..
I am able to hear and decode it fine with RTL-SDR/DSD+ as well with my SDS100 scanner.. So I am not sure why the hotspot wont..
KE7FNS
Pi-Star Team
Posts: 1913
Joined: Wed Apr 17, 2019 11:11 pm

Re: Hotspot ignoring my signal

Post by KE7FNS »

K8BMZ wrote: Fri Mar 19, 2021 8:04 pm Yep, I have been using this hotspot as a Fusion hotspot for a long time, and verified the frequency is correct. I am using 434.650mhz

It might be the way this radio is programmed as its a commercial radio and the programming software is quite advanced.

*EDIT* Nope... I loaded factory settings and added just the hotspot and still a no-go..
I am able to hear and decode it fine with RTL-SDR/DSD+ as well with my SDS100 scanner.. So I am not sure why the hotspot wont..
Well I think I've gone over the most common issues that people have reported. I'm really not sure about the actual mode and what works and what doesn't because I have never used it.

Maybe someone else can help. Sorry.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Re: Hotspot ignoring my signal

Post by K8BMZ »

I just did some more testing and my radio can RX the NXDN signal from the hotspot just fine, but I cannot transmit back to it. Is there any specific setting I should look for in the radio programming? Is the hotspot only looking for the RAN and ignores the rest of the header? I can specify talk groups for the channel programmed into the radio, I left it as TG1.
KE7FNS
Pi-Star Team
Posts: 1913
Joined: Wed Apr 17, 2019 11:11 pm

Re: Hotspot ignoring my signal

Post by KE7FNS »

K8BMZ wrote: Mon Mar 22, 2021 2:19 pm Is there any specific setting I should look for in the radio programming?
I honestly do not know.

MMDVMCal should not care about what ID is programmed into the radio, it will allow all. If Pi-star is configured for private, it will only allow yours, if it is public it should allow all.

I would confirm your radios actual frequency by using an SDR. Then I would use MMDVMCal to set the frequency to match as close to the actual center of the frequency as possible. (remember the F and f keys are only going to move the frequency by a few Hz at a time so it might take you a while to find the happy offset, it is very fine tuning). If you can find a response there then you know the hat can receive NXDN, it might be that the hat is not compatible. I've seen a developer mention that certain STM32105's are not powerful enough to process NXDN, and if that is the case a STM32103 isn't powerful enough either also since they are both clocked at 72 Mhz.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Re: Hotspot ignoring my signal

Post by K8BMZ »

KE7FNS wrote: Mon Mar 22, 2021 5:50 pm
K8BMZ wrote: Mon Mar 22, 2021 2:19 pm Is there any specific setting I should look for in the radio programming?
I honestly do not know.

MMDVMCal should not care about what ID is programmed into the radio, it will allow all. If Pi-star is configured for private, it will only allow yours, if it is public it should allow all.

I would confirm your radios actual frequency by using an SDR. Then I would use MMDVMCal to set the frequency to match as close to the actual center of the frequency as possible. (remember the F and f keys are only going to move the frequency by a few Hz at a time so it might take you a while to find the happy offset, it is very fine tuning). If you can find a response there then you know the hat can receive NXDN, it might be that the hat is not compatible. I've seen a developer mention that certain STM32105's are not powerful enough to process NXDN, and if that is the case a STM32103 isn't powerful enough either also since they are both clocked at 72 Mhz.
Thanks! I re-ran the mmdvmcal and set the offsets properly and it is now working. Thank you! Sorry I must have missed a step the first time around.
K8BMZ
Posts: 7
Joined: Sun Aug 02, 2020 5:25 pm

Re: Hotspot ignoring my signal

Post by K8BMZ »

After further investigation changing my offsets actually made every other mode have a lot of errors. That means it was my radio that has a bad offset. Luckily the programming software allowed me to edit the offset on the radio. The carrier looks bang-on the SDR and there are almost 0% errors on all modes with the MMDVM calibration at +-0 offset. :D
Post Reply