DUE not working with latest MMDVM

Help with other MMDVM Repeater Boards (with NO onboard RF)
Locked
g0ewh
Posts: 1
Joined: Tue Aug 06, 2019 9:48 pm

DUE not working with latest MMDVM

Post by g0ewh » Thu Aug 20, 2020 8:05 pm

Hi

I run a Arduino DUE which works fine with the August 2019 version of the MMDVM. Decided to update the MMDVM to it's current version, but it fails to run. It compiles and Uploads, but after booting up, the Tx & Rx LEDs of the DUE Programming port fail to light, only the ON & L of the other 4 show. The MMDVM config.h is identical to the previous MMDVM version and when I recompile and upload with last years version, it works.

Thanks
Richard

KE7FNS
Posts: 939
Joined: Wed Apr 17, 2019 11:11 pm

Re: DUE not working with latest MMDVM

Post by KE7FNS » Thu Aug 20, 2020 10:32 pm

g0ewh wrote:
Thu Aug 20, 2020 8:05 pm
I run a Arduino DUE which works fine with the August 2019 version of the MMDVM. Decided to update the MMDVM to it's current version, but it fails to run. It compiles and Uploads, but after booting up, the Tx & Rx LEDs of the DUE Programming port fail to light, only the ON & L of the other 4 show. The MMDVM config.h is identical to the previous MMDVM version and when I recompile and upload with last years version, it works.
If I were you I would file an issue report on Github instead of posting here.

https://github.com/g4klx/MMDVM/issues

What software are you using to compile the code and what OS are you building it in?

Theres so much code that has changed since Aug 2019 that it is impossible to tell what change could of broken it. I'd pull a build from in between Aug 2019 and now and test it and see what happens. If that build is broken, then you know what broke it is in between Aug 2019 and the halfway point. If it isn't broken then you know the break happened later. Then keep halving things until you find a build that works and where the very next build doesn't. Then analyze the differences and see what code broke it.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

KE7FNS
Posts: 939
Joined: Wed Apr 17, 2019 11:11 pm

Re: DUE not working with latest MMDVM

Post by KE7FNS » Thu Aug 20, 2020 11:16 pm

I did a little research.

https://groups.io/g/OpenDV/message/367

Thats pretty bad news, looks like you are stuck running older firmware, or upgrading.

looks like https://github.com/g4klx/MMDVM/commit/1 ... e4a1e3ee98 is the last working commit for an Arduino Due.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

Locked