Original ZUM 1.0 + DUE -any way to verify operation?

Help with other MMDVM Repeater Boards (with NO onboard RF)
Post Reply
VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Mon Feb 04, 2019 3:59 am

Hi all.

I have an original ZUM 1.0 modem board & Arduino Due that I am attempting to get working on Pi-Star. I am unable to get a Pi-Star to connect to any BM Master servers, and I suspect that the USB connected DUE & ZUM modem may not be working(communicating) with the RPi or Pi-Star. I have selected 'MMDVM/MMDVM_HS/TEENSY/ZUM(USB)' for the Radio/Modem Type.
Is there any way (log files, etc.) that I can verify it's operation?
Any suggestions would be greatly appreciated.
73 de Mike

M1DNS
Posts: 203
Joined: Thu Apr 05, 2018 5:30 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by M1DNS » Mon Feb 04, 2019 9:13 pm

Generally if mmdvmhost can't "see" a mmdvm board live logs will report "failing to read the firmware after six attempts"

You'll also notice the firmware and device missing from the dashboard info panel and prob. see all the boxes on the modes panel are lit up red. Indicating the services haven't started as it can't see a board attached.

Andrew M1DNS, (Mod)


Andrew M1DNS.
Pi-star Admin Team.

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Tue Feb 05, 2019 1:03 am

Thank you Andrew,

I have never seen anything appear in the "Live Logs" other than 'Starting logging, please wait...'

I may have to start with a new image...Already tried a factory reset, and that didn't help.
Perhaps it is time for a new ZUM radio board -the one that connects via GPIO :)

73 de Mike

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Tue Feb 05, 2019 3:23 am

Well that's interesting.. I ran an 'Upgrade' and the following message appeared>
Starting upgrade, please wait...
Detected Pi-Star 3.4.17 running on RPi hardware, attached to zum modem...

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Mon Feb 18, 2019 4:08 am

While looking through the log files, I am seeing the following error> E: 2019-02-18 00:17:21.944 Unable to read the firmware version after six attempts

Has anyone else experienced this?

Thanks in advance
73 de Mike

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Wed Feb 20, 2019 2:17 am

Have tried sudo apt-get install --reinstall raspberrypi-kernel
it didn't fix the "Unable to read the firmware version after six attempts" error

M1DNS
Posts: 203
Joined: Thu Apr 05, 2018 5:30 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by M1DNS » Wed Feb 20, 2019 8:21 pm

The error is telling you MMDVM host isn't "seeing' a mmdvm board (device) attached. It doesn't actually detect the physical attachment of a board etc. but instead tries to read the firmware on ur board / device if it can't you get that error message that it isn't seeing the device. Also the same if you have selected the incorrect device in the 'modem type' drop down selection on the config page.

Andrew M1DNS, (Mod)


Andrew M1DNS.
Pi-star Admin Team.

g7kbr
Posts: 26
Joined: Thu Nov 01, 2018 1:03 pm

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by g7kbr » Mon Feb 25, 2019 7:52 am

VE3MIC wrote:
Mon Feb 04, 2019 3:59 am
Hi all.

I have an original ZUM 1.0 modem board & Arduino Due that I am attempting to get working on Pi-Star. I am unable to get a Pi-Star to connect to any BM Master servers, and I suspect that the USB connected DUE & ZUM modem may not be working(communicating) with the RPi or Pi-Star. I have selected 'MMDVM/MMDVM_HS/TEENSY/ZUM(USB)' for the Radio/Modem Type.
Is there any way (log files, etc.) that I can verify it's operation?
Any suggestions would be greatly appreciated.
73 de Mike
Hi

Wonder did you ever fix your zum 1.0, ardunio issue?

Regards

Paul

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Tue Feb 26, 2019 8:11 pm

Hello Paul,

I have not been able to get the ZUM Modem + Due to be recognized. I am awaiting another power supply, as the one that i am currently using will supply just slightly more than 2 amps(2.4A). I will continue to post my progress (or lack of).
Thanks & 73
de Mike

VE3MIC
Posts: 8
Joined: Sat Dec 22, 2018 5:56 am

Re: Original ZUM 1.0 + DUE -any way to verify operation?

Post by VE3MIC » Thu Feb 28, 2019 1:11 am

-SOLVED-

I updated the MMDVM firmware on the DUE, and it is now working!
Thanks everyone
73 de Mike

Post Reply