Terminal settings for the ID51s plus2 and v4 RC3

Help with D-Star related issues
Post Reply
N9KO
Posts: 12
Joined: Wed Apr 11, 2018 3:08 pm

Terminal settings for the ID51s plus2 and v4 RC3

Post by N9KO » Sun Jan 27, 2019 6:01 pm

I installed v4 RC3 on my pi0w. I changed the modem type to Icom Radio in Terminal Mode(Dstar Repeater). The controller software is Dstar Repeater. The 51a+2 is in the terminal modem via DV Gateway - Terminal Mode. Yes, I am using the OPC-2350LU connected to my pi0w.

On the Pistar config page I set the default reflector for REF030 E to do an audio check. Nothing came back to me. The 51a+2 screen shows Terminal at the bottom, and it has TO: CQCQCQ at the top.

I followed the directions in the following url:
https://davidcappello.com/2019/01/25/pi ... AmRQ3G6WFI

I cannot make the DstarRepeater tab to turn green on my Admin screen.

One last thing. My Dstar registration was done several years ago under G2. I believe to use the Terminal and Access modes on the non-Pistar system, one needs to be registered through a repeater using the latest G3 software. Is this my problem?

Tnx
Cal
N9KO

N9KO
Posts: 12
Joined: Wed Apr 11, 2018 3:08 pm

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by N9KO » Mon Jan 28, 2019 11:33 am

That did not work. I did not see a dstarrepeater log, but a dstarrepeaterd01-28-2019 log that had comments about not accessing Hostfiles in the Root directory.

I will wait until the final version comes out and try again. Wasted way too much time on this.

MW0MWZ
Site Admin
Posts: 716
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by MW0MWZ » Tue Jan 29, 2019 12:23 am

VK4TUX wrote:
Mon Jan 28, 2019 7:29 am
Check /etc/dstarrepeater directly for

icomPort=/dev/ttyUSB0

and

restriction=0
rpt1Validation=0
These are done automatically provided Pi-Star is right up to date.
Andy

73 de MW0MWZ
http://pistar.uk

MW0MWZ
Site Admin
Posts: 716
Joined: Wed Apr 04, 2018 9:15 pm
Location: Wales, UK
Contact:

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by MW0MWZ » Tue Jan 29, 2019 12:25 am

N9KO wrote:
Mon Jan 28, 2019 11:33 am
That did not work. I did not see a dstarrepeater log, but a dstarrepeaterd01-28-2019 log that had comments about not accessing Hostfiles in the Root directory.

I will wait until the final version comes out and try again. Wasted way too much time on this.
Only thing you might want to make sure of, is that Pi-Star is right up to date, (press update on the dashboard), and then apply the settings in the config page - that should be all it takes.
Andy

73 de MW0MWZ
http://pistar.uk

User avatar
VK7HSE
Posts: 120
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by VK7HSE » Tue Jan 29, 2019 11:22 am

Ok thought that I'd give this a try, but when I go to set the modem as icom terminal radio in the drop down menu, I only have the option for the Icom repeater. This install is a restore from the 3.4x so I think that the modem type is missing even though the nightly updates are being applied.

So do I need the ID-51P2 connected to pi and in terminal mode for that option to be available in the drop down menu?

Or should it be in the menu regardless of what the status of the ID-51P2 is?

FYI dstar repeater was selected not mmdvm! Just to clarify that point...

Happy to reflash to the current released image to confirm my suspicions of the available modems being overwritten by the restore process.

Let me know if I'm barking up the wrong tree!

Sent from my Pixel 2 XL using Tapatalk


N9KO
Posts: 12
Joined: Wed Apr 11, 2018 3:08 pm

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by N9KO » Tue Jan 29, 2019 11:28 am

Here is my log after doing the update.
Attachments
n9ko var log pi star dstarrepeaterd log .PNG
n9ko var log pi star dstarrepeaterd log .PNG (63.65 KiB) Viewed 503 times

N9KO
Posts: 12
Joined: Wed Apr 11, 2018 3:08 pm

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by N9KO » Tue Jan 29, 2019 8:20 pm

It works now. To set Pi-Star in Dstarrepeater mode, I made the following changes based on a post by Elmer Delgado in the D-Star Users FB page:

Dstar repeater is not loaded and here is how to fix that!
1. You must reset the Pi-Star software to default [Configuration] [Factory Reset].
2. Reboot then select simplex and dstar repeater save it [Apply Changeds] reboot [Power] [Reboot]
3. Select terminal mode make sure the radio is powered on and in terminal mode and make sure you have the icom cable plugged in tbe back and to the pi (not a RT systems cable ) once you see the dstar repeater go green you should be set [Apply Changes]

The setup was linked to REF001 C and when I performed Step 3 I heard a UK station. Yeah!
Last edited by N9KO on Thu Feb 21, 2019 11:29 am, edited 1 time in total.

User avatar
VK7HSE
Posts: 120
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by VK7HSE » Fri Feb 08, 2019 4:48 am

Were any of the serial baud speeds changed from whatever is default in the ID-51P2? I had a heck of a time using the Android app for accessing the G3 Network and in the end it turned out to be the serial speed that was causing the problem. Even if the radio was on the correct speed I'd have to change it and revert it back for it to talk... Not sure if this is what is preventing it from working with pistar. But I'll give it a try again in a few weeks time and see how it goes...

Sent from my Pixel 2 XL using Tapatalk


User avatar
VK7HSE
Posts: 120
Joined: Sun Apr 15, 2018 6:35 pm
Contact:

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by VK7HSE » Fri Feb 08, 2019 7:47 am

VK4TUX wrote:Android app must have a return accessible Ip on the host and 40000 UDP , 12345 UDP & 12346 UDP open incoming to work on G3. W5LND and myself tested access point/erminal mode with the Icom app's regularly just after G3 was introduced, I setup the 6th G3 gateway in Texas. Using the windows app gave best results. You would be using VK7HSE T as your login to VK3RWN IP on the app being your only access point. Did you try from the windows app on your windows PC ? A lot easier to ensure 40000 12345 & 12346 UDP ports are open.
I gave up in the end because 3rwn is only G2 and most likely never get updated! That's why I keen to give it a go with ircddbgateway, I'm most likely going to have to do a full factory reset on the ID-51P2 and then try again as I'm pretty sure that it's a setting in the radio that's not not on the default setup and causing issues with talking across the serial link... Rainy day project I'm sure! Image

Sent from my Pixel 2 XL using Tapatalk


AE5JO
Posts: 4
Joined: Thu Feb 07, 2019 2:30 am

Re: Terminal settings for the ID51s plus2 and v4 RC3

Post by AE5JO » Wed Feb 20, 2019 11:47 pm

Would someone that got it working be kind enough to contact me or refer me to step by step instructions? I feel really stupid because I can't figure this out. [email protected]

Post Reply