New to Pi-star - can't link to any reflector

Help with D-Star related issues
AB1HD
Posts: 3
Joined: Mon Nov 26, 2018 1:39 am

New to Pi-star - can't link to any reflector

Post by AB1HD » Mon Nov 26, 2018 2:09 am

Hi,
I just got a Zumspot the other day. I've watched numerous videos, done many Google searches and I tried many settings with many reboots, but no matter what I do, the dashboard always says "not linked" and I never hear any traffic. I can see that the Zumspot hears me when I transmit on the dashboard and announces that I'm connected to the reflector (REFOO1C), yet the dashboard always says "not linked" and I never hear any D-star traffic.
I am registered on D-Star (done back in 2010), so I don't think that is the issue. I'm just not sure what to do at this point so I'm hoping someone can shed some light on why it's not working.

Thanks,
Rich AB1HD

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: New to Pi-star - can't link to any reflector

Post by KE0FHS » Mon Nov 26, 2018 2:37 am

Hi Rich, REF001 C has been having a lot of trouble lately. Can you connect to a different reflector, like REF030 C?

Also, just to double check: you must use D-STAR Repeater (DR) or Duplex mode: set up RPT1, RPT2, and a zero offset (either +/−0.000).
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AB1HD
Posts: 3
Joined: Mon Nov 26, 2018 1:39 am

Re: New to Pi-star - can't link to any reflector

Post by AB1HD » Mon Nov 26, 2018 2:58 am

Hi,
I've tried numerous reflectors will no luck, but I will try again.

Yes, I'm using Duplex mode with a zero offset.

Thanks,

Rich AB1HD

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: New to Pi-star - can't link to any reflector

Post by KE0FHS » Mon Nov 26, 2018 2:45 pm

When this has happened to me (ZUMspot + TH-D74A), it has almost always been a mistake in my radio setup.

I'm not sure what you've tried so far and how familiar you are with using a hotspot, but a few basic suggestions:
  • The module always has to be in the eighth spot (except for the link command), so if your callsign is five characters, then you have to leave two blank spaces between your callsign and the B or G in the RPT1 and RPT2 fields.
  • For the linking command, the module letter moves into the seventh spot, and L goes in the eighth spot.
  • Once you are linked, you have to switch to a calling channel (UR CALL: CQCQCQ), and at least for the Kenwood HT, it's important that you program that using Direct Input, not Local Call.
Beyond that, take a look in these notes at section 3, especially 3c, to see if something jumps out:
https://amateurradionotes.com/d-star-3.htm
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

9Y4AT
Posts: 6
Joined: Sun Aug 12, 2018 5:15 pm

Re: New to Pi-star - can't link to any reflector

Post by 9Y4AT » Tue Nov 27, 2018 5:56 am

I am having similar issues with a JumboSpot. I run 3.4.16, HAT version v1.3.3, I have set all correctly as best I could, but cannot link to any Refelectors. I have REF 001C set auto on boot, yet it will not connect.

I only have DStar selected in the configuration, I have selected MMDVMhost and Simplex Mode.

Thanks

Jeff

9Y4AT
Posts: 6
Joined: Sun Aug 12, 2018 5:15 pm

Re: New to Pi-star - can't link to any reflector

Post by 9Y4AT » Tue Nov 27, 2018 1:03 pm

I see no errors in the running log, when I send the link command from my Radio, all is normal like the other stations.

USER: 9Y4AT 9Y4AT B 9Y4AT G xxx.xx.xx.xxx

I send the link twice both times same like other users.

on the Dashboard Below
D-Star Network
not linked

seen.

9Y4AT
Posts: 6
Joined: Sun Aug 12, 2018 5:15 pm

Re: New to Pi-star - can't link to any reflector

Post by 9Y4AT » Wed Nov 28, 2018 5:42 pm

I do not see urcall anywhere.

The Pi-star software field that is labeled "D-Star Manager" normally whatever you are linked too it shows there, mines is showing "NOT LINKED" with the system set to link on startup.

So without a radio, the software is set to link automatically on boot to the Refelector set in the configuration page. This is not happening.

nano /var/log/pi-star/ircDDBGatway-......log I see:

Cannot connect to TCP client socket, err=111
Cannot connect to dns.xreflector.net

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: New to Pi-star - can't link to any reflector

Post by KE0FHS » Wed Nov 28, 2018 6:44 pm

Just FYI, I tried connecting to REF001 C and REF030 C from the D-Star Link Manager, and both linked straight away, so it's likely not a problem with the reflectors or with the Pi-Star software itself. My guess is that you have an issue with your network/router, or there is something misconfigured in your Pi-Star setup.
Have you double checked all of your basic configuration settings, including that you have the right Radio/Modem selected?
Are you using a frequency that's approved for use? As of firmware v1.4.12, 435.0 - 438.0 and 145.8 - 146.0 are blocked because they are reserved internationally for satellite communication.

Hopefully someone like CT1DVM, who knows this stuff much better than I do, can offer some additional troubleshooting suggestions.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

AF6VN
Posts: 484
Joined: Fri Jul 20, 2018 1:15 am

Re: New to Pi-star - can't link to any reflector

Post by AF6VN » Wed Nov 28, 2018 7:13 pm

As a second data point, my log (just did a reflector swap) shows

Code: Select all

M: 2018-11-28 18:58:42: Link command from AF6VN  B to REF030 C issued via UR Call by AF6VN
M: 2018-11-28 18:58:42: Removing outgoing D-Plus link AF6VN  B, REF001 C
M: 2018-11-28 18:58:42: D-Plus disconnect acknowledgement received from REF001 C
M: 2018-11-28 18:58:42: D-Plus link to REF001 C has failed
M: 2018-11-28 18:58:42: D-Plus reply is OKRW
M: 2018-11-28 18:58:42: D-Plus ACK message received from REF030 C
M: 2018-11-28 18:58:42: D-Plus link to REF030 C established
<snip>
M: 2018-11-28 18:58:43: USER: AF6VN    AF6VN  B AF6VN  G 76.255.154.65
M: 2018-11-28 18:58:43: USER: AF6VN    AF6VN  B AF6VN  G 76.255.154.65
That's a lot of status messages regarding linking...
KE0FHS wrote:
Mon Nov 26, 2018 2:45 pm
When this has happened to me (ZUMspot + TH-D74A), it has almost always been a mistake in my radio setup.

I'm not sure what you've tried so far and how familiar you are with using a hotspot, but a few basic suggestions:
  • The module always has to be in the eighth spot (except for the link command), so if your callsign is five characters, then you have to leave two blank spaces between your callsign and the B or G in the RPT1 and RPT2 fields.
  • For the linking command, the module letter moves into the seventh spot, and L goes in the eighth spot.
  • Once you are linked, you have to switch to a calling channel (UR CALL: CQCQCQ), and at least for the Kenwood HT, it's important that you program that using Direct Input, not Local Call.
For the TH-D74, it's much easier to use the REFLECTOR menu (hold ^ until menu appears, scroll and select REFLECTOR, scroll to LINK, select reflector [works in fields: reflector type, 3digit number, node letter]. PTT to send link command, may need twice if the hotspot didn't quite sync the first time. Return to REFLECTOR menu, select USE (this configures the CQCQCQ with repeater/reflector fields in place).

--
AF6VN
Dennis L Bieber

User avatar
KE0FHS
Posts: 1110
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: New to Pi-star - can't link to any reflector

Post by KE0FHS » Wed Nov 28, 2018 9:08 pm

AF6VN wrote:
Wed Nov 28, 2018 7:13 pm
For the TH-D74, it's much easier to use the REFLECTOR menu.
I agree that for ad-hoc reflector connections, it's easier to use DR mode and the REFLECTOR menu. Don Arnold, W6GPS, has a good video about that for the TH-D74: Programming TH D74 software for a DVAP using DR mode, Feb 3, 2017 (https://www.youtube.com/watch?v=dNmirLcfVvw (except that, unlike what he shows for the DVAP, when you set up the ZUMspot hotspot in your repeater list, you still need to set up RPT1 and RPT2 with the module in the eighth spot, usually B and G).

Personally, for reflectors and repeaters I use more than once in awhile, I still think it's easier to set them up in memory channels. Once I have them set up, I find the memory channels much faster to use than DR mode and the REFLECTOR menu.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply