Zum radio with two CDM 1250 as a D-Star repeater

Help with D-Star related issues
Post Reply
kf4eok
Posts: 5
Joined: Wed May 01, 2019 3:02 pm

Zum radio with two CDM 1250 as a D-Star repeater

Post by kf4eok » Fri May 03, 2019 5:13 pm

I have a Zum radio board ver .9 I got from HRO.
I have the System Fusion side working good. I am having a hard time getting the D-Star side of things to work. I see all the networking side on the dashboard is working and I am getting a digital transmit out. The problem is that it just sounds like digital noise on my radio. The D-Star mode is green indicating that it is on. I cannot get the DStarRepeater in the service status to turn green. The DMRGateway and YSFGateway will turn green when I turn them on. I have tested System Fusion and it works good. I have not tested DMR as of yet. I am running Pi Zero W Rev 1.1 and Pi-Star Kernel 4.9.35+
I am getting the network traffic and it is being transmitted out the repeater but all you can hear is a digital noise. The receive radios cannot understand or decipher the RF signal. Can anyone help me to get this D-Star working or give me ideas of what to try.
Thanks KF4EOK / Daniel

M1DNS
Posts: 810
Joined: Thu Apr 05, 2018 5:30 am

Re: Zum radio with two CDM 1250 as a D-Star repeater

Post by M1DNS » Fri May 03, 2019 5:46 pm

To take Ur post literally... Dstarrepeater shouldn't be lit green as ur not running Dstarrepeater. Ur setup for the zumboard should be running mmdvmhost. If you have configured for Dstarrepeater in ur setup that won't run with the hardware you have.

If you are running mmdvmhost and the DSTAR mode isn't lit it's most prob. because mmdvmhost can't 'see' the hardware you have. you have either chosen the incorrect modem (mmdvm device) in the config setup or the MMDVM board you have needs an update to a more current firmware version.

You also might need to play with output audio settings to fine tune the audio level that works reliably with ur DSTAR radio. But first, You might want to visit the expert settings admin/expert/edit_mmdvmhost.php and check or uncheck the tx invert setting, save changes, wait for services to restart then try agn.

Andrew M1DNS, (Mod)



Andrew M1DNS.
Pi-star Admin Team.

kf4eok
Posts: 5
Joined: Wed May 01, 2019 3:02 pm

Re: Zum radio with two CDM 1250 as a D-Star repeater

Post by kf4eok » Fri May 03, 2019 6:20 pm

OK I understand the DStarRepeater button will be red because I am not running that, thanks for that clarification.
I do have the controller mode set to MMDVMHost and the controller mode is set to Duplex Repeater.
I have the radio / modem type set to ZUM Radio-MMDVM for Pi (GPIO)
I have tried the tx invert setting in both settings with the same results.
The modes enabled button is green and the network status buttons are green.

M1DNS
Posts: 810
Joined: Thu Apr 05, 2018 5:30 am

Re: Zum radio with two CDM 1250 as a D-Star repeater

Post by M1DNS » Fri May 03, 2019 8:24 pm

Ok green on green is good.

Another thing to look at is within the radio itself.
It's been a while since I've done this but there's a setting in the radio which locks the mode to DSTAR I think it's named (auto) FM detect. Or FM auto detect ?? Disable that as it switches to FM Rx if the radio thinks it's an FM signal. Disabling it will lock the radios digital rx to gmsk DSTAR. and help it decode DSTAR. Then it's prob a little fine tuning on the audio pots on the board, it shouldn't take too much finessing if it's already running well with C4FM.

Andrew M1DNS, (Mod)

Andrew M1DNS.
Pi-star Admin Team.

Post Reply