dstarrepeaterd failing

Help with D-Star related issues
Post Reply
k2dls
Posts: 74
Joined: Mon Aug 20, 2018 5:24 pm

dstarrepeaterd failing

Post by k2dls » Tue Jul 02, 2019 2:22 pm

I noticed that my DVAP had stopped responding a few times this morning and did a couple of reboots. When the problem persisted, I checked to see if dstarrepeaterd was running. It was not. So I did a restart of the process. The problem reoccured rather quickly. From the systemd journal:

Jul 02 09:44:02 pi-star systemd[1]: Starting D-Star Radio Servce...

Jul 02 09:44:02 pi-star dstarrepeater.service[8235]: dstarrepeaterd started as PID 8250

Jul 02 09:44:02 pi-star systemd[1]: Started D-Star Radio Servce.

Jul 02 09:45:04 pi-star systemd[1]: dstarrepeater.service: Main process exited, code=killed, status=11/SEGV

Jul 02 09:45:04 pi-star dstarrepeater.service[8282]: dstarrepeaterd is not running

Jul 02 09:45:04 pi-star systemd[1]: dstarrepeater.service: Control process exited, code=exited status=1

Jul 02 09:45:04 pi-star systemd[1]: dstarrepeater.service: Unit entered failed state.

Jul 02 09:45:04 pi-star systemd[1]: dstarrepeater.service: Failed with result 'signal'.

It looks like the dstarrepeaterd binary was updated early this AM during the daily update cycle. I'm running on an older ARMv6 RPI Model B. It had been running fine for about a year. Currently using RC4.

User avatar
w7efs
Posts: 308
Joined: Sun Apr 22, 2018 4:26 pm

Re: dstarrepeaterd failing

Post by w7efs » Tue Jul 02, 2019 2:59 pm

This issue was addressed in viewtopic.php?f=3&t=1921

k2dls
Posts: 74
Joined: Mon Aug 20, 2018 5:24 pm

Re: dstarrepeaterd failing

Post by k2dls » Tue Jul 02, 2019 5:23 pm

Thank you.

Post Reply