Callsign change/strange ircddbgateway problem

Help with D-Star related issues
Post Reply
k2dls
Posts: 74
Joined: Mon Aug 20, 2018 5:24 pm

Callsign change/strange ircddbgateway problem

Post by k2dls » Thu Sep 05, 2019 2:39 pm

My callsign was changed yesterday from K2DLS (1x3) to K2IE (1x2). The D-Star gateway registration was updated about 24 hours ago. A registration check via https://www.pistar.uk/d-star_regcheck.php returns the expected results.

Yet, I'm having a rather strange problem. I run a single ircddbgateway on the same Pi-Star instance as K2IE-C. I also have a K2IE-B module, which uses the ircddbgateway instance running on the same RPi as K2IE-C. K2IE-B is a Zumspot/Pi Zero W combo, K2IE-C runs on an RPi B+ (swapped out yesterday from an RPI B because it was way too slow under Buster) with a 2m DVAP. This architecture worked fine for months as K2DLS. Custom firewall rules had to be added (and were disucssed some months ago on another thread) to facilitate communication between the B and C modules.

Since the callsign change, K2IE-B is working but K2IE-C (the one on the same host as ircddbgateway) is not. Here is what I am seeing in the ircddbgateway log:

M: 2019-09-05 14:35:18: Header received from unknown repeater, K2IE C
M: 2019-09-05 14:35:18: Header received from unknown repeater, K2IE C

From dstarrepeater log:

M: 2019-09-05 14:35:18: Radio header decoded - My: K2IE H/2820 Your: CQCQCQ Rpt1: K2IE C Rpt2: K2DLS G Flags: 40 00 00
M: 2019-09-05 14:35:19: AMBE for K2IE H Frames: 0.7s, Silence: 3.0%, BER: 0.0%
M: 2019-09-05 14:35:19: Transmitting to - My: K2IE C/ Your: K2IE H Rpt1: K2IE G Rpt2: K2IE C Flags: 01 00 00

So I'm focused right now on an ircddbgateway issue. And remember, the SAME ircddbgateway passes the traffic from K2IE-B, which is on a different host. Any suggestions?

k2dls
Posts: 74
Joined: Mon Aug 20, 2018 5:24 pm

Re: Callsign change/strange ircddbgateway problem

Post by k2dls » Thu Sep 05, 2019 4:13 pm

Fixed.

Somehow, Pi-Star ended up changing some gateway and repeater addresses in the dstarrepater and ircddbgateway configs. I took at look at a backup from last week and then figured out what happened.

I don't know why Pi-Star did this, perhaps something for Andy to look at.

For my config to work, I bind ircddbgateway to all interfaces. That wasn't changed, but it two cases, loopback addreses in both were replaced by external interface addresses, but not consistently and not by me!

73

k2dls
Posts: 74
Joined: Mon Aug 20, 2018 5:24 pm

Re: Callsign change/strange ircddbgateway problem

Post by k2dls » Thu Oct 03, 2019 11:26 pm

Update to RC6 broke my config again!

Somehow the repeaterAddress1 is being changed back to 127.0.0.1 from the external interface where I had set it.

Post Reply