"D-Star Net" Spontaneously Disconnecting

Help with D-Star related issues
Post Reply
KN4FYR
Posts: 12
Joined: Wed Apr 11, 2018 12:19 pm
Contact:

"D-Star Net" Spontaneously Disconnecting

Post by KN4FYR » Thu Sep 26, 2019 11:46 pm

Good day!

Running the RC5 version on an RPi3B+ with a DVMega with latest firmware, and MMDVM with only DStar enabled. I've re-imaged a few times using new SD cards and still have the following problem.

Upon boot, the system runs just fine but eventually the "DStar Net" indicator goes red. A quick reboot fixes everything and it works fine until it disconnects again.

I've had multiple Pi-Stars running for months and months and this is a relatively new behavior. I suspect that this is a router issue, perhaps something to do with UPnP. Rebooting the router does not restore the "D-Star Net" indicator to green and resetting the router to factory defaults is a problem since I have a zillion ports forwarded to other devices. All the Pi-Stars rely on UPnP and I have no ports forwarded to the PiStars.

Any thoughts? I'm out of ideas.

Thanks and 73!

Dan
KN4FYR

KN4FYR
Posts: 12
Joined: Wed Apr 11, 2018 12:19 pm
Contact:

Re: "D-Star Net" Spontaneously Disconnecting

Post by KN4FYR » Sat Sep 28, 2019 9:10 pm

Not certain yes, but I may have solved it.

Looking through the logs, I found a certain error message repeatedly. Googling it, I found that the errors were caused by a static APRS server that was either offline or behaving badly. Changing to the round robin URL as I now know is recommended instead of the static server has eliminated the errors in the Pi-Star logs, so I think I'm in the clear.

73
Dan
KN4FYR

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: "D-Star Net" Spontaneously Disconnecting

Post by KE0FHS » Sat Sep 28, 2019 9:22 pm

Good find!
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KN4FYR
Posts: 12
Joined: Wed Apr 11, 2018 12:19 pm
Contact:

Re: "D-Star Net" Spontaneously Disconnecting

Post by KN4FYR » Sun Sep 29, 2019 7:54 pm

Thanks! That'll teach me to be sure to check the Pi-Star logs for cues before I give up. There's nearly always a clue or two buried in there if you're willing to go hunting. In truth, I kinda dig that sort of troubleshooting.

Post Reply