Can listen but not talk out

Help with D-Star related issues
G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Can listen but not talk out

Post by G8FKL » Mon Oct 21, 2019 4:43 pm

Trying to get my Icom IC-9100 to talk D-STAR via DV-Mega/Pi2ModB hotspot running PS 3.4.17.

I'm receiving fine on Reflector REF001C but can't seem to get anyone to hear me. Icom DV settings as follows (* = space). As you'll see I am receiving time accouncements fine.

Name: HotSpot
Receive Frequency: 438.800
Offset Frequency: 0.000
Duplex: -DUP
Repeater Call Sign: G8FKL**B
Gateway Call Sign: G8FKL**G
Rpt1 Use: Yes
MyCall: G8FKL
UrCall: CQCQCQ

Screen grabs attached (exact location obscured - but visible on QRZ.

Advice welcome please.

Image

Image

Image

M1DNS
Posts: 406
Joined: Thu Apr 05, 2018 5:30 am

Re: Can listen but not talk out

Post by M1DNS » Mon Oct 21, 2019 5:29 pm

I don't know the setup for the 9100 but,
What other options do you have in the UrCall field ?
Later generation mobile and handheld icom radios had
cqcqcq use repeater or cqcqcq use reflector?

If so, try using those instead of the plain cqcqcq entry.

Also no mention of rpt2. usually setting to duplex mode enables rpt2
but you don't show that in ur lineup above?
Watch the livelogs from the dashboard when you keyup.
they might give a better indication of what it is, or isn't doing.

One another thing to try is setting the mode type to public.
You shouldn't need to if the config / radio is matched, but it's a crude fix if not.

Andrew M1DNS, (Mod)









Andrew M1DNS.
Pi-star Admin Team.

G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Re: Can listen but not talk out

Post by G8FKL » Mon Oct 21, 2019 5:33 pm

Thanks Andrew. I believe it's free text entry. I'll give both a try in a little while. 73s.

G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Re: Can listen but not talk out

Post by G8FKL » Mon Oct 21, 2019 8:38 pm

No go I'm afraid. There's an 8-character limit on the entry.

Can't check at the moment but I believe RPT2 is set to G8FKL**G

ct1dvm
Posts: 162
Joined: Thu Apr 19, 2018 6:34 am

Re: Can listen but not talk out

Post by ct1dvm » Tue Oct 22, 2019 11:00 am

Yes I have seen this issue with the 9100.
Last edited by ct1dvm on Thu Oct 24, 2019 10:50 am, edited 1 time in total.

G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Re: Can listen but not talk out

Post by G8FKL » Tue Oct 22, 2019 3:47 pm

Thanks all for the suggestions. I am a bit further along but still not able to call out. The radio is to blame I think.

Programming the IC-9100 from the front panel I have this:
Ur: CQCQCQ My: G8FKL
R1: G8FKL B R2: GW
But there's no place in the radio to program in a reflector. The Pi-Star is set to REF001C. Have tried both public and private node settings. The dashboard reports thus:

Image

So it's clearly seeing my signal but not getting to the reflector.

G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Re: Can listen but not talk out

Post by G8FKL » Tue Oct 22, 2019 4:12 pm

Update to my previous. By changing the radio Ur: to REF001C I was able to call out and just had a brief chat with a ham in Canada. Pi-Star reporting the following which is different to what I see on every other entry:
Image

Can I stick with this as a working config or do I need to make further edits?

73s.

AF6VN
Posts: 271
Joined: Fri Jul 20, 2018 1:15 am

Re: Can listen but not talk out

Post by AF6VN » Tue Oct 22, 2019 4:18 pm

Perusing https://www.icomamerica.com/en/download ... cument=545
Page 88 (emphasis mine):
You can store repeater information for quick and simple
communication in up to 500 repeater memory channels
(Repeater list) in up to 10 Groups. Programming
the repeater list is required for DR mode operation
Note: if the 9100 is similar to my Kenwood -- to use a hotspot you MUST be in DR mode, not DV mode. DV mode is basically direct (radio to radio) or local repeater only, and does not transmit the information needed to have calls gatewayed to other systems. (Possibly Icom lets one set everything and somehow figure out which mode to use, but DR mode with a defined "repeater" for the hotspot seems simpler)

Page 89-91 cover how to add your hotspot as a "repeater".

Page 99 covers using that defined repeater.

The manual doesn't have anything specific for reflectors, so you'd have to manually dial in the correct link/unlink commands in the UR field (once you get the "repeater" itself working). Kenwood implemented a "destination select" menu with choices for local, gateway, individual, reflector, where the latter gives entries for link (brings up menu to spell out reflector), unlink, info, an "use reflector" (sets CQCQCQ and proper repeater mode).

--
AF6VN
Dennis L Bieber

AF6VN
Posts: 271
Joined: Fri Jul 20, 2018 1:15 am

Re: Can listen but not talk out

Post by AF6VN » Tue Oct 22, 2019 4:38 pm

G8FKL wrote:
Tue Oct 22, 2019 4:12 pm
Image

Can I stick with this as a working config or do I need to make further edits?
That seems to be showing a reflector LINK command line... If so, every time you PTT, you are instructing the server to (re)link you to the reflector.

Here is the sequence via my Kenwood...
Image

12:25:35 is my sending the LINK command for REF030C
12:25:38 is my hotspot announcing "linked to ..."

I then set the Kenwood to "Use Reflector" (via menu) and it sets the UR to CQCQCQ. Pressing PTT results in "Target" showing just CQCQCQ

--
AF6VN
Dennis L Bieber

G8FKL
Posts: 11
Joined: Sun Apr 28, 2019 1:56 pm

Re: Can listen but not talk out

Post by G8FKL » Wed Oct 23, 2019 12:09 pm

I think this has something to do with the Icom being a 1st generation D-STAR implementation. The 'L' on the end of the UR: entry was inserted by the radio, not by me. A second entry, UR01 is set to *******U (*=space).

Am I doing something wrong in linking every time I press the PTT button? I don't want to be hogging resources or monopolising the reflector.

Post Reply