Pi-Star 4.1.14 Internet Connection issue

Help with D-Star related issues
Post Reply
KB1MKY
Posts: 6
Joined: Thu Jun 07, 2018 12:21 pm

Pi-Star 4.1.14 Internet Connection issue

Post by KB1MKY »

Hi,
I've upgraded to the latest version of Pi-star and now have a strange issue. Running Pi 3B with zumspot GPIO single band. The issue is that the Pi has internet access. Full access no issues. Pi-Star apparently does not. No ircDDB access nor will it link to any gateways or repeaters. It does seem to run the nightly updates though...Very strange. Could this be a port issue or is it something different?

Thanks
Alex
AF6VN
Posts: 592
Joined: Fri Jul 20, 2018 1:15 am

Re: Pi-Star 4.1.14 Internet Connection issue

Post by AF6VN »

Sounds like your router may not be doing uPnP (used, as I recall, to set the special ports needed). Standard ports (#s <1024 or so; used by various update mechanisms) are likely handled correctly.

--
AF6VN
Dennis L Bieber
KE7FNS
Pi-Star Team
Posts: 1944
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KE7FNS »

KB1MKY wrote: Mon Jun 14, 2021 3:05 pm Could this be a port issue or is it something different?
I agree with AF6VN. Check your router for UPNP settings and enable it if possible. If you don't have UPNP, then you will need to do some manual port forwarding.

It could also be possible your ISP blocks certain ports so you might have to talk to the ISP technical support.

port forwarding info here:
http://wiki.pistar.uk/Ports_to_forward_ ... NP_network
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
KB1MKY
Posts: 6
Joined: Thu Jun 07, 2018 12:21 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KB1MKY »

Hi agian
Thanks for those suggestions. The network is uPnP enabled. I also, as just a matter of course for these things, have the appropriate ports forwarded. I don't think it's an ISP issue as the device doesn't connect on either of my ISPs, Spectrum or Verizon. I know for a fact that it worked on verizon before I updated as that was how I was using it mobile. I'll keep digging on this.
Again thanks for the suggestions.
73
Alex
KB1MKY
KE7FNS
Pi-Star Team
Posts: 1944
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KE7FNS »

KB1MKY wrote: Tue Jun 15, 2021 10:56 am I know for a fact that it worked on verizon before I updated as that was how I was using it mobile.
Then it might of been one of the recent updates.

Are you trying to use DTMF and link/unlink repeaters?
if so: viewtopic.php?p=19149#p19149

If not can you explain in more detail what you are trying to do?
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
KB1MKY
Posts: 6
Joined: Thu Jun 07, 2018 12:21 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KB1MKY »

KE7FNS wrote: Tue Jun 15, 2021 7:12 pm
KB1MKY wrote: Tue Jun 15, 2021 10:56 am I know for a fact that it worked on verizon before I updated as that was how I was using it mobile.
Then it might of been one of the recent updates.

Are you trying to use DTMF and link/unlink repeaters?
if so: viewtopic.php?p=19149#p19149

If not can you explain in more detail what you are trying to do?
Not using DTMF for anything, It won't connect anywhere. No REF, XRF, DCS connections or anything else. The options to connect are there but it won't connect. Like I said the Pi itself has full internet access, the Pi-Star software has update access but nothing else. It's very odd.
KE7FNS
Pi-Star Team
Posts: 1944
Joined: Wed Apr 17, 2019 11:11 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KE7FNS »

KB1MKY wrote: Thu Jun 17, 2021 7:45 pm Not using DTMF for anything, It won't connect anywhere. No REF, XRF, DCS connections or anything else. The options to connect are there but it won't connect. Like I said the Pi itself has full internet access, the Pi-Star software has update access but nothing else. It's very odd.
I'd reimage the SD card, and start over fresh and test it.

Then if that works, I would update it manually and test again.

And if it still works at that point I would restore your backup settings and test again.

If its the update that killed it, things should fail after the update, if its a setting you have in your configuration it should fail when you restore your settings.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
KB1MKY
Posts: 6
Joined: Thu Jun 07, 2018 12:21 pm

Re: Pi-Star 4.1.14 Internet Connection issue

Post by KB1MKY »

Good Idea, I'll give it a shot.
Thanks!
Post Reply