Raspberry Pi 3A+ WiFi issue

Help setting up WiFi
User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Raspberry Pi 3A+ WiFi issue

Post by KE0FHS » Sat Oct 19, 2019 3:49 pm

KB1B wrote:
Sat Oct 19, 2019 10:01 am
Similar to raspi-config, people can run:
sudo dpkg-reconfigure locales

I set the locale in /etc/environment and also do the following the following:
sudo pistar-update
sudo locale-gen
Tried this procedure with two 4.1.0-RC6 hotspots this morning: disabled the default en_GB.UTF-8 UTF-8 and selected en_U.UTF-8 UTF-8S, and also selected en_US.UTF-8 as the default locale for the system environment.
  • The first was an RPi 4B-based one, and it worked fine.
  • The second is an RPi 3A+ hotspot, and while it changed the default locale, it failed to changed the default locale for the system environment. Tried it multiple times, but it kept hanging at the following stage, whether I ran the sudo dpkg-reconfigure locales command or the sudo locale-gen command:

Code: Select all

[email protected](ro):~$ sudo locale-gen
Generating locales (this might take a while)...
  en_US.UTF-8...
At that point, the SSH windows froze (ctrl+c didn't work), and the only way to recover was by using a hard restart on the hotspot and by quitting the SSH app. Not pretty.

Too early to say whether it had any effect on the WiFi issue.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KB1B
Posts: 4
Joined: Sun Oct 13, 2019 11:31 pm

Re: Raspberry Pi 3A+ WiFi issue

Post by KB1B » Sat Oct 19, 2019 7:13 pm

Interesting. It takes a while but I'm not sure why this would hang.
A friend says his PiStar/RPi3A+ fails to connect to WiFi so I'm going to look at it an report what I discover.
Can you try this: and tell me what happens?
rpi-rw
sudo dpkg-reconfigure locales

I re-read this thread and perhaps the RPi3A+ just has poor quality control and produced boards with borderline-bad WiFi chips?
Several people said they take the same TF/SD-card out of a dysfunctional RPi 3A+ and put it into another RPi X+ and then it works!

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Raspberry Pi 3A+ WiFi issue

Post by KE0FHS » Sat Oct 19, 2019 7:25 pm

I took a different approach. I moved the microSD card from the RPi 4B hotspot that worked for resetting the locale and moved it the 3A+ hotspot, where it works fine, as expected. Then I flashed a fresh 4.1.0 image on the RPi 4B hotspot, did all the configuration, updating, and upgrading, then ran sudo dpkg-reconfigure locales, which worked. Now we'll see if that helps the underlying WiFi issue on the two hotspots (despite the title of this topic, I have had WiFi issues with my 4B hotspot, too).
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

KE7FNS
Posts: 416
Joined: Wed Apr 17, 2019 11:11 pm

Re: Raspberry Pi 3A+ WiFi issue

Post by KE7FNS » Sat Oct 19, 2019 8:21 pm

KE0FHS wrote:
Sat Oct 19, 2019 3:49 pm

Code: Select all

[email protected](ro):~$ sudo locale-gen
Generating locales (this might take a while)...
  en_US.UTF-8...
That shows it was in still in RO mode and I'll bet thats why it failed. I know I've put it in RW mode and gone to compile something and in the middle of the compile, it fails with cannot write to disk. The background stuff that happens to kick it into RO can be fairly annoying when it does it when you don't want it to.
All views, comments, posts and opinions shared are entirely my own.

User avatar
KE0FHS
Posts: 1067
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Raspberry Pi 3A+ WiFi issue

Post by KE0FHS » Sat Oct 19, 2019 9:01 pm

I wondered about that, but whenever I ran the command successfully, starting in ro mode, it would finish in rw mode, so I figured the script must include switching to rw mode.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

ea7gwc
Posts: 22
Joined: Wed Apr 11, 2018 3:53 pm

Re: Raspberry Pi 3A+ WiFi issue

Post by ea7gwc » Sun Oct 20, 2019 9:18 pm

KB1B wrote:
Sat Oct 19, 2019 7:13 pm
I re-read this thread and perhaps the RPi3A+ just has poor quality control and produced boards with borderline-bad WiFi chips?
Several people said they take the same TF/SD-card out of a dysfunctional RPi 3A+ and put it into another RPi X+ and then it works!
I put the same microsd to a pi3 b + and there is no
wifi boot issues.
That same card in a PI3 A + sometimes has serious problems of
boot wifi. Once it starts well, the A + works perfectly and the wifi is stable, so I think my card is fine.

Also with Raspbian Buster there are no problems with the PI3 a + and
It always starts well.

So I think I think something goes wrong in PI-star.
73

Post Reply