new router problems

Help setting up WiFi
Post Reply
k0fg
Posts: 2
Joined: Thu Apr 01, 2021 1:22 am

new router problems

Post by k0fg »

Hate to ask this question again but I read dozens of posts and have not found an answer.

Bought a new router after using pi-star on the old one successfully for a couple years. Got the new router setup and can use the mmdvm zero w hotspot with it running pi-star v 4.1.5, or the newest version whatever it is. Trying to figure out how to connect to different wi-fi systems while traveling and staying at motels, friends houses, etc.

I did a system reset on the old router, that would make it a new wi-fi system, then plugged it in and let it boot up, connected the pc to the wi-fi just fine. On the available wi-fi connections I see one called pi-star, not pi-star-setup, but just pi-star. Cannot connect to it, tried every password I've used in the past 2 years, including the default. Go to a browser and try using http://pi-star.local/ --- no joy, said cannot find it. But the hotspot is flashing a rapid red light, which I think means it is connected to a wi-fi system.

If I put a wpa-supplicant file on the sd card pointing to the old router then it connects to the old router ok. But then when I change back to the new router it does the same kind of routine, can't connect no matter what, unless I put a wpa file on the sd card pointing to the new router, then it connects .

Cannot find a way to connect to the hotspot unless I use a wpa file and that is not good when traveling.

The hotspot shows it is connected, and pi-star shows on the available wi-fi systems available but cannot connect.

AP is turned on, at least it was last time I got connected to the hotspot.

Fred, K0FG
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: new router problems

Post by KE7FNS »

k0fg wrote: Wed Jan 12, 2022 9:52 pm Trying to figure out how to connect to different wi-fi systems while traveling and staying at motels, friends houses, etc.
It isn't very easy. The easiest thing would be to simply connect to the AutoAP every time you want it to connect to a different network and enter those specific network details every time.
k0fg wrote: Wed Jan 12, 2022 9:52 pm On the available wi-fi connections I see one called pi-star, not pi-star-setup, but just pi-star.
It is named "pi-star-setup" on freshly imaged SD cards, on older setups that have already been through the configuration pages, it gets renamed to whatever the hostname is set too. Normally the hostname is defaulted to "pi-star", or it is named whatever you have entered in the configuration in the hostname field.
k0fg wrote: Wed Jan 12, 2022 9:52 pm Cannot connect to it, tried every password I've used in the past 2 years, including the default.
The default is " raspberry" all lowercase. Also raspberry has a silent p in it.

If you changed the AutoAP password using the dashboard configuration page, it is whatever you changed it to.

The following will show you what the password is set to: type the command from the command line. the password is only the text to the right of the = sign.

Code: Select all

grep wpa_passphrase /etc/hostapd/hostapd.conf
k0fg wrote: Wed Jan 12, 2022 9:52 pm Go to a browser and try using http://pi-star.local/ --- no joy, said cannot find it. But the hotspot is flashing a rapid red light, which I think means it is connected to a wi-fi system.

There is no point in trying to access a network device when it isn't connected to any network.

Since the AutoAP is available that means it cannot be connected to the wifi network. If it is connected to the wifi network you cannot see the AutoAP. It can only do one or the other not both.

The blinking red SRV/SVC LED on the hat does not mean it is connected to wifi (in fact nothing on the hat has anything to do with wifi). The RPi has a green LED that indicates SD card file access, and a red LED that is solid indicating power is applied. There is not a wifi connected indicator LED. The blinking SRV/SVC LED just indicates that if it is flashing slowly no communications with the background software has happened, and if it is blinking fast that communication has happened.
k0fg wrote: Wed Jan 12, 2022 9:52 pm If I put a wpa-supplicant file on the sd card pointing to the old router then it connects to the old router ok.
Ok.
k0fg wrote: Wed Jan 12, 2022 9:52 pm But then when I change back to the new router it does the same kind of routine, can't connect no matter what, unless I put a wpa file on the sd card pointing to the new router, then it connects .
Theres a few things here that you are not understanding.

This second router needs to be setup with the identical options as your other router, and it also would need the identical SSID, and PSK entered in it. It would probably just be easier to use a new wpa_supplicant.conf file specifically for this router, so it would have its own unique SSID and PSK.

It also could be on the wrong band, RPi Zero W's do not have 5GHz capability and can never connect to routers that only provide a single 5GHz band. You need to see if this new router has 2.4 Ghz capabilities and use it.

It could also be using a different encryption setting. Should be using WPA2-PSK.
k0fg wrote: Wed Jan 12, 2022 9:52 pm Cannot find a way to connect to the hotspot unless I use a wpa file and that is not good when traveling.
Yeah, it isn't meant for traveling, its meant to connect to the same router every time. You'll have to manually configure every new network you want it to connect to. By either using the wpa_supplicant.conf file, or using a web browser on a smartphone, tablet or laptop and the AutoAP.
k0fg wrote: Wed Jan 12, 2022 9:52 pm The hotspot shows it is connected, and pi-star shows on the available wi-fi systems available but cannot connect.
I don't understand what is showing as connected, and to what. You said it connected to your old router, but won't ever connect to the new one.
k0fg wrote: Wed Jan 12, 2022 9:52 pm AP is turned on, at least it was last time I got connected to the hotspot.
AP being turned on, just means that if it cannot connect to a wifi network after 120 seconds, it will deploy its own AP and wait for you to connect to it to configure the settings for a network you want to connect to.

Again, you cannot connect to 5Ghz networks (not to be confused with 5G cellular networks, you can't connect to those either) with a RPi Zero W.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
k0fg
Posts: 2
Joined: Thu Apr 01, 2021 1:22 am

Re: new router problems

Post by k0fg »

If I burn a new image to sd card the AP kicks in and gives me a pi-star-setup option in available wi-fi and I go thru the setup routine and connect just fine to router A. Then I turn off everything, boot the cable modem, boot router B, boot pi-star. Get the pi-star-setup wi-fi and connect to the pi-star. Then I go to the wi-fi info area, scan for new wi-fi and it finds router B. But no matter what I do it will not connect to router B wi-fi. Enter info for router B, click on save and connect, then click on power and let the hotspot reboot - no wi-fi connection.

Shut off everthing, burn a new pi-star image to the sd card. Reboot everything just like before only this time router B is plugged in. Get the pi-star-setup and connect to router B. All is well. Then I turn off everything, reboot it all but this time I have router A in line. And now I cannot connect to router A.

I connect fine to whichever router is online when I use a fresh image of pi-star on the sd card. But I can never change routers and connect pi-star to a different wi-fi unless I burn a new image before trying to connect.

Fred, K0FG
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: new router problems

Post by KE7FNS »

k0fg wrote: Fri Jan 14, 2022 4:24 pm Then I turn off everything, boot the cable modem, boot router B, boot pi-star. Get the pi-star-setup wi-fi and connect to the pi-star.
I think you are making this way more complicated than it needs to be.

Simply connect the hotspot to router A, and while still connected to router A add the new network for router B using the dashboard. Save it and you are done. When router A is online it will connect to router A, when router B is online it will connect to router B. If both are online it should connect to router A because of the priority since it was added first.

If you wanted to do this same procedure using the wpa_supplicant.conf file, you'll need to manually edit the file to contain both networks. You create two wpa_supplicant.conf files (one for each unique network), and then open one in notepad or some standard text editor then copy the network section from one file and paste it into the other and save, then copy that new file (with multiple networks) to the SD card and boot it.

Code: Select all

network={
        #ssid="router-A"
        ssid=8903147598375908347590238475903847590234785
        #psk="router-A-PSK"
        psk=9038790238475902384572390485723905790234857023948
}

network={
        #ssid="router-B"
        ssid=98234759023759023875902387590234857
        #psk="router-B-PSK"
        psk=2390485720398572903857239085729038457
}
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
KE7FNS
Pi-Star Team
Posts: 2429
Joined: Wed Apr 17, 2019 11:11 pm

Re: new router problems

Post by KE7FNS »

KE7FNS wrote: Thu Jan 13, 2022 12:01 am It isn't very easy. The easiest thing would be to simply connect to the AutoAP every time you want it to connect to a different network and enter those specific network details every time.
Just to explain my reasoning of why I said something different earlier.

The difference is because you said you were going to be traveling and you probably won't know the wifi network credentials beforehand and be able to add them while you are connected to a network.

So in your other case with router A and router B, you currently know both network credentials so there is no reason you can't add them both at once.


Also, the wpa_supplicant.conf file. The wifi builder only creates a file with one network in it, and if you place another networks configured wpa_supplicant.conf file on the SD card, it will overwrite all of the previous network settings, it does not add to them.

So if you use a wpa_supplicant.conf file for router A, and then copy a wpa_supplicant.conf file for router B, it will overwrite A, and will only be able to connect to router B. So you need to be aware that this may happen and it might explain why you cannot connect to router A anymore. I don't believe the AutoAP overwrites previous settings and it should allow you to add the network info for router B. So I'm not sure what you are doing that is causing your issue, but I don't believe the tools are the cause of it.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
Post Reply