Connection issue

Help setting up WiFi
Post Reply
ka2qit
Posts: 1
Joined: Sun Aug 26, 2018 9:10 pm

Connection issue

Post by ka2qit » Fri Aug 31, 2018 7:19 pm

Had working on wifi network, went into dashboard and deleted one unused network and added a new cellular phone hotspot network. The field gave it the same network number 1 as home network. Could this have caused a conflict? How would I resolve this no longer having wifi access to the device. Tnx 73 Bob

N3GBJ
Posts: 8
Joined: Sun Jun 03, 2018 12:30 am

Re: Connection issue

Post by N3GBJ » Thu Sep 13, 2018 6:00 pm

I had something similar happen. Drove me absolutely nuts. I'm using 3.4.16

I went on vacation and prior to leaving added a second network entry (SSID and password) in Pi-Star for the hotel where I was staying as I've been there before and the network settings are stored in my notebook PC. I arrived, fired up the Zumspot, and found no activity. I couldn't find Pi-Star with the usual "pi-star.local" so I tried sniffing the IP address but wasn't surprised when I couldn't find it since good hotels prevent such snooping. My notebook PC was connecting to the network with no problems so I setup my notebook to be a wireless hotspot with its own SSID, password, and subnet which allowed me to snoop. I wasn't thinking at the time -- I should have given the notebook wireless the same SSID and password as my home network. No matter. I finally got all to work by putting a new wpa.supplicant file on the SD card with the settings for my notebook hotspot. I forgot about the Auto AP which my Pi will support.

It was strange, though. I did some experimentation and discovered inconsistent network operation with two network entries saved in Pi-Star.

Before leaving to go home with all working just fine, I added my home network and SSID as a second network in Pi-Star (WLAN1) with my notebook hotspot as the first entry (WLAN0.) I got home, fired up the Zumspot and the Zumspot eventually connected to the second network, my home network, but there was no connection to the YSF gateway (I had it configured for DMR2YSF using DMR GATEWAY.) I deleted the first network network entry, which I no longer needed, saved the changes which promptly locked me out of Pi-Star. I waited several minutes but did not see the Zumspot appear in the IP sniff so I reluctantly had to pull the plug, then plug back in to restart theZumspot and then saw the Auto AP "Pi-Star" network appear in my list of wireless networks several minutes later. I did an IP sniff and the Pi-Star was not there. I connected to "Pi-Star" network, connected to Pi-Star, and discovered that deleting the first network deleted everything or at least gave that appearance. I had to start over with brand new network settings. I get a network connection, save it, but still promptly got locked out of Pi-Star. I had to pull the Zumspot plug again after waiting several minutes with no connection, then power it back up and then all worked fine.

I don't know if something got messed up with all of this bad plug-pulling which I don't like to do -- so I went into SSH and did a "sudo pistar-update" and had it refresh. I haven't had time to see if that changed anything. But, I learned not to keep two network entries in Pi-Star for now as doing so, at least for me, causes erratic operation. I can use my notebook PC as a hotspot and I have its SSID and password the same as my home network so I can go through that for the few times that I the Zumspot on vacation and not have to change network settings in Pi-Star.

Post Reply