SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Help setting up WiFi
Post Reply
af5bc
Posts: 6
Joined: Fri Jan 04, 2019 4:37 pm

SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by af5bc » Tue Feb 19, 2019 4:07 am

I'm trying to setup a mobile hot spot using a Raspberry PI 3A+.

I've burned a fresh SDCARD with beta 4.0 RC3 and installed it in on a RPI 3A+ with a MMDVM_HS_dual_hat. The MMDVM board has a small Nextion display attached. I have everything working except Wifi.

When setting up the host spot I used a USB to Ethernet adapter. When I reboot the host spot with the USB Ethernet adapter disconnected, the wifi doesn't connect and the Nextion display shows MMDV host stopped.

I've added two different wifi networks. Also, tried enabled and disabled AP mode. Note, when AP mode was enabled, my android tablet was not able to connect to it.

Any tips?
Last edited by af5bc on Wed Feb 20, 2019 3:03 am, edited 1 time in total.

User avatar
KE0FHS
Posts: 722
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by KE0FHS » Tue Feb 19, 2019 2:44 pm

Have you tried all the usual suspects?
  • A space in the network name can cause problems connecting to some routers.
  • Some radio/modem boards require the WPA or WPA2 security standard, and won't work with WEP.
  • Make sure your wireless network doesn't have "Wireless Isolation" enabled, which could prevent your computer and hotspot from communicating with each other.
  • Might help to reboot your router, too.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

af5bc
Posts: 6
Joined: Fri Jan 04, 2019 4:37 pm

Re: Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by af5bc » Tue Feb 19, 2019 4:56 pm

Thanks. I should comment that the same wireless networks work on a pi zeroW running 3.17.

I'm hoping to get rid of the piZeroW and switch to RPI 3A+ for my mobile setup.

Tonight, I'm going to test the same setup on a 3B+ and a 3B to try to isolate the culpurat.

User avatar
KE0FHS
Posts: 722
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by KE0FHS » Tue Feb 19, 2019 5:13 pm

af5bc wrote:
Tue Feb 19, 2019 4:56 pm
I'm hoping to get rid of the piZeroW and switch to RPI 3A+ for my mobile setup.
Same here. I really like the RPi 3A+. It's a nice balance between speed, capacity, and size.

FYI, I've got three RPi 3A+ hotspots (one ZUMspot v0.4, one ZUMspot v0.6, and one MMDVM_HS_Hat v6) running Pi-Star 4.0.0-RC3 with no network-related issues.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

af5bc
Posts: 6
Joined: Fri Jan 04, 2019 4:37 pm

Re: Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by af5bc » Tue Feb 19, 2019 6:15 pm

KE0FHS wrote:
Tue Feb 19, 2019 5:13 pm
FYI, I've got three RPi 3A+ hotspots (one ZUMspot v0.4, one ZUMspot v0.6, and one MMDVM_HS_Hat v6) running Pi-Star 4.0.0-RC3 with no network-related issues.
Are they all three running WiFi?

User avatar
KE0FHS
Posts: 722
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by KE0FHS » Tue Feb 19, 2019 10:47 pm

af5bc wrote:
Tue Feb 19, 2019 6:15 pm
Are they all three running WiFi?
Yes, I use only WiFi for my hotspots at home (Android hotspot when mobile).
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

af5bc
Posts: 6
Joined: Fri Jan 04, 2019 4:37 pm

SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by af5bc » Wed Feb 20, 2019 2:59 am

I had to manually generate the wpa_supplicant.conf. It had the wrong country code, and it didn't have the proper key_mgmt value.

Also, I used the " wpa_passphrase" command to generate the "psk" value. Here is my new wpa_supplicant.conf file (with SSID and PSK values removed - you will need to generate your own).
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
ap_scan=1
fast_reauth=1
country=US

network={
scan_ssid=1
ssid="<REMOVED>"
psk=<REMOVED>
key_mgmt=WPA-PSK
id_str="0"
priority=100
}

User avatar
w7efs
Posts: 198
Joined: Sun Apr 22, 2018 4:26 pm

Re: SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by w7efs » Thu Feb 21, 2019 1:59 am

"wpa_passphrase ssid password" certainly doesn't generate all those values, so "wpa_passphrase ssid password >> /etc/wpa_supplicant/wpa_supplicant.conf" and then editing the file to remove the commented plain text password and add the other fields must be what you meant.

af5bc
Posts: 6
Joined: Fri Jan 04, 2019 4:37 pm

Re: SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by af5bc » Thu Feb 21, 2019 3:51 am

That's correct. I generated the psk values with wpa_passphrase, and then tweaked the network parameters manually.

User avatar
KE0FHS
Posts: 722
Joined: Wed Apr 11, 2018 8:40 pm
Location: Colorado, USA
Contact:

Re: SOLVED - Can't get wifif to work with RPI 3A+ and Beta 4.0 RC3

Post by KE0FHS » Thu Feb 21, 2019 3:12 pm

af5bc wrote:
Thu Feb 21, 2019 3:51 am
That's correct. I generated the psk values with wpa_passphrase, and then tweaked the network parameters manually.
FYI, JP is the default country code because it has the broadest selection of channels. It's fine to leave that as is, no matter where you are located.
73, Toshen, KE0FHS
Playing with Pi-Star (unofficial notes about setting up and using Pi-Star):
https://amateurradionotes.com/pi-star.htm

Post Reply