Page 3 of 5

Re: Raspberry Pi 3A+ WiFi issue

Posted: Tue Oct 08, 2019 6:49 pm
by ea7gwc
There are definitely many boot problems
Wifi with pi3 a +.
The same works perfectly, but suddenly stops working wifi
at startup. 2.4 or 5ghz independent.
Once it starts well, it works perfectly.
The problem is at startup, with network interfaces.

73

Re: Raspberry Pi 3A+ WiFi issue

Posted: Tue Oct 08, 2019 8:38 pm
by KE0FHS
ea7gwc wrote:
Tue Oct 08, 2019 6:49 pm
There are definitely many boot problems
Wifi with pi3 a +.

The problem is at startup, with network interfaces.
Did you try flashing a fresh image of Pi-Star 4.1.0-RC4?

Re: Raspberry Pi 3A+ WiFi issue

Posted: Tue Oct 08, 2019 8:58 pm
by DB6BD
I have tested this on a Raspberry Pi 0W, 3B, 3A+, 3B+ and 4B. Toshen, I am looking forward to test one of your early 4B+ boards. ;)

Once I thought I have the same problem back, but that was due to a failure of my own, connecting the 3A+ to a computer USB instead of to the original RasPi power supply. Hooking it up to a screen via the HDMI interface revealed faulty boot up including low power warnings. After connecting back to the regular power supply, everything worked fine, again.

Kind regards,
Dennis

Re: Raspberry Pi 3A+ WiFi issue

Posted: Tue Oct 08, 2019 9:03 pm
by KE0FHS
DB6BD wrote:
Tue Oct 08, 2019 8:58 pm
I have tested this on a Raspberry Pi 0W, 3B, 3A+, 3B+ and 4B. Toshen, I am looking forward to test one of your early 4B+ boards. ;)
Whoops, I made a mistake. My board is a 4B. Sorry about that. I'll update my previous posts.

Re: Raspberry Pi 3A+ WiFi issue

Posted: Fri Oct 11, 2019 4:20 pm
by KE0FHS
OH NO! My RPI 4B-based hotspot failed to connect to my WiFi on first startup this morning. So even if this issue is reduced in severity, apparently it is not fully fixed.

Re: Raspberry Pi 3A+ WiFi issue

Posted: Fri Oct 11, 2019 8:47 pm
by DB6BD
I'll put my duplex HAT on my 4B to check and come back if I see the same issue.

Re: Raspberry Pi 3A+ WiFi issue

Posted: Sun Oct 13, 2019 4:36 am
by w7efs
DB6BD wrote:
Thu Aug 22, 2019 9:18 am
... But yes, using Raspbian, WLAN works without hickups, while in the Pi-Star 4.1.0 RC3 on my Raspberry Pi 3A+ hardware has issues connecting to my home WLAN. ...
Do the issues persist in RC6, please? Much development work has been contributed since RC3.

Re: Raspberry Pi 3A+ WiFi issue

Posted: Sun Oct 13, 2019 5:16 am
by DB6BD
Hi,

I haven't seen anymore issues since I started over with PiStar 4.1.0 RC4. Neither on my RasPi 4B, as Toshen.

Issues may derive from weak power supplies, too.

Kind regards,
Dennis

Re: Raspberry Pi 3A+ WiFi issue

Posted: Sun Oct 13, 2019 7:35 pm
by ea7gwc
Right now I have needed 3 ignitions, so that
The PI3 a+ start to operate the wifi.
4.1.0 RC6

73

Re: Raspberry Pi 3A+ WiFi issue

Posted: Sun Oct 13, 2019 9:16 pm
by KE0FHS
ea7gwc wrote:
Sun Oct 13, 2019 7:35 pm
Right now I have needed 3 ignitions, so that
The PI3 a+ start to operate the wifi.
4.1.0 RC6
This is such a strange issue. I have the most problems with the 3A+, but this morning, I had to power on my 4B hotspot four times before it would connect to my WiFi. A bit later, I powered on one of my 3A+ hotspots and it connected right away. On both of these hotspots, I started anew a week or so ago with a fresh 4.1.0-RC4 image and updated and upgraded to RC6. For a few days I had no problems whatsoever, so I thought that had solved this issue, but then it started happening again.