Wifi not working

Help setting up WiFi
KE7FNS
Pi-Star Team
Posts: 1823
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Thu Mar 25, 2021 12:52 am Is that hostapd?
Yes.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

KE7FNS wrote: Thu Mar 25, 2021 1:40 am
N2TDI wrote: Thu Mar 25, 2021 12:52 am Is that hostapd?
Yes.
Thank you
KE7FNS
Pi-Star Team
Posts: 1823
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Thu Mar 25, 2021 1:48 am Thank you
Whats the log say? invalid/unknown driver??

Code: Select all

grep hostapd /var/log/syslog
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

:x
KE7FNS wrote: Thu Mar 25, 2021 5:51 am
N2TDI wrote: Thu Mar 25, 2021 1:48 am Thank you
Whats the log say? invalid/unknown driver??

Code: Select all

grep hostapd /var/log/syslog
It says nl80211: could not configure driver mode deinit ifname=wlan0_ap disabled_11b_rates=0 driver initialization failed

I had read on the Armbian forum that there was some issues with the hostapd file and usb dongles.
KE7FNS
Pi-Star Team
Posts: 1823
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Thu Mar 25, 2021 12:17 pm It says nl80211: could not configure driver mode deinit ifname=wlan0_ap disabled_11b_rates=0 driver initialization failed

I had read on the Armbian forum that there was some issues with the hostapd file and usb dongles.
Yes.

I realize you want your old hardware to "just work" like it used too, but that doesn't appear to be possible anymore. (its not something Pi-star has any control over)

The AutoAP is only used once to configure your hotspot anyway, once you provide a valid network for it to connect to and it is always able to connect to that network it should never be needed again.

You said it works when you disable the AutoAP, so setup your network information either manually or using the wifi builder and be done with it. Then focus on upgrading your hardware that is somewhere between 9 to 5 years old.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
Post Reply