Wifi not working

Help setting up WiFi
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Wifi not working

Post by N2TDI »

I have 2 hotspots that I have upgraded to 4.1.4 and now the wifi dongle no longer works. When they were on 3.4.17 they worked fine, but not after the upgrade. Both see the ralink rt2800 and iwconfig and ifconfig reports both wlan0 and wlan0_ap but it will not scan for SSIDs and the auto ap never shows up. This worked fine on 3.4.17 si I don’t know if it’s a setting or there’s an issue in the new kernel...
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

If I turn off auto ap mode then the wifi will scan and find available SSIDs.
KE7FNS
Pi-Star Team
Posts: 1782
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Wed Mar 24, 2021 2:15 pm If I turn off auto ap mode then the wifi will scan and find available SSIDs.
Then leave auto AP mode off. There seems to be some incompatibility with the dongle and the auto AP. Use the wifi builder to setup your network if you can't access the dashboard.

You could also just get a newer RPi with built in wifi and do away with the dongle altogether.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

KE7FNS wrote: Wed Mar 24, 2021 5:18 pm
N2TDI wrote: Wed Mar 24, 2021 2:15 pm If I turn off auto ap mode then the wifi will scan and find available SSIDs.
Then leave auto AP mode off. There seems to be some incompatibility with the dongle and the auto AP. Use the wifi builder to setup your network if you can't access the dashboard.

You could also just get a newer RPi with built in wifi and do away with the dongle altogether.
Yes i can do either or both of those things, but i am using an approved dongle, so I thought there might be a fix for this issue.
KE7FNS
Pi-Star Team
Posts: 1782
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Wed Mar 24, 2021 5:56 pm Yes i can do either or both of those things, but i am using an approved dongle, so I thought there might be a fix for this issue.
The only way someone can come up with a fix is to research and identify exactly what the problem is. The problem is that requires the exact same hardware as you, both that brand of dongle and I assume a RPi 1, or 2 since they are the ones without wireless. I have a wifi dongle laying around here somewhere but I don't know which chipset it has.

You mentioned you thought it was a kernel issue, and that cannot be the case because you said it works when the AP is off. If it was a kernel issue it wouldn't work at all. I'm pretty certain the kernel detects it correctly, it is the AutoAP that is incompatible for some unknown reason.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

KE7FNS wrote: Wed Mar 24, 2021 7:26 pm
N2TDI wrote: Wed Mar 24, 2021 5:56 pm Yes i can do either or both of those things, but i am using an approved dongle, so I thought there might be a fix for this issue.
The only way someone can come up with a fix is to research and identify exactly what the problem is. The problem is that requires the exact same hardware as you, both that brand of dongle and I assume a RPi 1, or 2 since they are the ones without wireless. I have a wifi dongle laying around here somewhere but I don't know which chipset it has.

You mentioned you thought it was a kernel issue, and that cannot be the case because you said it works when the AP is off. If it was a kernel issue it wouldn't work at all. I'm pretty certain the kernel detects it correctly, it is the AutoAP that is incompatible for some unknown reason.
The chipset I have (Ralink rt2800) is stated to work with pi-star which it does in version 3.4.17, I guess something has changed in version 4.1.4 that it is no longer compatible.
KE7FNS
Pi-Star Team
Posts: 1782
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Wed Mar 24, 2021 9:25 pm The chipset I have (Ralink rt2800) is stated to work with pi-star which it does in version 3.4.17, I guess something has changed in version 4.1.4 that it is no longer compatible.
I agree something changed with the AutoAP software, but without the exact same hardware as you I cannot test it and find out exactly what it was or if a fix is even possible. I checked my USB wifi and it is a different chipset.

3.4.17 is no longer supported due to the OS no longer being maintained. It reached its End Of Life. The OS that 4.0 is on is also EOL, but Andy has extended support for it due to COVID and repeater site access, once that is lifted it will also no longer be supported.

I suggest you just spend 10 bucks on a RPi Zero W, or 25 on a RPi3 or 4, and you will no longer have a need for the dongle.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

KE7FNS wrote: Wed Mar 24, 2021 9:57 pm
N2TDI wrote: Wed Mar 24, 2021 9:25 pm The chipset I have (Ralink rt2800) is stated to work with pi-star which it does in version 3.4.17, I guess something has changed in version 4.1.4 that it is no longer compatible.
I agree something changed with the AutoAP software, but without the exact same hardware as you I cannot test it and find out exactly what it was or if a fix is even possible. I checked my USB wifi and it is a different chipset.

3.4.17 is no longer supported due to the OS no longer being maintained. It reached its End Of Life. The OS that 4.0 is on is also EOL, but Andy has extended support for it due to COVID and repeater site access, once that is lifted it will also no longer be supported.

I suggest you just spend 10 bucks on a RPi Zero W, or 25 on a RPi3 or 4, and you will no longer have a need for the dongle.
I just saw another post where the person had the exact same issue, but with a different yet previously compatible dongle on version 4.1.0 so it does seem something has changed.
KE7FNS
Pi-Star Team
Posts: 1782
Joined: Wed Apr 17, 2019 11:11 pm

Re: Wifi not working

Post by KE7FNS »

N2TDI wrote: Wed Mar 24, 2021 10:09 pm I just saw another post where the person had the exact same issue, but with a different yet previously compatible dongle on version 4.1.0 so it does seem something has changed.
Yes, what changed is the AutoAP software was updated.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:
N2TDI
Posts: 10
Joined: Tue Feb 12, 2019 3:03 am

Re: Wifi not working

Post by N2TDI »

KE7FNS wrote: Wed Mar 24, 2021 10:16 pm
N2TDI wrote: Wed Mar 24, 2021 10:09 pm I just saw another post where the person had the exact same issue, but with a different yet previously compatible dongle on version 4.1.0 so it does seem something has changed.
Yes, what changed is the AutoAP software was updated.
Is that hostapd?
Post Reply