Not receiving signal

Help with DMR issues
M1DNS
Posts: 424
Joined: Thu Apr 05, 2018 5:30 am

Re: Not receiving signal

Post by M1DNS » Fri Nov 29, 2019 12:51 pm


KE7FNS wrote:
Why are you transmitting on Local (1) talkgroup?


UK Ireland and most of EU still support reflector linking. In Calling up a reflector as a private call and talking through it using tg9 (BM) Tg8 (dmr+) and tg6 (XLX)

Many UK group's teach linking using reflectors rather than an actual Tg.

Sent using Tapatalk






Andrew M1DNS.
Pi-star Admin Team.

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: Not receiving signal

Post by KE7FNS » Fri Nov 29, 2019 7:04 pm

M1DNS wrote:
Fri Nov 29, 2019 12:51 pm
UK Ireland and most of EU still support reflector linking. In Calling up a reflector as a private call and talking through it using tg9 (BM) Tg8 (dmr+) and tg6 (XLX)

Many UK group's teach linking using reflectors rather than an actual Tg.
But he isn't connecting or connected to any reflectors....
All views, comments, posts and opinions shared are entirely my own.

M1DNS
Posts: 424
Joined: Thu Apr 05, 2018 5:30 am

Re: Not receiving signal

Post by M1DNS » Sat Nov 30, 2019 7:15 am

KE7FNS wrote:
But he isn't connecting or connected to any reflectors....


Reflector linking is a big thing here in the UK. Many sites and group's state 'all traffic via tg9'

that's where the confusion lies, being told all traffics on tg9

Which you and I know that wouldn't be correct with a static set for tg91. Or any Tg in fact. But when on the upcurve it's relatively simple to misread what's being taught and not knowing the differences between linking via TG's or via reflectors.


Sent using Tapatalk





Andrew M1DNS.
Pi-star Admin Team.

M6KFR
Posts: 48
Joined: Sun Jan 20, 2019 4:49 pm
Location: STAFFORD UK

Re: Not receiving signal

Post by M6KFR » Sat Nov 30, 2019 4:31 pm

As advised I have removed completely the existing code plug, set up a private call for 9990 keyed it up, although it shows up, I got no reply.
Where TG1 comes from I don’t know as I’ve never entered it to any code plug I’ve tried to use.
I have noticed the DMR drops out on my admin page, I’m on WiFi and not “hard wired” in, if I reboot it comes back in ? Is this anything to do with my selection of “radio type”? As you know Chinese hats all come with the usual lack of instructions.
Any ideas ?
Thanks
Gordon M6KFR

AF6VN
Posts: 278
Joined: Fri Jul 20, 2018 1:15 am

Re: Not receiving signal

Post by AF6VN » Sat Nov 30, 2019 5:44 pm

M6KFR wrote:
Sat Nov 30, 2019 4:31 pm
As advised I have removed completely the existing code plug, set up a private call for 9990 keyed it up, although it shows up, I got no reply.
Where TG1 comes from I don’t know as I’ve never entered it to any code plug I’ve tried to use.
I have noticed the DMR drops out on my admin page, I’m on WiFi and not “hard wired” in, if I reboot it comes back in ? Is this anything to do with my selection of “radio type”? As you know Chinese hats all come with the usual lack of instructions.
"Radio type" should have nothing to do with WiFi behavior -- it identifies the board handling the amateur band transmissions (and is the concern of MMDVM part of the software). WiFi is handled by the R-Pi running the Pi-Star software.

"DMR drops out" is vague... Do you mean "DMR Net" changes from green to red under "Network Status"? Or "DMR" under "Modes Enabled" is going red? Or "Trx" under "Radio Info" is going to just plain "Listening" instead of "Listening DMR"?

Note: if your hotspot is using WiFi for connections, a lost WiFi connection would also mean you would lose access to the dashboard. If "DMR Net" goes red, but you still have dashboard access, your problem is likely somewhere in your WiFi ROUTER or external path to the server dropping or blocking internet packets. Firewall settings on the router perhaps... I presume you aren't using some "public WiFi" node (anything goes with those -- traffic limiting, need to log-in to a web page to activate outgoing traffic connection, etc.)




An MD-380 shouldn't be that difficult to set up (and should be similar to my MD-390). I have some 20+ channels defined for my hotspot. All channels are identical except for the field "Channel Name" and "Contact Name".
  • TOT 180
  • Power Low
  • Admit Criteria Color Code
  • Color Code 1
  • Time Slot 2
  • Privacy None
  • In Call Criteria Always
{Of course, the hotspot is set to the same color code, and frequency is the same for all}

Channel name, obviously, is whatever serves to identify the channel.
Contact name is drawn from the list defined in "Digital Contacts" -- Primarily they are all "Group Call" with (first) the Mi5 (Michigan DMR repeater group) talk groups, followed by a collection of Brandmeister talk groups for use with the hotspot (Mi5 repeaters do not link out to Brandmeister, but Brandmeister does have a pair of talk groups that route to Mi5's Statewide 1 and 2). I also define an RX Group list which has all these hotspot/BrandMeister contacts -- each channel then is configured to that group list. This allows inbound traffic on any of the configured BM talkgroups (if static, or not a timed out dynamic) to be heard, with the group identified. To talk on that group does require one to dial up the proper channel.



Your very first post states that the radio used to work with the hotspot -- then after a gap of non-use, stopped functioning. If you hadn't made changes to the radio configuration, that means something in either the hotspot, the router, or downstream changed.

--
AF6VN
Dennis L Bieber

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: Not receiving signal

Post by KE7FNS » Sat Nov 30, 2019 6:05 pm

M6KFR wrote:
Sat Nov 30, 2019 4:31 pm
As advised I have removed completely the existing code plug, set up a private call for 9990 keyed it up, although it shows up, I got no reply.
Your BM page shows the hotspot correctly receiving your attempt at connecting to 9990.

Code: Select all

3 Hours	2721	GB M6KFR [GORDON] (2343853)	 Parrot (9990)	 	  S9+40dB	5
In your dashboard, you should be seeing a RF connection (while you are keyed up), and then a network connection shortly after you unkey.

So what that means is our radio is simply not programmed correctly. You don't have it set to listen to the response. You can do this a number of different ways, the easiest is to just turn on promiscuous mode that way your radio will always listen to every transmission, no matter which group is is from. But again the issue you are having of not hearing the parrot is because the radio is not programmed to listen to the transmission from the hotspot from the 9990 group. In your codeplug there should be an area for a "receive group list" or something similar where you can specify which group that channel is supposed to listen to, you need to set it to listen to 9990.

On my radio I have a monitor button that I can hold in to temporarily enable promiscuous mode.
M6KFR wrote:
Sat Nov 30, 2019 4:31 pm
Where TG1 comes from I don’t know as I’ve never entered it to any code plug I’ve tried to use.
I don't know either, so it must be some default.
M6KFR wrote:
Sat Nov 30, 2019 4:31 pm
I have noticed the DMR drops out on my admin page, I’m on WiFi and not “hard wired” in, if I reboot it comes back in ? Is this anything to do with my selection of “radio type”? As you know Chinese hats all come with the usual lack of instructions.
Not sure what "drops out" means, but as far as the radio type, no, that doesn't really matter all that much.
All views, comments, posts and opinions shared are entirely my own.

M6KFR
Posts: 48
Joined: Sun Jan 20, 2019 4:49 pm
Location: STAFFORD UK

Re: Not receiving signal

Post by M6KFR » Sat Nov 30, 2019 6:14 pm

Many thanks for you very informative answer
By DMR dropping out I meant it goes from green to red on occasions, or it’s red at start up.
I hadn’t thought of a router problem I will try changing back to my older one that I know works ok.
I also thought it was important to select the correct radio type/‘top hat’ setting in configuration.
Many thanks for the clear precise md380 program procedures it’s(I’m ashamed to say) shown me where I may of gone wrong.
Another mistake I made was formatting over my working DMR set up when I saw V4 of pi=star had been released.
Whilst I was able to set up dstar and ysf with minimum fuss I have to admit I am flummoxed with DMR.
Still it’s fun learning as I go along.
My thanks to you and everyone who has suggested solutions... I’m only surprised no one has said give up.... (-;.
Gordon M6KFR

KE7FNS
Posts: 441
Joined: Wed Apr 17, 2019 11:11 pm

Re: Not receiving signal

Post by KE7FNS » Sat Nov 30, 2019 6:39 pm

I'm not sure what would be causing the green to red situation but it could be a number of things that are out of your control.

The good news is, your hotspot appears to be working correctly (when it stays green), so I see no reason to "give up" now.

I'm pretty sure once you figure out how to get the radio to listen to the parrot group, then you'll be able to apply the same settings to another group like 91, 92, 93, and you'll be off and talking to everyone around the world.
All views, comments, posts and opinions shared are entirely my own.

AF6VN
Posts: 278
Joined: Fri Jul 20, 2018 1:15 am

Re: Not receiving signal

Post by AF6VN » Sat Nov 30, 2019 8:02 pm

KE7FNS wrote:
Sat Nov 30, 2019 6:05 pm
So what that means is our radio is simply not programmed correctly. You don't have it set to listen to the response. You can do this a number of different ways, the easiest is to just turn on promiscuous mode that way your radio will always listen to every transmission, no matter which group is is from. But again the issue you are having of not hearing the parrot is because the radio is not programmed to listen to the transmission from the hotspot from the 9990 group. In your codeplug there should be an area for a "receive group list" or something similar where you can specify which group that channel is supposed to listen to, you need to set it to listen to 9990.
Unless the OP is running 3rd party firmware in the radio, the MD-380/390 do not have "promiscuous mode".



I also just tried a test with my MD390, using the menu system to add a new contact "9990 / Parrot" (and then had to figure out how to use contacts for sending). I'd already had a channel configured as BM TG 9 (which I never used as US BM doesn't use reflectors). That got me out of the group with actual traffic (US Nationwide is my normal space).

With "Parrot" highlighted* in the contact list, PTT and mumbling my call sign produced (hard to cut&paste since the page keeps refreshing)

Code: Select all

Local RF Activity
Time (EST) 	 	Mode 	Callsign 	Target 	Src 	Dur(s) 	BER 	RSSI
14:02:31 Nov 30th	DMR Slot 2	AF6VN	9990	RF	5.8	0.4%	
and releasing PTT then resulted in

Code: Select all

Gateway Activity
Time (EST) 	 	Mode 	Callsign 	Target 	Src 	Dur(s) 	Loss 	BER
14:02:40 Nov 30th	DMR Slot 2	9990	AF6VN	Net	6.6	10%	0.0%
14:02:31 Nov 30th	DMR Slot 2	AF6VN	9990	RF	5.8	0%	0.4%
(and yes, I did hear my mumble)
Note that my radio was still set for a channel using BM TG 9, and if I were to PTT again, the dashboard would show TG 9 rather than 9990. The private call to 9990 only holds while the screen is on the contact list. I have no channel configured for 9990. I don't know if the group/private hang time settings in the radio affect it. I did not try using a different talk group -- as I understand it, TG 9 acts as a "local" by most repeaters, meant for use when a reflector has been activated -- so should not have any interfering traffic on a hotspot with no active reflectors.

So -- again presuming the MD-380 is similar to my MD-390.
Have a CHANNEL configured for Group type contact TG 9 (and located in some zone) and hotspot frequency
Have a Private type contact "Parrot" 9990 (suggest either first or last contact in list) (OR "manual dial")
Select the zone and TG 9 channel
{optional, may not be needed: PTT to activate TG 9 on BM<>hotspot}
Menu button; Contacts confirm; 1 Contacts confirm; ^ or v to find Parrot contact; with Parrot highlighted: PTT and make some short announcement ("manual dial" could be used here).
Release PTT; should hear announcement repeated back.

I did NOT have to add Parrot/9990 to any receive group list (In fact, since I added Parrot/9990 using the radio "New Contact" menu I could NOT add it to any group list -- that function is not available in the radio itself), nor create a channel dedicated to that contact.



* this is what took me a while to figure out... Selecting "Parrot" and hitting "Confirm" was NOT the action to take; just selecting and PTT is what worked for private call. "Confirm" brought up a sub-menu and "call alert" just made the radio blip the TX and listen for a responder -- not enough to activate the hotspot even. Same problem with "Manual Dial" -- one does not want to "confirm" after entering the 9990; instead just PTT while the entry page is showing.

--
AF6VN
Dennis L Bieber

M6KFR
Posts: 48
Joined: Sun Jan 20, 2019 4:49 pm
Location: STAFFORD UK

Re: Not receiving signal

Post by M6KFR » Tue Dec 03, 2019 11:48 am

Hi
Pleased to say DMR is up and running (-:
Not only my code plug but an actual fault on my phone line caused many headaches.
BT came out and fiddled about with local j.b. Reslotting my line ? And I have no more problems connecting up to pi-star.
Who ever suggested that I link up to 9990 check that works and build up from there is a star !
Many thanks to all who gave helpful hints and tips.
Linking to Ireland was a major key, why I can’t use the U.K. is a mystery .
So thanks one and all
73
Gordon M6KFR

Post Reply