Cannot connect to Brandmeister network

Help with DMR issues
G8SEZ
Posts: 196
Joined: Fri Apr 13, 2018 8:26 pm

Re: Cannot connect to Brandmeister network

Post by G8SEZ » Fri Jul 31, 2020 11:07 am

Interesting, I had not read that bit in detail before. I don't know what the effect of switching clocks would be on the mmdvmhost, it might not like it. a sudden clock frequency/phase jump might upset the UART on the RPi. If you look at the HSI frequency accuracy on page 56 you will see it can vary up to 2% or a little more. No idea if the user calibration register is in use, but even with that it could be 1% in error.

There's no doubt that the STM32F10x CPUs are clever little beasts, I had not appreciated how much flexibility they offer.
--

Brian G8SEZ

G4TVP
Posts: 26
Joined: Mon Feb 03, 2020 11:30 pm

Re: Cannot connect to Brandmeister network

Post by G4TVP » Fri Jul 31, 2020 3:26 pm

The new MMDVM HAT has arrived this afternoon, just soldered on the SMA socket and it appears to be working :D

Hooray!

G4TVP
Posts: 26
Joined: Mon Feb 03, 2020 11:30 pm

Re: Cannot connect to Brandmeister network

Post by G4TVP » Fri Jul 31, 2020 6:47 pm

Had a bit of time to play and now have BM connection backup and working.

Just wanted to say a big thank you to all that have helped.
73s Mike

G8SEZ
Posts: 196
Joined: Fri Apr 13, 2018 8:26 pm

Re: Cannot connect to Brandmeister network

Post by G8SEZ » Fri Jul 31, 2020 6:53 pm

G4TVP wrote:
Fri Jul 31, 2020 6:47 pm
Had a bit of time to play and now have BM connection backup and working.

Just wanted to say a big thank you to all that have helped.
73s Mike
Good. Now you can work out what's wrong with the other one at your leisure.
--

Brian G8SEZ

KE7FNS
Posts: 852
Joined: Wed Apr 17, 2019 11:11 pm

Re: Cannot connect to Brandmeister network

Post by KE7FNS » Fri Jul 31, 2020 7:17 pm

G8SEZ wrote:
Fri Jul 31, 2020 11:07 am
Interesting, I had not read that bit in detail before. I don't know what the effect of switching clocks would be on the mmdvmhost, it might not like it. a sudden clock frequency/phase jump might upset the UART on the RPi. If you look at the HSI frequency accuracy on page 56 you will see it can vary up to 2% or a little more. No idea if the user calibration register is in use, but even with that it could be 1% in error.

There's no doubt that the STM32F10x CPUs are clever little beasts, I had not appreciated how much flexibility they offer.
Yeah, I don't know exactly what it would do in that situation either, and don't feel like peeling off a crystal to find out. From what I gathered on the ST forum the HSI is accurate enough that UART communications are still possible even with that 2% error.

I wish I was able to get an inline debugger to work so I could step through this thing and really dive into the inner workings.
G4TVP wrote:
Fri Jul 31, 2020 6:47 pm
Had a bit of time to play and now have BM connection backup and working.
Interesting.

I'm curious if your still getting those overflow messages in the log cept now it isn't breaking the communications, similar to what I experienced a few months ago.

Code: Select all

grep -i overflow /var/log/pi-star/MMDVM-2020-07-31.log
Either way glad you are happy with it working.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol:

G4TVP
Posts: 26
Joined: Mon Feb 03, 2020 11:30 pm

Re: Cannot connect to Brandmeister network

Post by G4TVP » Fri Jul 31, 2020 7:23 pm

Nope, no "overflow" messages in the log or any other errors indicating any sign of problems.

I think working out what was up with the other board, will wait until next week. I am enjoying listening to TG91 in the meantime :)

Post Reply