Non-Latch of Repeater to the Network.

Help with DMR issues
Post Reply
F5VMR
Posts: 35
Joined: Thu Apr 12, 2018 6:08 am

Non-Latch of Repeater to the Network.

Post by F5VMR »

This is a difficult one to describe, as it is not a fault per se, but an anomaly that is requiring a further investigation.
From time to time a transmission I make to the MMDVM Repeater in DMR, gets the require Ack-Tone, but when I view the dashboard, the transmission is not showing. So I have dropped key, and re-tried getting the same Ack-tone, but this time the transmission proceeds to the network normally.

Code: Select all

M: 2021-09-06 09:31:14.448 Downlink Activate received from G4NAB
M: 2021-09-06 09:31:14.453 Debug: Mode set to DMR
M: 2021-09-06 09:31:14.940 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 6 800
M: 2021-09-06 09:31:14.944 DMR Slot 2, received RF voice header from G4NAB to TG 2352
M: 2021-09-06 09:31:15.000 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 9 799
M: 2021-09-06 09:31:15.060 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 15 799
M: 2021-09-06 09:31:15.120 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 5 796
M: 2021-09-06 09:31:15.480 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -2 792
M: 2021-09-06 09:31:15.840 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 2 789
M: 2021-09-06 09:31:16.200 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -11 786
M: 2021-09-06 09:31:16.560 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -7 786
M: 2021-09-06 09:31:16.920 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 7 785
M: 2021-09-06 09:31:17.280 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -5 785
M: 2021-09-06 09:31:17.640 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -1 785
M: 2021-09-06 09:31:18.000 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -4 784
M: 2021-09-06 09:31:18.360 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -12 783
M: 2021-09-06 09:31:18.720 Debug: DMRSlotRX: voice terminator found slot/pos/centre/threshold 2 450 6 785
M: 2021-09-06 09:31:18.726 DMR Slot 2, received RF end of voice transmission from G4NAB to TG 2352, 3.6 seconds, BER: 0.0%
M: 2021-09-06 09:31:20.160 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 8 798
M: 2021-09-06 09:31:20.169 DMR Slot 2, received RF voice header from G4NAB to TG 2352
M: 2021-09-06 09:31:20.220 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 14 795
M: 2021-09-06 09:31:20.280 Debug: DMRSlotRX: voice header found slot/pos/centre/threshold 2 450 20 797
M: 2021-09-06 09:31:20.340 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 14 793
M: 2021-09-06 09:31:20.700 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -7 789
M: 2021-09-06 09:31:21.060 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -17 787
M: 2021-09-06 09:31:21.420 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -25 781
M: 2021-09-06 09:31:21.780 Debug: DMRSlotRX: voice sync found slot/pos/centre/threshold 2 450 -14 780
M: 2021-09-06 09:31:22.140 Debug: DMRSlotRX: voice terminator found slot/pos/centre/threshold 2 450 20 783
M: 2021-09-06 09:31:22.146 DMR Slot 2, received RF end of voice transmission from G4NAB to TG 2352, 1.8 seconds, BER: 0.0%
M: 2021-09-06 09:31:27.087 Debug: DMRIdleRX: data sync found centre/threshold -110 838
M: 2021-09-06 09:31:27.098 Downlink Activate received from G4NAB
M: 2021-09-06 09:31:27.483 Debug: Mode set to Idle
M: 2021-09-06 09:31:27.585 Debug: DMRIdleRX: data sync found centre/threshold 7 788
M: 2021-09-06 09:31:27.645 Debug: DMRIdleRX: data sync found centre/threshold -21 791
M: 2021-09-06 09:31:27.705 Debug: DMRIdleRX: data sync found centre/threshold 2 793
M: 2021-09-06 09:31:39.285 Debug: DMRIdleRX: data sync found centre/threshold 92 782
M: 2021-09-06 09:31:44.692 Debug: Mode set to DMR
M: 2021-09-06 09:31:47.692 Debug: Mode set to Idle
This is an extract from the log at a point where I made three consecutive transmissions on TG2352. The first two were acknowledged and continued with Voice Sync, but the final transmission the voice header and sync was not interpreted. Although the Ack-Tone was heard.

Are any other MMDVM Users experiencing the same symptoms and is there a solution? The board in use is a ZUM-Radio Repeater Board in a Tait Repeater. The radio type is Chinese, but I've noticed these symptoms on all the radio's I possess, both portable & mobile. The settings for the Pi-Star are standard.
Last edited by KE7FNS on Mon Sep 06, 2021 6:11 pm, edited 1 time in total.
Reason: Next time use a [code] [/code] block on lengthy log postings.
KE7FNS
Pi-Star Team
Posts: 2077
Joined: Wed Apr 17, 2019 11:11 pm

Re: Non-Latch of Repeater to the Network.

Post by KE7FNS »

F5VMR wrote: Mon Sep 06, 2021 9:38 am Are any other MMDVM Users experiencing the same symptoms and is there a solution?
My guess is it is an issue with the firmware not responding fast enough, or its in the middle of a cycle and has to wait for the next go around. Another issue is adding the debug information causes delays, so you should test in standard operation without the debug flag enabled in both the software and firmware. Those extra messages are extra data that takes up time.

You should probably contact the board manufacturer and ask them if they have any ideas or solutions. You could also post an issue report on the MMDVM firmware github and see if someone can recreate your issue. https://github.com/g4klx/MMDVM

You might also have better luck asking over on the repeater builder forums as that group has more users actively using repeater boards, whereas this forum has more hotspot users than repeater users.
If someones previous actions are any indication of their future actions, then I predict the deletion and removal of access will happen at any moment. 7-11-2020.

"07/13/20 This Website Has Been Taken Down" ... again :lol: and again
F5VMR
Posts: 35
Joined: Thu Apr 12, 2018 6:08 am

Re: Non-Latch of Repeater to the Network.

Post by F5VMR »

Indeed I had one Debug switch on true so I have changed that. I will give another test period before I take it further. I know I'm not the only one with this issue.
Post Reply