Cannot get my mmdvm to acknowledge my DMR radios.

Help with DMR issues
Post Reply
w9mt
Posts: 19
Joined: Mon Jul 15, 2019 2:40 pm

Cannot get my mmdvm to acknowledge my DMR radios.

Post by w9mt » Wed Jul 17, 2019 9:54 pm

I'm likely missing something very obvious.

I've been running DMR on my Shark openSPOT 1's for over two years without issue. I can successfully switch modes to YSF and D-Star and also run them without issue on the OS1. This works with all three "flavors" of radios and radio modes.

I now want to run multiple mmdvm's simultaneously (one for each of the 3 modes) on widely spaced RF frequencies. I've been bringing up each mmdvm individually. Unit 0 runs YSF down near 431MHz and works fine. Unit 1 runs D-Star near 438 MHz and also works fine. They also peacefully co-exist and I can run both mmdvm's in a combination of T&R for YSF and D-Star without issues.

DMR on the mmdvm has been a real puzzle for me. I have my DMR "Unit 2" mmdvm running near 446 MHz. I've left most of the defaults set to their original values in Pi-Star. The only exceptions are the RX and TX Offsets (which are to be set to +500 per the supplier), and RF Level (this was reduced from 100 down to 10 on all 3 of my mmdvms to minimize desense). I've double checked my radio name (my callsign: W9MT) and my DMR ID is the same in my radio and in my mmdvm's Pi-Star settings. I've even changed my access criterion in my radio's channel information from Color Code to Always. I am using CC1 and Slot 2 in Pi-Star and my radio, just like the guys in the YouTube videos. I also changed my Node Type from Public to Private like I saw someone do on YouTube. In Configuration, Control Software is set to mmdvmHost and Simplex. All of these attempts to achieve DMR communications have failed miserably.

Here's the crux of the problem... Unlike the YouTuber's, my mmdvm won't display DMR mode when I key up my radio and dynamically allocate a TG. The mmdvm simply ignores me. On the Dashboard page of the Pi-Star web interface Mode Enabled shows DMR as green; Network Status shows DMR Net as green; DMR Repeater shows my correct DMR ID, and CC1 and TS2 enabled. Most troublesome is that I never see the Radio Info Trx box light up when I depress PTT on the radio, and also "No TG/No Ref" is displayed near the bottom left on the Dashboard. The simplex RF frequency in the mmdvm matches that in the channel information in my radios.

I know the hardware in the mmdvm is good. If I swap the SDHC chips configured for YSF and D-Star, both of those modes work great in this 3rd mmdvm. Plus, with the DMR configured SDHC chip in Unit2, I can go to the Brandmeister website and make some TG's as Static. This does make the mmdvm receive on those TG's (e.g.: 91 and 3100), and I can hear the audio on my radios. I use server 3101 or 3102. Both work in Static TG rx only.

I am not using TG9 as my Receive group entries like I know I had to on the OS1. I have my Rx Group entry the same as the Digital Contact for that Zone and Channel entry.

Hints are very much appreciated.

I have 3 of the popular DMR radios: TYT MD-380 (UHF), Radioddity GD-77, and Radioddity/Baofeng RD-5R. If someone could clue me in on codeplugging a couple of TG's in any of the 3 above radios and what mmdvm/Pi-Star settings would be known to work with those radio settings...THAT WOULD BE OPTIMAL.

I've been figuratively banging my head on this mmdvm/DMR impasse for a couple of weeks already. What am I doing wrong?

w9mt
Posts: 19
Joined: Mon Jul 15, 2019 2:40 pm

Re: FIX FOUND...Cannot get my mmdvm to acknowledge my DMR radios.

Post by w9mt » Thu Jul 18, 2019 3:57 am

After my original posting I found that several others have had similar problems in getting their mmdvm's to respond to their DMR handhelds.

Others found success by adjusting the RxOffset and TxOffset in Expert mode to as much as 2500 from the nominal Pi-Star settings. (I assume this is 2500 Hz.) This did not work for me.

Quite by accident I adjusted the RxDCOffset and TXDCOffset from their nominally zero values to about 700. My mmdvm abruptly began working, responding well to my MD-380's PTT commands. I found that an RxOffset and TxOffset both at zero (supplier recommended +500 for each) and the TxDCOffset and RxDCOffset at 700 gave me a BER of 0.2% or less with reliable operation via the radio.

I just wish that a description of what each "diddling-point's number" actually does would actually be available. I have been unable to find such a set of descriptions. I don't like "shooting in the dark" and I also don't believe that both Rx and Tx settings for the four parameters really track each other as "two pairs", Tx and Rx.

But, I'm happy I've got this working...

I am going to assume that the RxDCOffset and TxDCOffset are an analog DC Offset pair that centers the voice data stream more symmetrically within the encoder/decoder chip. Perhaps the 700 is in units of milliVolts.

I'd feel a lot more comfortable having test points to probe and a trace to look at on an o'scope to tweak this in optimally. What do the forum's readers think? :D :D :D

KC3OCO
Posts: 1
Joined: Sun Dec 22, 2019 8:50 pm

Re: Cannot get my mmdvm to acknowledge my DMR radios.

Post by KC3OCO » Mon Dec 30, 2019 12:47 am

I had a similar problem. My Pi-Star Hotspot came with a tag that listed the Tx & Rx offsets at +0.500. Wouldn't work, although leds on MMDVM board would light when I PTT'd.

I adjusted to 0, 0 to test and it worked. My final adjustment was actually +0.25 resulting in a BER of 0.1% or so.

Bottom line, take the Tx and Rx offsets they provide with a grain of salt.

Thanks for your post, it helped flag me to try changing the Tx & Rx offsets and not waste a lot of time chasing down other potential causes.

EA3BIL
Posts: 60
Joined: Tue Apr 17, 2018 11:45 pm

Re: Cannot get my mmdvm to acknowledge my DMR radios.

Post by EA3BIL » Sat Feb 01, 2020 10:52 pm

"Grain of salt" or the hole salt pot if the TCXO is 12.8Mhz.
'Cause they show quite unstable (at least for my drama experience with an "german mmdvm board").

Post Reply