DMR Fails after 20191016 Update

Help with DMR issues
Post Reply
User avatar
K1IMD
Posts: 13
Joined: Thu Apr 12, 2018 2:42 am
Location: Long Island, NY USA

DMR Fails after 20191016 Update

Post by K1IMD » Mon Oct 21, 2019 5:00 am

I have built about 20 mmdvm repeaters and at one time or another they have or are running Pi-Star. I presently have 6 mmdvm repeaters on the air. The one in question at the moment is at our second home 1800 miles away from home which I am visiting for the next couple days.

The repeater was made from a pair of UHF CDM1550LS+ radios, RPi 2B and a ZUM Radio ver 1.01 MODEM USB, DUE it has worked flawlessly for over a year. To standardize equipment to allow a buddy to service the repeater if necessary I swapped out a working, preconfigured RPi 3B, ZUM radio ver 0.9 MODEM HAT and it did not work. In the process Pi-Star updated to 20191016 which I did not notice at first. I took a backup older version from 10 months ago and burned the SDCard and it worked which was version 3.4.16. Next I created a new SDCard from scratch using V4.1.0-RC4 and it worked fine with the July update. I ran the update... BOOM it stopped working.

Now not working means that the portable does not hand shake with the repeater. My Motorola SL300 never works in the failed mode but my CS750 does sometimes. However, often requiring a second or third PTT to pass traffic even though every time you get the talk permit tone. It does not matter which version old or new, after the update of the RPi I see this issue.

I will only be here for a couple more days. How can I either roll back or stop the updates until the problem can be resolved? I will be another year before I visit his site again but I do have a VPN and ssh access when not on site. Rebuilding another card remotely is not possible. This weekend when I return home I will have to see what has happened to the 5 mmdvm repeaters. I only run DMR no other modes are enabled.

What can I do?

73
Jon
K1IMD

PS - One more Hint - The Motorola SL300 does not decode audio in the failed mode but the CS750 seems too.
73!
K1IMD

KE7FNS
Posts: 422
Joined: Wed Apr 17, 2019 11:11 pm

Re: DMR Fails after 20191016 Update

Post by KE7FNS » Mon Oct 21, 2019 6:56 am

K1IMD wrote:
Mon Oct 21, 2019 5:00 am
I ran the update... BOOM it stopped working.
When you say you ran the update, what exactly do you mean?

you ran "sudo pistar-update" or "sudo pistar-upgrade" or both??

Since you changed MMDVM modem hats, did you check to see if the TX/RX offset is anywhere near where it needs to be on the different modem? Every hat is going to have its own settings so your older settings might be way off. I'd double check it with MMDVMCal.

Are you running the latest firmware for the different hat?

It seems more like a frequency offset issue than a software issue to me, since you say one radio works sometimes.
All views, comments, posts and opinions shared are entirely my own.

User avatar
K1IMD
Posts: 13
Joined: Thu Apr 12, 2018 2:42 am
Location: Long Island, NY USA

Re: DMR Fails after 20191016 Update

Post by K1IMD » Mon Oct 21, 2019 1:00 pm

Good Morning KE7FNS,
The update was run from the GUI which only updates pi-star and not the OS.

I changed both the RPi and the MODEM and was working on a similar system before I installed it on the pair of radios in question.

I think you missed the point that when I created a new SDCard from scratch using the same configuration files from the backup it worked fine. Only after running the update from the GUI did it stop working. None of the configuration, offset, audio levels etc. should have any impact because all I did was update the pi-star files from the GUI.

Why would two radios work fine with low or no BER yet after the update one does not hand shake at all and the other it temperamental?

This is a mystery to me.

73
Jon
K1IMD

KE7FNS
Posts: 422
Joined: Wed Apr 17, 2019 11:11 pm

Re: DMR Fails after 20191016 Update

Post by KE7FNS » Mon Oct 21, 2019 9:26 pm

I don't know.

It looks like there was a recent update to the MMDVMHost binary, but I don't see any recent changes to the MMDVMHost source code that have anything to do with DMR changes. I also don't know what version of MMDVMHost the older pi-star was using either, the documentation on things like that do not exist.

https://github.com/AndyTaylorTweet/Pi-S ... 40385c46aa

I'll snag the old MMDVMHost file out of the Pi-Star_RPi_V4.1.0-RC4_27-Aug-2019.zip image, and send it to you in a PM and you can use something like winscp to copy it remotely. Then you'd need to disable the nightly updates so it doesn't get overwritten with the new version that you've experienced doesn't work.

I'd leave a backup copy of MMDVMHost in the home dir on the RPi, just in case.
All views, comments, posts and opinions shared are entirely my own.

User avatar
K1IMD
Posts: 13
Joined: Thu Apr 12, 2018 2:42 am
Location: Long Island, NY USA

Re: DMR Fails after 20191016 Update

Post by K1IMD » Tue Oct 22, 2019 5:04 am

Problem discovered - In the update this week MMDVMHost was updated. By copying over MMDVMHost with an earlier version fixes the problem. Apparently something is up with the updated file. Since I am away from home with limited tools special thanks for KE7FNS for getting me the stuff I needed. Life is good! 😁 73 Jon K1IMD
73!
K1IMD

Post Reply